Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Windows 10 - port issues - multiple arduino installs
I was having problems installing repetier on my Da Vinci 2.0A board.  I had already flashed it and there is no way back for the j37 motherboard.  Every time I loaded the repetier FW the computer no longer recognized the port.  Windows 10 would disconnect then reconnect then disconnect etc etc, the port saying device was unrecognized.  I believe this was because of the fact that somewhere along the line I deleted the printer profile.  Maybe not.  I spent 3 days trying to make it work as per instructions on github.  I used several versions of arduino but none would compile a sketch.  I was getting pretty desperate.

 I needed drivers for the printer and windows was no help. I decided to revert to the the davinci FW.  I found a copy of it for the jp1 motherboard online, along with Da Vinci's installer.  I used this to load it on my printer, although it would not work on my printer it would allow me to run the DaVinci install disk. 

When I ran the install disk it first installed a version of framewok necessary for the printer then it installed the drivers and xyzware. 

So now I tried to get arduino to work again but it still would not compile.  I got an error message pertaining to missing files in the c:\users\yourname\appdata\local\arduino15\packages\arduino\sam folder.  As I had multiple installs it had listed each in a separate subfolder.  I copied the contents of the subfolder directly to the sam folder and that did it.  I was able to compile the sketch and load it to my printer.  I am now working on leveling the bed.

I've read several posts about the port being unrecognized after installing the firmware.  I hope this helps someone.  Also If desired I have the binary file for Da Vinci  2.0A  2 Fans  if needed I will put it on my dropbox and make it available as soon as I have solved the bed issues I am now working on.

Forum Jump:

Users browsing this thread: 1 Guest(s)