Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Filament Resetter: Is Mine OK?
#1
Hi all,

My apologies for the long post, but I'm looking for some assistance, and reassurance that I am not doing damage to anything...  If you're Arduino-minded, please give this a read, and post a reply.  Also, I know next to nothing about electronics, and this is the first time I have dabbled with Arduinos, so please forgive my ignorance if the below is nothing I should worry about.  Undecided

I've built a filament resetter, based on the information found here, and other places on the web, as I've got quite a few "empty" XYZprinting cartridges that have filament in them begging to be used.

It does the job, and resets cartridges to 120m MAX, 120m available, but the LEDs do not behave like the LEDs in other instructions.

The board is a Duionotech Nano, V3.0, which has pins, and a mini-USB adapter, from which it can draw power, and transmit and receive data.

I'm using the EEPROM.ino file from Voltivo, and flashed it to the chip using the current Arduino IDE software.  The software recognises the Nano as an Arduino Nano (it is advertised as being fully compatible with such).

When I connect the board to a powered mini-USB cable, two things happen: the blue PWR (power) LED comes on solid, and the white LED to the right of the PWR LED starts flashing. This LED is simply labelled as "L", and I don't know what it represents.  Huh

When the pins contact the plates on the cartridge, the "L" LED goes solid, and remains so, as long as the connection is maintained, until I press the button on the board.

When the button is pressed, the "L" LED and the TX LED start flashing in unison.  After a few seconds, the TX LED stops flashing, but the "L" LED continues to flash, even after the connection is broken.

My cartridge is now reset, as detailed above.  Smile

My questions are these: 

1). Do I need to be worried about the "L" LED flashing all the time, or is this just a byproduct of using a Nano board instead of a Mini?  Huh

2). Also, even though the cartridges read as being 120/120, will they work with my unmodified da Vinci 1.0, which is not firewalled?  That is, if I use these cartridges, and I receive a firmware or software update, will this reset somehow brick my machine or cartridges?   Exclamation

If you're still reading this, and you need more information, please let me know in the comments below, and I'll try to provide it.  Big Grin 

Thanks in advance,


Jeff
Reply
#2
Hi all,

I know it is bad form to reply to my own post, but I have more to add to the above.

I tried to flash the chip on one of my newer cartridges (the ones that can be taken apart easily, and have the white plastic cylinder in the middle) this morning, and it appeared to work OK.

When I went to print with the cartridge, I got an error message to say there was a fault with the cartridge.

So I flashed another of my newer cartridges.

I turned the machine off and back on, and tried both cartridges again, and got the same error.

I flashed one of my older cartridges, and tried it, and it worked fine.

Has XYZ added something to the chip on the newer cartridges, that prevents the current version of the EEPROM.ino on this site from successfully resetting?  Or am I encountering some other problem?

Also, is there a more recent version of the EEPROM file, than what is list on this site?

Cheers,


Jeff B
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)