Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Firmware upgrade failed, USB device says VID_0000&PID_0002
#1
On a new Duo 2.0A, attempted firmware upgrade. Was able to build and upload the firmware successfully (including doing the two file copies and changing the Configuration.h file). After compiling/uploading, where I saw the upload and verify process run, and then the message that the printer was rebooting ... the printer never made it to a successful boot (two black bars). I also got a "USB device not recognized" message on my W10 laptop. When looking in Device Manager, the vendor ID is 0000 and the product ID is 0002 - which I believe is why the device isn't recognized.

I have tried all the basic things recommended on other threads - including powering down/up the printer and laptop, removing the device from device manager and rebooting the machine, removing and reinstalling the IDE, trying a different cable, trying different USB ports, resetting the chip (multiple times), installed Atmel to see if their drivers would help, and tried connecting to a different computer (a Mac). None of the above helps.

Anybody have any other suggestions on why my USB device is reporting an unknown device and what I might do about it?

Thanks in advance for any help!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)