Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Da vinci 1.0A stops printing randomly running repetier .92
#1
I have been running Repetier .92 for 2 month's now and i realy like being able to make adjustment to all the setting's so now i have the printer printing well but only printing small test parts with around 3-400 lines of gcode, iam now trying to print larger parts with hundreds of lines of gcode and the printer just randomly stops during printing the LCD says idle and the host say's waiting no error codes and i cannot get the printer to respond unless i reboot it and the repetier host program tried all the windows setting's for sleep ETC baude rate is correct nothing seams to make a difference don't know what to do from here any help is greatly appreciated thanks.
Reply
#2
Try printing your file from the SD card. If that works then your problem is likely to be the USB cable or computer. If sdcard printing does not work then I would suggest trying an UPS supply, as you could be experiencing a power glitch. Also, make sure there are no words near the thermistor or heater that are bare and possibly shorting add this will also cause a reset.

Kieth
Reply
#3
recently there was a fix pushed for this behaviour - it is not yet in original repetier, neither davinci fork as I was waiting for more test feedback in pull conversation as I do not use USB at all

in line 1012 of hal.cpp change

HAL::allowInterrupts();


by

noInt.unprotect();

PR is there: https://github.com/repetier/Repetier-Fir...les#diff-0
Reply
#4
Quote:in line 1012 of hal.cpp change

HAL::allowInterrupts();

I'm also having a lot of USB communication issues since moving to Repetier and was looking to make this change. Then saw that allowInterrupts() actually does nothing in the DaVinci fork, but is active in the PR and original. What's the reason for that?
Reply
#5
On repetier DUE, function is empty also - issue is on repetier original not specific to Davinci, you may have checked AVR part.

https://github.com/repetier/Repetier-Firmware/pull/425

And for what I can see - repetier have not yet implementing this fix but did some others changes: like 928 line commented and also some change in watchdog

https://github.com/repetier/Repetier-Fir...er/HAL.cpp
Reply
#6
Sorry, I was looking in master branch, which appears to be 0.91 (it is enabled there):

https://github.com/repetier/Repetier-Fir...tier/HAL.h

I do see that it is disabled in the work092 branch. I'll give it a try and apply the patch.
Reply
#7
It may be a short term solution, as repetier doing another way which also need some watchdog update
But please share your results
Thanks
Reply
#8
Hi
I have not had the opertunity to do much printing with my Da vinci then recently i needed to make a tool so i designed it in Rhino and made it in 2 parts first part printed just fine ran for 2 hr's and 11 min's no problem then today i tried to print the second part and it quit after 20 minutes running no where near finishing the run time on the part was estamated by slic3r at 1hr 58 minutes i thought i had it going but it's still doing the same thing any news on the problem fix.

Dennis
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)