Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Problem with Z axis movment and calculated z-step rate
#1
I have a modified DaVinci 1.0 (no jumper pins)
Issue: The z-axis is not moving the proper distance with the calculated z-step rate. It is not a huge discrepancy (1/4, 1/2 etc) that would indicate an improper microstepping rate. Nor is it intermittent as might be caused by missed steps. It is a small but consistent error. About 97mm for every 100mm

Symptoms:
I have been having a issue with filament jamming and striping out in the extruder. It seems to be a back pressure issue in the nozzle. It happens constantly on layer 3 when printing 3 bottom layers (.3mm per layer, .4mm first layer). If the print can get to layer 5 the rest of the print is fine.
Closely watching the print, the nozzle actual begins to scrape off bits of plastic from the previous layer. A little during layer 2 a lot during layer 3, building up this thick excess of plastic around the nozzle.
Rechecking things I found that my e-steps were off! Apparently I had not calibrated properly when replacing the extruder.
Recalibrating the e-steps and adjusting the extrusion multiplier seemed to reduce the amount of extra plastic building up, but did not correct the nozzle gouging into the previous layer.
So I tested the z-axis and found that it was not traveling the full expected distance. Moving about 97mm instead of the expected 100mm.
At first I thought it was varying, but it turns out I was being sloppy in my measurements.
I came up with a fixed measuring point and discovered yes it was off by a small but consistent amount.
I tried increasing the stepper current (Pololu Stepper Driver with trimpot) - no change
I tried decreasing the stepper current (Pololu Stepper Driver with trimpot) - no change
I did some math and adjusted my z-steps and now it is moving 100mm for 100mm.

The issue:
My concern is that you should not need to "calibrate" the z-steps on a direct drive setup right?
I have heavily modified this machine so there are lots of areas I could have screwed up or overlooked something.
So I am worried that this may be a symptom of some other issue.:/

It could be the stepper driver. I have a thermocouple probe thermometer on order so I can monitor the temp of the stepper driver chip in case it is a over heat missed step issue.
Is there some other firmware setting I am overlooking? I have not made any changes to the default backlash settings. The only value I changed was my modified z-step rate.
Could it be backlash related? I would not think so, not with a error of 3mm with only 1 move? As I understand it backlash is going to be a small error and only show up when reversing directions. When measuring the bed travel I measured the higher point, then the lower point, then the higher point again. The results were constant.

Any advice or ideas on this would be greatly appreciated!

My Mods:
I replaced the stock extruder with a Bowden style, I purchased the Ezstruder cold end from SeeMeCNC.
I replaced the hot end with a e3D V6
When modifying my extruder I forgot that the extruder motor wont engage when cold and thought I had a problem. In my attempts to diagnose a possible bad stepper driver I switched the stepper driver boards. I plugged in one backwards and fried it. :ohmy:
I wound up replacing the driver board for both the Z Axis and the Extruder with new ones I got from Pololu. These have a manual trimpot to set the current.
I had to modify them to work, replacing the pins on one side with jumper wires so they could plug into the motherboard.
In an attempt to reduce the z banding issues I was having I replaced the stock thread coupler on the Z axis with a flexible thread coupler. I also replaced the bushings on the z axis with 8uu bearings.
Reply
#2
UPDATE
I got a thermocouple probe thermometer and put it in the stepper driver chip.
During a 2 hour print the chip never exceeded 57c. With a max operating temp of 85c I think I can rule out missed steps due to driver overheat.
I was reasonably certain that was not happening but it is nice to confirm it.
Reply
#3
UPDATE
I found that a big part of my "layer 3' problem was backlash.
As part of my custom code I home the axis then drop the build plate to 1mm to make sure that the nozzle will clear for any initial moves.
Then the build plate raises up for the first print at 0.4mm.
Then drops down for each layer after that.
This up, down, up, down was causing backlash errors. Not much but enough.
I changed my custom code to drop the build plate to 0.1mm so that after the build plate only moves down for the entire print.
This made a huge difference with the layer 3 problem

Interestingly I diagnosed this while playing with some flexible filament. With my extruder any backpressure would cause the filament to tangle. Because if this I was able to see the exact moment that it encountered back pressure. And that it was happening constantly in the same place, the beginning of layer 3. This let me track down what was happening Smile

I have not eliminated it completely, but it is lessened enough that I can print using regular filament without issue. (Flexible is still a bit tricky)

I have no idea why my step rate is not equal to calculated though. That has me wondering if something else is wrong?
Eventually, I will probably replace the Z threaded rod with ACME and add a anti-backlash nut.
(I want to redo the whole print bed eventually, upgrade to a metal base and better heater)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)