Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier can't connect to Da Vinci 1.0 after flash
#1
Hi, I've looked through the forums and can't find an answer, forgive me if I'm blind, but would be grateful for any help. I have gone through as many sets of instructions as I can. I first downgraded the Da Vinci 1.0 firmware to 1.1J. Then attempted to change to repetier firmware, but even though my computer was completely disconnected from the internet Da Vinci wanted to update the firmware from the internet, and would not give me the opportunity to upgrade from a file on my computer. I have arduino already on the computer from the original downgrade. So installed repetier-host, and followed the instuctions here: http://tinyurl.com/pnejt3d and flashed the printer. Had lots of trouble with the port, every time I did something, the printer decided it was on a different port. Finally went to Control Panel > Devices > Ports and Arduino Due is on Com 10. Uploaded the new info to the printer and saved to EEPROM.
Now I can open Repetier and adjust all the settings, and on the printer I have levelled the bed. But in the Printers and Devices, the Da Vinci is not listed. (It used to be, before I did all this). And when I open Repetier and click connect, I get this error message:
The connection failed with the following error: The parameter is incorrect.. Make sure your printer is connected, enabled and connection data is set correct. Open printer settings? So the printer seems to be happy, but the computer can't find it.
Any suggestions, please.
Reply
#2
Printers and Devices, the Da Vinci is not listed. this is normal the drivers is no more XYZ printer but Arduino Due

Seems FW is working if you did the bed lebeling, Is Arduino due port visible in device manager ?
Did you selected the correct port in Repetier host ? Printer Baud and Repetier Baud must be identical (default is 230400 in FW)
Reply
#3
Yes, Arduino due port is visible in device manager, although it seems to change when I restart the computer, and sometimes it changes to Bossa port. Anyway I picked the one that was showing at the time (now COM13) . When I open the repetier .ino configuration.h there is this line #define MOTHERBOARD 999 (is 999 OK?).
Baudrate seems OK #define BAUDRATE 230400.
So I re-verify the info and re-upload to printer, load to fail-safe, save to eeprom. Turn off and on again, printer says printer ready. Open repetier host v1.0.6, click big red connect button, same error message as before.
The connection failed with the following error: The parameter is incorrect.. Make sure your printer is connected, enabled and connection data is set correct. Open printer settings?
So I open printer settings, they are these
Serial connection
port: auto. I change that to com13, save.
Click the connect button again - yay, green!! :cheer:
Try a print. The extruder heats up, but the bed does not, so the print doesn't stick. Using ABS. Where is the choice of which kind of filament you are using? Bed temp is set to 90 deg, Max bed temp is set to 120deg.
PS Thanks so much for your help, really appreciate your time.
Reply
#4
there are more setting in repetier host than baud and com for communication
did you check them all?

once fw is flashed no need to reflash to change a setting unless you selected wrong model in configuration.h

is z working properly from printer? is bed heating when command is from printer not host?
Reply
#5
I've fiddled with all the settings I could, read the instructions Smile and watched u-tube videos. Now the bed heats Tongue
We thought the extruder wasn't heating, but then figured out it does one after the other (xyz used to do both at the same time, so that was unexpected).
Progress is good. Now to try a print. It prints off the edge of the bed, and the extruder hits the metal clamp on the edge of the bed. The object is in the middle of the bed visually, in the Object Placement tab I clicked Centre Object. But that's not where it is trying to print. Is there a way to set the print in the centre of the bed, I seem to have missed that somewhere?
Reply
#6
this a setting in slicer you use = Print Area, need to be correct settings according your printer and the settings needed by the software - there are several threads on this on the forum
Reply
#7
Yes, there are several threads, and they all seem to say different things. I've gone over all the config settings I can find - it seems everybody does something different depending on their machine, or personal preferences. I copied some of them, but no luck, then after fiddling so much decided it might pay to re-calibrate the bed. Bad idea. Extruder went off the side of the bed, (as usual), jammed, then smoke starts pouring out of every orifice of the printer. The air was blue (the language was blue too). Sick
Turned it off, Steve (who is clever) replaced the one yellow wire that was completely burnt, and turned it on. It started.
So now I'm too scared to try anything else.
Read more forums, decided this thing just has to work. Copied this G-code here: http://tinyurl.com/qfnnupg. Test print, a little gear - bed and extruder heat up, filament starts to extrude (laying a test strip down the side of the bed, like it always has using xyz ware), only half way through the strip, the printer turns itself off. At least it didn't blow up.
Steve fiddles inside, decides to replace some more yellow wire, and we try again. The printer doesn't stop. Yay. Progress. Good progress.
The print is not in the centre of the bed, we can work on that tomorrow.
I think it's going to work :cheer:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)