Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Need help with adjusting print bed height.
#1
Hello guys,
I have flashed repetier 0.92 firmware on my 1.0 but I'm not sure what to do next. I use simplify3d, and as far as I can tell everything seems to work fine- heating, fans, steppers. What I am having problems with is the print bed height. The print bed is about 10-15mm higher then the extruder, even if I were to tighten the leveling screws all the way down it would still not be enough for the extruder to not hit the side of the print bed. Do I need to add Start and End g-code? And if so, could someone briefly explain how to do that? Or is there something else that I'm missing?
Sorry for noobish questions, but I could not figure out how to get things set up (feel a bit embarrassed to be honest)
Since I was planning on using S3D from the beginning I never bothered to install Repetier Host as I thought it would be redundant, was that wrong thinking?
Using Windows 8.1 and the latest version of Simplify3D.
Thank you
Anton.
Reply
#2
there is a way but it won't prevent any accident if you do Z homing alone and I do not know if it is reliable :
in configuration.h line 844 #define ENDSTOP_Z_BACK_ON_HOME 0
try #define ENDSTOP_Z_BACK_ON_HOME 10 or what ever the value you need it should drop bed to 10mm after homing and set this new position to Z = 0

Another solution, hardware this time, print a longer flag (+10mm or what ever you need) for the Z end stop, people who mod their DAVINCI with EDV6 extruder without changing carriage use this mod as extruder nozzle is longer than stock one so they are in same situation as you.
here the flag : http://www.thingiverse.com/thing:621440

EDIT: Seems new models come with this problem : https://github.com/luc-github/Repetier-F.../issues/79
Reply
#3
Thank you for quick reply luc.
I ended up going with the hardware solution, and as far as I can tell right now everything is working as it is supposed to Smile
Thank you.
Anton
Reply
#4
If your using Simplify3D, when you set up the FFF 'Edit Process Settings' go to the tab G Code. At the bottom of the left column there is the option to add an offset to any of the axis.

Having broken my bed I am temporarily using a rerap type heater with a glass plate on it until my XYZ replacement arrives. To accommodate this extra height on the bed I have put a 4 mm offset into the Z setting. This has allowed me to manually level the bed with it being 4 mm lower than normally.
Reply
#5
Hi can you tell me how you set the Z offset in the eprom? I tried to give the z-home variable a number, but i doesnt seem to do anything. I homed all axeses, changed the z-home variable in the eprom to 100, turned off the printer. Put the extruder above the bed, turned it back on and homed only the Z axes, it goes up and down and comes to exactly the same height as before. When i check the Z height, it does say 100.

Do I have to set another variable?

Thank you.
Reply
#6
yes this is correct behavior, Z offset set the position when homing = at home position nozzle is at zoffset, it does not change physicaly the position - bed will be moved accordingly when printing, that is why bed leveling is done at Zoffset=0, and why it is not recommended to use zOffset to level the bed when distance is more than 0.1 mm, because it will not prevent nozzle to crash the bed if doing Z homing with nozzle on middle of the bed and if nozzle is lower than bed at home position.
Reply
#7
Thanks for your answer. I thought this was the case. I have a BuildTak on my plate and i need the bed to be 2 mm lower, what would be the best way to do this so that the extruder never is going to hit it? I want home just to be 2 mm lower.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)