Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier firmwareload is causing printer reset over and over
#1
I uploaded Repetier tonight and after a normal upload, the printer resets itself every 20-30 seconds. The screen blanks, the computer beeps and the led lights go out. Then the system restarts, the computer beeps and the printer appears normal for a few seconds.

I'm going to try reflashing it in the morning, but if anybody has any clues or suggestions, I'd sure appreciate them.
Reply
#2
what printter do you have?
what fw did you flashed ?
what fw did you had before?
Reply
#3
Hi luc,
I have the 1.0 and it did have the "J" fw on it and I just uploaded the FW version 1.0.6
Reply
#4
1.06 is not fw version but host, what fw did you downloaded 0.91 and/or 0.92?
Reply
#5
0.91 Sorry luc. Smile It's late here.
Reply
#6
0.91 does not have and does not support watchdog which do the reset

so I am prettry sure you first dowloaded 0.92 and used it to update variant. cpp then dowloaded and flashed 0.91

please use the variant.cpp provided in 0.91 if you flash 0.91
Reply
#7
does this solve your issue ?
Reply
#8
Hi luc. That solved the reset problem, but now R Host doesn't do anything with the printer. The lights come on and the printer functions all work from the printer keypad, but it's unresponsive to the computer. I tried closing host and opened Ponterface. It connected with the printer and even ran a print, except the extruder and heated bed did not heat.

We had a holiday today and with family obligations there wasn't much time to look at it. I hope to try a few things tonight.
Reply
#9
this is due to bad configuration of repetier host - check your repetier host settings and be sure baud rate is same as printer
Reply
#10
Is there a baud rate that is recommended? I see lots of options.
Reply
#11
default one in printer is 230400, if too may error 115200 is OK, printer and host must use same values
Reply
#12
OK, I seem to have everything operating except the extruder heater and the bed heater. Any thoughts about those?
Reply
#13
when heating from printer is it working ?
Reply
#14
No it's not, but I just discovered that on the printer, the "Dry Run" option is turned ON and for some reason, clicking on it will not turn it off.
Reply
#15
Dry run is On when there is a problem and the only way to set it off is to restart printer
Reply
#16
I'll bet I have another problem then and sadly, I'm just too tired tonight to think logically. I'll take a stab at it after work tomorrow.

Thank you for your patience and willingness to help Luc. You have my vote for sainthood. Smile

Larry
Reply
#17
It seems that each time I reset the printer power, I try to change it from "dry run", it immediately turns on "dry run" again.

I've cleared and reloaded the firmware a couple times. I've erased all the arduino firmware a couple time, resetting the computer and reloaded it from scratch too with no change. No matter what I do the heaters don't seem to engage at all.

Is there a working copy of the complete 0.91 firmware posted someplace. I'm assuming that I'm doing something wrong with the setup and I'd love to have a zipped firmware that I can just drop on it?

My initial thoughts of changing to a mega 2560 ramps board is most likely my best option. Apart from adjusting steps per 100mm and extruder feeds, I can use the same firmware as one of my other printers.
Reply
#18
https://github.com/luc-github/Repetier-Firmware/wiki
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)