Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
What firmware for Da Vinci 1.0A
#1
Had my printer for a bout a week now and am getting some fairly good prints out of it.

At the moment I'm running stock firmware 1.0.1

Just sticking with stock firmware at the moment, is there a better one I can be running, and is it even possible to upgrade to a specific version? Or will the software just update to the latest version? Is the latest version causing issues for people?

I may look into installing Repetier on my printer. Is anyone reading this post running this on a 1.0A, what are your thoughts?

I have read loads of posts on this forums but it's really confusing with a mix of 1.0 and 1.0A printers. Loads of posts say to run 1.1.J but I believe that is only for the 1.0 printers, and the firmwares for 1.0a are encrypted or something and cannot be flashed?

Bottom line, What firmware should I run on my printer to get the best results?

Matt.

PS. My printer has the J37 board in it. According to the Repetier GiHub readme file, this is an unsupported board? I'm sure people are running it on this version though. Is the readme just out of date?
Reply
#2
what repository are you checking ?
Reply
#3
Was looking at this one: https://github.com/luc-github/Repetier-F...92?files=1

The readme.md file says:
The board can be easily exposed by removing the back panel of the printer secured by two torx screws. Supported boards have a jumper labeled JP1. Unsupported second generation boards have a jumper labeled J37. More info can be found on the Voltivo forum.

Matt
Reply
#4
good catch - thanks for pointing this - I have corrected the read me for 1.0A/2.0A support
Reply
#5
Ok, Time to start flashing then Smile. Wish me luck!!

Thanks, Matt.
Reply
#6
I have added also 2 excellent tutorial links in the read me - have look
Reply
#7
I've got everything going, but i'm having issue with the z height.

I have levelled the bed in manual mode so that an a4 sheet is tight beneath it. But when I print the print head is too high above the bed. I can bring it down a bit using the z offset in slic3r but I can't seem to bring it down enough (I guess the z offset can't make the z value go below 0.

Is there a way I can adjust the z height without using the z offset in slic3r? Do I just need to move the headbed up a bit or will that then cause the nozzle to actually hit the bed when z is set to 0?

If I click the home z button, the nozzle goes to the correct height. It's only when it's printing that is raises up too much?

Thanks, Matt.
Reply
#8
is your Zmin at 0 in EEPROM ?
normally you should not need to use any Z offset if bed is properly level - check your slicer setting / RH setting to be sure you do not have any one any where
Reply
#9
How can i check the eeprom? Is I using one of the m codes? I've just popped out for a bit so will check when I get back home.

The bed is definitely level and doing a home z sits the nozzle perfect all over the Bed. But printing has the nozzle at least 1mm above the bed. I have deleted all my old slic3r configuration and started fresh without any 3 offset.

Thanks, Matt.
Reply
#10
in repetier host you can check Config->Firmware EEPROM configuration menu when connected
Reply
#11
I can't see a Z min attribute in the eeporm. But the z home is set to 0.0. There is also a Z probe height which was set as 2.8. Should this be 0?

Thanks, Matt
Reply
#12
It is zhome if set to 0 it is OK so the problèm is thé slicer

If you manually move nozzle to z=5 then xy to 100,100, then z to 0 using manual tab, it works ?
Reply
#13
Yep, Manual button to home z brings the nozzle perfectly down to the bed, piece of paper moves with a little resistance. When I start a print job the bed moves down out of the way, it heats up but then when it goes to print the head is about 1mm-1.5mm above the bed and the plastic is just extruded into air.
Reply
#14
when then it is in your slicer configuration if manual gcode do what is expected - check your generated GCODE and your slicer settings - sorry i am not familiar with slic3r cannot tell you more about what is wrong with slic3r
Reply
#15
The only things in the gcode are to tell it to move z to 5, then heat everything up, then move z to 0.35 (first layer height). I've not used cure before but I tried with it and got the same issue.

So I started a print with slic3r and adjusted the bed while it was printing the first layer. It is now working for each print. If I do a home z the nozzle touches the bed and if I move it up by 1mm it hovers just over, so it's not very far Out. There is a YouTube video with someone else that seemed to have the same issues.

Unfortunately I now have another problem. I started a print going and about 1cm up the print the layer shifted on the x axis by about about 1cm and ruined the print. If have printed about 50 models on the stock firmware since I had the printer and have never had an issue. This is the first full print I have tried with repetier and got the issue straight away Sad. I believe there is no way to go back to stock firmware either.

I know there is a thread on the forum about this so will go and have a read through. I believe you made a change in the configuration.h but since I only downloaded it yesterday I assume I already have that change.

Seems like repetier just doesn't like the 1.0a very much.

Matt
Reply
#16
well this is weird, because if when you do manual command to be at Z=0 on the bed, and position is correct then there is no reason when using slicer there is a difference unless repetier host has some setting for Z position or slicer has some z offset

About shift sorry but this is not linked to repetier, stock FW has same issue - it has several root cause and all are HW and seems linked to new board yes- the change in repetier was a work around for some root cause not all
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)