Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Thermistor Tables, not using small curcuit board
#1
Hey,
I am sorry if there already maybe a solution to this problem on the forum, but I searched for hours and did not find anything:

I have a Da Vinci 1.0A with repetier 0.92, my stock thermistor broke and I ordered this one instead:
http://www.amazon.de/gp/product/B00QHENJ...ge_o00_s00

Since there is no detailed information, I assumed it is one of the types described here with 3950 beta:
https://cae2100.wordpress.com/2014/03/08...or-marlin/

The problem is that while trying to solder the new thermistor to the small curcuit board, I somehow destroyes the contact pins, so I connected it directly.

Now I am at a loss what values I need to change in configuration.h to make it work - right now the reading of the firmware is about 50° higher than the actual temparature.

Any help is greatly appreaciated.

Best Regards
Jakob
Reply
#2
I am struggling with a similar situation myself. It is going to be really hard to get a accurate thermistor table without knowing the data for your thermistor. Sad
You might want to check the packaging and paperwork that came with it and see if there is any clue to the manufacture and model.
Or try contacting the reseller and see if they have that info so you can get a data sheet?
Reply
#3
Hey,
I managed to calculate the beta using this guide:
http://reprap.org/wiki/MeasuringThermistorBeta

I got a value of 96800 ohm at 25 degress and 4450 ohm at 230 degrees, that made a beta of 2253 - can that be right?

I then tried to make a thermistor table using this:
http://nathan7.eu/stuff/RepRapCalculator...TempLookup

My Problem is that I do not know the r1 and r2 values, since I bypassed the breakout board and connected the thermistor directly to the main board.
I am not sure if this is even supposed to be working. When I put 0 or 1000 for r1 and 4700 for r2, it does not work.

Any advice? I am kind of stuck here, and would greatly appreciate any help.

Best Regards
Jakob
Reply
#4
Check out these two threads.
Unfortunately there are several versions of the boards, so it is hard to say what R values are in your machine.
Repetier .91 + e3d v6 extruder
E3d v6 Extruder Thermistor Table

I could not get the tables to work but it is probably because many of the generic calculators do not do the {x8, x4} multiplier on the table data?

As I understand it there is not supposed(?) to be anything on the break out board as part of the thermistor circuit. But I plan on bypassing it completely eventual just to be sure.
Reply
#5
On my 1.0 I bypassed the breakout board and did not notice any change in the temp readings.
Reply
#6
Thank you! Somehow, when I tried the standard table that comes with the davinci repetier FW, it worked perfectly.

Thanks!
Reply
#7
That (table #5) is what most of us running non-stock hotends use too. It may not be perfectly accurate but I can certainly print both PLA and ABS at their standard temps.
Reply
#8
It works now - but about 1-2 Minutes into the print I get heater decoupling error. I tried to set define PDM_FOR_COOLER 0 to 0 as mentioned here: https://forum.voltivo.com/showthread.php?tid=8364

but it didn't help (I have Da Vinci 1.0 with stock fan and stock fan mount).

Then i disabled the heater decoupling check, but the print went bad (filament not sticking to bed, tangling up) almost immediately. So I guess it is some kind of hardware issue, the temperature readings seem ok.

Should I open up a new thread in the hardware section? Any advice on finding out the cause of the problem?

Best Regards
Jakob
Reply
#9
Have you replaced the stock connector of the heater cartridge? It's so cheap and crappy that it's bound to fail eventually. Everybody is replacing it with something proper sooner or later.
Reply
#10
Yes I have. I also hat this error with the R271 part (as discussed here: https://forum.voltivo.com/showthread.php?tid=8517 bridged it and added a fuse as suggested.
Reply
#11
Well, then if it keeps decoupling while printing then you probably have a bad connection somewhere, or a wire broken internally, either on the sensor or on the heater... Try and see if you can repro the issue by manually enabling the heater and then jogging the print head around into different positions.
Reply
#12
I tried, but couldnt reproduce it by moving the head around.

But there is a clear moment when it happens everytime: After printing the first layer, the fan (stock fan) goes from 100% to something less, and then the rror occurs. Does this narrow it down somehow?

Best Regards
Jakob
Reply
#13
Hu, that sounds odd. Are you sure it is the extruder fan slowing or the power supply fan? On mine it is the power supply fan that is louder and changes speed a lot.
Are you printing the first layer at a different (higher?) temp?

Somewhere there is a thread about tweaking the decouple settings, changing the temp range and time before it timeout.
Before I got my PID tuned I would occasionally get decouple errors so I bumped up both the temp range and timeout duration on the decouple settings and that fixed it.
When it does it's layer change / fan slow / decouple -thing, does the reported temp /suddenly/ change? (something shorting out maybe? but on layer change? that suggests something going on with the Z-axis - which doesn't make sense.)
Reply
#14
Hey Aaron,
somehow the error disappeared, although I did not change anything. So for now, everything is working fine.
But thank you very much for your advice, if I ever get the same problem again, I know where to start debugging....

Best Regards
Jakob
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)