Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
x and y endstops quit working????
#1
I am at a loss. I have a davinci duo with two fans and I have been running repeater for a long time with no problems. I have been very happy with everything. Then one day after a perfect print. I got the two black bars for a couple minutes then it restarted on its own and since then I haven't been able to print. It will only move in positive direction ( x and y axis z is fine) and it won't home. I've reflashed several times, all parts are good. I flipped the logic on the two endstops and it will move in all directions again but if I try to home it slams the side of the machine. The path it's trying to take is way off the bed but it says it's where it is supposed to be. I'm at a loss,I've built a couple reprap machines I'm no expert but I've got a good grasp on how things work. Any help would be great!

Thanks
Reply
#2
what fw are you using ?
did you tried to use the top lid endstop to check if it is end stop or wire issue
Reply
#3
I am Using repetier .92 mod. That's the funny thing. The hardware is good. I've switched them and everything works as long as it's not on x or y. I checked them with a meter and they are sending correct voltage when triggered.
Reply
#4
Homing is no more working ? or just moving like using manual commands in repetier host ?
Reply
#5
With default settings on endstop in my configure h file it will home fine but then it will move in posstive directions only when I back up the numbers back down to zero but the head stays still. If I switch logic in configure h it will move both directions and plus and minus. But when I try to home it is trying to home way off the bed and slams into side and just keeps banging into it until I shut it off. I have re flashed with fresh copies of firmware. It worked perfectly as soon as I switched to repetier months ago and this just started out of the blue
Reply
#6
did you updated with recent version of fw ? the wires are known to generate false signal and getting worse with time (repetier and stock)- there is a Workaround implemented recently may be it will help
Reply
#7
Yes latest from github I used. What is work around?
Reply
#8
this one https://forum.voltivo.com/showthread.php?tid=8594
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)