Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Will not extrude during printing, only using manual controls
#1
Hi all, I just finished upgrading my davinci to E3D and adapted the original extruder to make a bowden setup. I basically removed all the stock extruder gear off the carraige and re-mounted it on the self above the z axis, kept the pcb that controls the temp and fan etc. What is happening is when I commence a print (am using repetier and the custom firmware) the print head starts tracking like it is printing, and previews on-screen, but it does not extrude any filament. I can however manually push filament through using the manual controls, so the issue seems to be that the software is not telling it to extrude during printing? Any ideas on whats going on would be very much appreciated. Cheers
Reply
#2
I had very a similar issue when I installed my e3d. Check to make sure that the filament is properly feeding on the idler's teeth, my filament was feeding on the smooth side and that happened. If it still isn't working, check that you feed/flow rate is correct.
Reply
#3
Thanks Nolan, the filament is definitely feeding properly when I control using the manual controls, it is only when I come to print that the extruder decides it doesnt want to function. If I pause print and manually extrude, no issue. It makes me think its software related, however I neglected to mention I also accidentally got the extruder stepper connector and the other connector that goes into the small pcb confused and plugged them into one another. When I first tried to print it would not heat nor switch the fan on, I then realised what I had done. After switching them back the fan works, bed and nozzle come up to temp and everything else is acting as normal, but I do now wonder if this may have had an effect? I checked feed rate, and is also fine.
Reply
#4
if extruding when not on bed, it means bed is may be too close so extruder cannot extrude

redo your bed levelling
Reply
#5
Thanks luc, it will extrude over the bed no problems manually, and the bed has been calibrated using my feeler guages, is pretty spot on (apart from the slight warp in one corner!) Cheers
Reply
#6
if when you start print on first layer the gauge is able to pass - then the other parameter is the slicer/gcode
Reply
#7
The gauge can pass when I stop the print on first layer. Slicer/gcode is where I get a bit lost, but willing to pry if you can give me any clues where to start?
Reply
#8
Sorry misreading - ignore my previous message - I am Editing
pls - share you code until 3 lines after Z layer
Reply
#9
to level the bed I start the print and then kill it once it has started to scribe the first layer. I then manually move the head around and level on the adjusters until I am happy I have approx 0.2mm clearance. The thing is, the stepper isnt even trying to push filament, it just doesnt do anything once the print has started, only when I use the manual control. Thanks Luc
Reply
#10
Ok did you tried the manual leveling function in maintenance menu - just for my information

Anyway ignore my previous message (I read "can't" when you wrote "can" - I just wake up and not awake sorry Blush )

please - share you code until 3 lines after Z layer to see the code
Reply
#11
the maintenance menu on the printer? I suspect I havent, however I did go in and try switching the hotend and build plate on manually when I had my original issue with the connectors switched around. Sorry, Im in my office now and have left the printer at home so will have to get the code this afternoon when I get home (New Zealand time) Thanks Luc
Reply
#12
Sorry Luc, I tried reloading the firmware onto the machine to see whether there was something going on there, but nothing changed. It definitely has no problems extruding filament when heated. My code is simply the code as uploaded from arduino straight out of the github.
Reply
#13
I am talking about code generated by your slicer, the gcode not the fw one
Reply
#14
perimeters extrusion width = 0.40mm
; infill extrusion width = 0.67mm
; solid infill extrusion width = 0.67mm
; top infill extrusion width = 0.67mm
; support material extrusion width = 0.40mm

G21 ; set units to millimeters
M190 S110 ; wait for bed temperature to be reached
M104 S230 ; set temperature
G28 ; home all axes
G1 Z5 F5000 ; lift nozzle

M109 S230 ; wait for temperature to be reached
G90 ; use absolute coordinates
G92 E0
M82 ; use absolute distances for extrusion
G1 F2700.000 E-4.00000
G92 E0
G1 Z0.100 F7200.000
G1 X82.490 Y80.533 F7200.000
G1 E4.00000 F2700.000
G1 X82.916 Y80.135 E4.00536 F360.000
G1 X83.292 Y79.836 E4.00977
G1 X83.766 Y79.515 E4.01504

is that enough of the code?
Reply
#15
You print at 0.1, Start to print at 0.2 or 0.3 by layer to see if it extrude better

and decrease your retractation
from
G1 F2700.000 E-4.00000
to
G1 F2700.000 E-2.00000
Reply
#16
Thanks Luc, having a go now. Just for interests sake here is my hacked E3d/bowden setup

Cheers
Reply
#17
PICS HERE[Image: photo35.jpg][Image: photo25.jpg][Image: photo16.jpg]
Reply
#18
Increasing first layer to 0.2mm seems to have worked Luc! I am running a bowden setup as below, the retract rats you suggest above are correct for this? I now need to know where to set the drive gear diameter for the extruder? Ive hunted through slicer but no joy. Sorry for the naive questions..
Reply
#19
you can fine tune the retractation now extrusion is ok - it was just to be sure something going out quickly during test

I do not use bowden you may request help on user 2 user thread for this

about gear size it does not work like this - you need to do extruder calibration by adjusting steps/mm for extruder - setting is in EEPROM
http://www.instructables.com/id/How-to-c...d-Printer/
Reply
#20
Thanks Luc, really appreciate the help. Cheers
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)