Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
First Print on Repitier / 2.0A
#1
Can someone give me some tips to get printing working properly. I am trying to print from Repetier Host,, it's moving and extruding, but the extrusion does not appear to be fast enough. I can load the filament through the menus and it comes out at a reasonable rate, but it just wont seem to print.

I have the filament diameter set to 1.75 in the host settings.

Any ideas?

Edit: Have their been any issues with the temperature being misread on the new mainboards? Ambient does seem to be reading high.

Edit2: If I dial the temperature up to 250 and the filament size down to 1.5 I start getting something happening. Temperature not being set right? Extrusion speed wrong?

Edit3: Just checked the ambient temps and they are reading 17 for the bed and 20 for the extruder. Not far apart, but I would expect them to read the same? I'll check again in the morning when it will be a fair bit colder.
Reply
#2
can you explain more the state "it does not print"
you meaning extrusion is ok on drip box, but when start printing nothing extrude ? => bed is too close and do not allow filament to go out
redo your bed leveling
Reply
#3
Filament will extrude to the dripbox, yes.

When I print, filament does come out, but too slowly. It is like it he extruder is too cold or is being extruded too slowly. When I upped the temp and filament speed (by altering the width) I did get something to print, but bad quality. It does seem to be the temp to me? Is it possible the latest 2.0a have a different thermistor setup?

I'll try looking at the bed levelling, but I don't -think- that is the issue.
Reply
#4
if extruder can extrude on top of drip box it can extrude when printing

what do you mean by extrude slowly ?

all come from slicer settings - are you sure printing start when extruder reached temperature and not before ? this is also a common mistake in settings

I had confirmation it is fine for 2.0A to print with people helped to find the last pin out

normal temperature for ABS are 230 for extruder and 90/110 for bed, to increase speed you must increase feedrate in slicer

Also : increasing temp / nozzle size do not increase speed
Reply
#5
Just checked the temps again, it's now 6 on the bed and 11 on the extruder. Should they not read the same?

My initial settings were 225 extruder and 100 bed for abs. According to the display, all temps are good. I altered the filament size down to 1.5, which I believe alters the feed rate?

By extrude slowly I mean not very much filament comes out compared to what I have seen when the setup worked -- it's slow / cold enough that when it comes out it curls up and around the hot end. Is there anything in the eeprom settings which will effect extrusion speed?

Also, what is a good way to double check the actual hot end temps against the values shown on the display? Use a thermocouple pushed into the hot end?
Reply
#6
no no filament size is 1.75 / nozzle is 0.4 do not change them

Temperature has been measured using a thermocouple, by drilling a hole in extruder but no mesurement was done under 15 degres, as was hotter than now, so there is a lack of accuracy under 15 degres for extruder - but it does not matter as usage temperature are corrects (>20 degres)
wow 11 degres it is cold in your place !!! be sure you close the printer top and door and temperature are stable before printing and use 110 for bed not 90

for the flow first you must check if flow is homogenous on dripbox or 10 cm over bed, not speed - if curling just push the curl when extruding and it will fall, then you can see the line of flow.
speed are handled by slicer so different slicer = different settings, you need to adjust them - but the settings on forum are the one most of people use so they work.
Reply
#7
I'll double check all my host settings for printer and slicer and try again shortly. The only other setting which would affect this, if it's not a temperature issue, is the "extr. steps per mm" in the EEPROM. I'll double check what mine is set to -- I did reset default settings in first flash, so it should be correct.

Edit: I see this post for calibrating the the extruder steps. I'll check that to be sure.
Reply
#8
You need to calibrate your extruder steps default is 99 as in average we all got this but can vary from 96 to 110 - so you won't notice the speed difference
and steps are not part of slicers settings - speed is a setting
http://www.repetier.com/documentation/re...t/slicing/
Reply
#9
Ok, I noticed I had changed the first layer width to be smaller than the default for some unknown reason when I first started setting up the slicer, so I increased this back to its default, and now we're printing. After a bit of tweaking I'm starting to get some nice results.

To those who are not sure about switching to Repetier with the 2.0A, I can say its working nicely now here. The firmware LCD usage is MUCH nicer than the XYZ firmware and of course I'm now not limited by filament type or future crippling firmware upgrades from XYZ.

So I'm very pleased, thankyou very much to Luc for all your help getting this working. Smile

Edit: The print quality is excellent -- I would say much better than the same part I printed with XYZ. HOWEVER the USB comms to the printer locked up before the job completed! I'll have to check on running from the SD card, or tweaking the comms settings.
Reply
#10
happy you found the root cause - it is likely often a slicer issue or bed issue at the beginning, as with repetier you have more parameters, so it is easier to mess up if you do not do carefully.
If I can have a suggestion : simplify3D, the top slicer for 3D, it is not cheap, but you can read on forum it really worth it, and if you start doing 3d printing you will use it with all your printers.

about com port : try different port if you can , also try to install drivers from IDE 1.6.3 someone said it solved his communication problems

Happy printing ^_^
Reply
#11
I saw the 1.6.3 USB driver solution in another thread while searching last night, so I have downloaded it and will try today. I'll report back on how I get on! Smile

Thanks again!
Reply
#12
After changing the drivers I still ended up with a failed print. I then noticed the baud rate was set differently between the host and client, so I set those the same and things seem to have improved. Although I did get one print where it seemed to hang right at the last gcode command. I assume without any extra custom gcode the head should return to come at the end of a print? It left the head at the last position the print with the heaters off, so the extruder stuck to the print. I've added code to home the head and lower the bed and the next print was fine. Seems suspect, though.

However I can't understand how baud rate affects anything, as we're using a USB connection simulating a comms port. USB comms drivers will ignore this figure as it doesn't make any sense for a packetised USB connection. Confusing...

One question -- is there an easy way to print from the host? Ie. just add an extra gcode command or two to get it to upload the whole sequence before playing It back? So far that's the only thing I prefer about the default xyz process to using repertier!
Reply
#13
if hang it may means there is a typo issue and yes fw do not like - share the code so can check

USB/Serial yes speed need to be the same because in between true serial or usb it is still 2 wires : rx/tx so listening speed must be same

print from the host : 1 / open repetier /2 load stl / 3 - slice / 4 - press print or 1 / open repetier /2 load gcode / 3 - press print
I do not see more easy

if you want to do it manually there is the manual tab where you can send manually any command

the printer only do what GCODE tell it to do, no extra action that is not on the GCODE, - if you want go back to home at the end of print / put bed down at the end of the print - add the commands in custom end gcode of your slicer - with repetier you control all actions - printer is just executing your requests

if you want to upload the GCODE to printer and disconnect host, use the SD Card manager but upload is very slow because of used protocole - I use wifi SDCard is 10000 times faster
you also can print directly after slicing I remember there is a check box for this
Reply
#14
My terminology wasn't very good in that last post! By host I mean the printer, and by client I mean the pc. So, I was meaning could I add some commands to write the gcode stream to the sd card then execute it from there. I've just seen those commands do exist, so I'll give them a try.

Using a native usb com port, baud rate is not relevant and not used -- this is a hardware feature of rs232. In the case of rts / cts, this is the buffer full state which is all you need. I assume we're talking to the processor via the native USB port on the Sam chip and not via a uart and a usb to serial bridge? Or does this go via a bridge? If there is a uart involved, then baud rate really does count! Using native USB there's no reason not to have the USB connection very fast! I'm just familiarising myself with the code to see if I can figure out what's going on... Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)