Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.0A and Repetier Host .92 Layer Shifting Support Group
Ok, I think I've got the problem nailed. Here's how it went down:

I tried just about everything in terms of firmware and eeprom settings. Nothing. Still having the good print in the back, shifted print in the front side of the bed. Let's just say that this has monopolized my life. I'm pretty sure my gf is close to breaking up with me. I've tried every single thing on this thread, and the closest I came to a eureka moment was when I decided to mess with the cables to the X direction stepper motor.

I unplugged the stepper cables and unplugged the limit switch. freed the stepper cables from the little slot where they were wrapped around. Wrapped them in some tape and separated them from the red cables to the limit switch. I reconnected them and zip tied them to the slot, nice and tight so they wouldn't move.

HOLY CRAP that was a mistake. When I tried to just home the X-Axis it went bananas. Basically side stepping and getting stuck in place and making a horrible sound. So I unwrapped them and left them free without the zip tie and without being looped in the slot. That returned it back to somewhat normal, but now having issues when homing or moving using controls. Tried doing a dry run print right now and it clicks like crazy only messed up during the initial perimeter. It's working fine doing the infill and other layers. This problem is so confusing!!!!!!!!

So now I disconnected the limit switch (with the three wires going to it) and it's somewhat better.

I really the problem is: The limit switches making the printer act whacky and confused. Now how do I make it so that it doesn't check those limit switches?? Because it's obvious that if it's failing on perimetry, then it's fighting itself when checking if the perimeter it's laying down is hitting any boundaries. How do we turn that check off??

Thanks Smile
Reply
So how can I check these end stops and turn them off? I'm pretty sure that I've got this narrowed down to either A) Noise to the steppers from being shitty and B) The limit switches (end stops??) being the problem.
Reply
Hi - I just added (back) the end stop status in last FW
end stop status is displayed in page 2, at the end of X, Y, Z lines, and in position menu for X, Y, Z.
the open square means the end stop is not reached - the full square means endstop is reached

so you can either move axis manualy, or using arrow to move axis to check what is happening - but be aware, if it is a fast change you may not see it live - as display is slow

Hope it will help you to check your endstop
Reply
When you say "page two" what do you mean? And honestly I think it's a hardware issue. I mean, messing with the wires directly caused the stepper motor x axis to go crazy and do what causes the sidestepping (a violent stepper jerking back and forth) why wouldn't that be the problem? I mean, visually, it looks like the cables are too short, even at points like the middle of the print bed.

But I guess it wouldn't hurt to turn off that setting and see behavior. Just not sure what you mean by page 2. And yes I've read every single post in this thread so far hoping for a fix. I'm 98% positive it's not the firmware.

Side note, my limit switch for the x axis looks damaged (dented) ... I disconnected it completely and ran a dry run and same problems.
Reply
I winder if just extending the four wires to the stepper would fix it once and for all. What do you think?
Reply
Page 2 = when on main screen you press down key - you also have a Page 3 and Page 4 if you are in advanced mode

Yes issue is hardware - I just add this visual feedback in FW to help to check if endstop is answering properly, as it was requested by several people to test if endstop is communicating properly with FW
Reply
Hi Everyone.

I am looking for some clarity on this shifting problem. Some people are identifying it as shifting on the X-axis and others say the print is shifted to the back. So, can we all use the same nomenclature when talking about the problem.

The issue is that the 3-D printers do not use the standard rectilinear co-ordinate naming systems. To be specific, on the DaVinci, the X-axis is positive towards the left of the plate and negative towards the right side of the plate. The Y axis is positive towards the front of the plate and negative towards the back of the plate. And the Z-axis is positive towards the bottom of the unit. Hopefully the Z-axis will never go negative, otherwise it will be above the extruder.

Could we all ensure that we make sure when we are talking about print shifts that we are specific about the direction, the axis, and the approximate X, Y, Z values where this occurs.

In my case and others, we get a print that is shifted towards the back, that is in the negative Y direction usually when printing about 10 cm above the plate. And this only seems to happen when we are printing towards the front of the machine, with high Y-values. I have noticed that when the extruder is near the front of the machine, that the cable on the extreme right of the machine that runs the stepper for the X-axis, binds on the stepper motor, preventing the extruder from going fully in the Y-direction. Specifically, there is a cable tie that seems to catch.

I wish that we had a good STL file that would fail in a more than random way that we could use to test this further. Does anyone have such a beast?

Also, Luc, I am still not able to understand where the menu item is that checks the end stops. How do we get that item on the LCD menu of the DaVinci and do we need a specific Repetier release to see that menu.

In case anyone is considering whether or not they should install Repetier on their stock DaVinci, I suggest that Repetier is the way to go and has given me no grief at all. My support to a good team.
Reply
About end stop visual status , I have added it yesterday to master branch, so only latest release have it
Reply
So something weird happened today. I took off the gray plastic piece that holds the wire harness with zip ties and let it free. I figured that maybe the zip ties bunching the cables together was the problem. And actually now that the cables are free the x motor is sidestepping even when I print toward the back of the printer, where it used to work.... Maybe someone finds this info useful.
Reply
My issue was on the X axis (Right to left). But it has only happened on one model so far (Although I pirnted the model at two different sizes, the shift happened at the same height and by the same amount).

Only thing I have changed since then is the acceleration values on x and y from 1000 to 900. I have had no errors since, but have not tried printing the original model again yet.

Have just printed the tyrannosaurus rex skull and stand and it all printed perfect.

Matt.
Reply
Luc,

Which version of Repetier Host, exactly, has this feature?

Repetier-Host Windows 1.0.6 or Repetier-Host Windows 0.95F

If neither of these where can I get the updated version?

Steve
Reply
Matt,

I assume that you are referring specifically to the Travel Feed Rate in the printer settings? If not, where did you alter the acceleration rate?

Steve
Reply
No it was in the eeprom settings. In repetier host one of of menus has an option to show eeprom (can't remember which one off the top of head but it is easy to find).Click on that and there are settings for x,y and z acceleration. X,y are set to 1000. I read a post somewhere about reducing this value to make acceleration less harsh. I changed x and y to 900. I can't say if it made a difference but I have not had a failure since and have printed about five 6-10 hour prints.

Matt
Reply
It is in custom Fw 0.92 not host
Reply
Figured out the problem with the help of a friend on Instagram.

I took the x wire harness out and installed it in place of the y wire harness. Now the y axis was going crazy. Put a different harness on x axis and voila... problem solved.


Happy printing guys!
Reply
Hi wondering if this issue is fixed? Got lost in the reading of the thread and my understanding of what was happening. Guess I may have found out too late that this is an issue prior to flashing last night. I flashed the fw and set up a large print with almost a full bed footprint last night, started out well. Went to bed and woke up to spaghetti everywhere. Noted something odd and it looked as if the printer was not printing in the correct spot. Figured something got pulled out of place and happened upon this this morning. It looks as if everything in the print were shifted to the left by 36 mm almost exactly. It appeared to happen at the 3.0 mm mark in the vertical print. from my measurements. It sounds like this is what is happening to people? No issues with the y axis. Had no issues like this before I flashed the fw last night... anyone provide some insight on where to go from here?[Image: 20150507_075537.jpg]
Reply
Did you ever print an item that covered as much of the bed prior to loading the new firmware. If not, then going to the new extreme of the bed may have put a strain on the x-axis stepper motor that caused the offset. Myself and others on this thread have found the problem to be related to these wires and replacing them fixed it.
Reply
Yes, it took a while to diagnose when it first started. Got to the point where it wouldnt print. Cut the wire tie and straightened the harness and its working. Had purchased a new stepper motor and gear for no reason Smile. Looks like it broke the x axis limit sensor wire also. Big caution to anyone using these.
Reply
Quote:They didn't charge me anything other than the shipping fee that I had to pay to ship the board to them. I think it mostly had to do with the fact that I bought my printer from Amazon and they knew full well that I could have just returned/replaced my printer through Amazon if they didn't help me. That's not to say that I did not appreciate what they did for me.

How long did it take for them to ship your main board back? I sent mine in to be replaced and haven't received anything after three weeks.
Reply
It took about 2-3 weeks total. I'm not sure which service center you have sent yours back to. Mine was sent to San Diego.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)