Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.0A and Repetier Host .92 Layer Shifting Support Group
#81
Quote:FYI : I have set
#define ALWAYS_CHECK_ENDSTOPS 0 by default in FW master branch, I think it is not big deal to apply for everyone and it will help people who do not check this thread

where can i find the FW master branch to set this to 0? thank you in advance
Reply
#82
Quote:So you're telling me that the wire harness went bad after I flashed Rep .92 and then fixed itself after I went back to stock firmware? I haven't had one single misstep after 100+ hours of prints now on the stock firmware.

I'm not saying that the wire harness isn't the issue. It obviously has been for some, but I don't think that is in any way related to what we're experiencing here.

It is totally reasnoble that yours is also a wiring issue. If the issue is with noise or wiring in the endstops then you would have an issue with just Repetier if your ALWAYS_CHECK_ENDSTOPS was set to on (which was the default up to now) AND if the stock firmware is written to ignore endstops while running (effectively ALWAYS_CHECK_ENDSTOPS = 0). In that likely circumstance you would only have an issue running Repetier and no issue at all running stock firmware.

Some other people have reported other issues with wiring to steppers too but for some it seems to only be endstops. This tends to suggest the wiring harnes is of poor grade wire OR that the harness is not properly isolated for noise (shielded). I tend to think it is this latter case because having built a lot of CNCs and printers I have seen these behaviours before when I go cheap on wire, get cabling too close together and fail to have a grounded shield.
Reply
#83
The medical equivalent of this problem would be a cough: Many causes for the same symptom. I had this same problem on a DaVinci 1.0 using stock firmware. For me it was a combination of the X wiring having cracked internally causing glitches and the shim to realign the X axis pulley being damaged. Occurred after about 3kg of prints.

The thing with the wiring was that it looked fine on the outside, but when i touched the bundle and moved the wiring it caused the stepper to fire. Cut the wires about a cm up from the connector and soldered in an extra 50cm cable from a spare stepper. Unwound the bundle, let the endstop wiring out to its full length and let them both dangle inside. Problem gone

Based on the design I suspect this problem will occur on most machines so it is probably worth eliminating as a possibility before searching for other fixes.
Reply
#84
Ok,

So I have just flashed the latest repetier firmware to my 1.0A and it included the always check endstops=0 code.

Have printed loads of things since I got my da vinci just over a week ago and didn't have any issues. Started my first big print going with repetier last night and got a problem about 1cm up the model where the x axis shifted by about 1cm and ruined the model.

So what is the list of things I can try to do to stop this? I have ready about people changing the wiring to the endstops but surely with the updated endstop code, this shouldn't make any difference anyway?

What modifications have people done that they can honestly say the problem has completely gone away for them?

Thanks, Matt.
Reply
#85
You are right to presume that with check endstops at 0 that should avoid issues with resets due to endstops tripping due to noise. Some have reported the issue was with the wiring to the steppers. Personally I would replace these on the failing axis first with a quality leads that have shielding. You don't need to ground the shielding initially but if it is not improving matters you could ground the shield to see if it's a noise (EMI) rather than short in the original cabling. You could also consider routing existing cabling differently so it keeps away from all other cabling. That would isolate the noise issue.

This leads me to a point where RH could be subtly contributing to this issue just in the way it is driving something such that it is generating slightly more noise. In fact just more (or less) aggressive acceleration or higher speed s could be causing more noise triggering issues due to poorly specced/routed cabling.
Reply
#86
Do you completely replace the entire wiring harness to the steeper motors? What type of connectors are they on the ends? Also is there a particular type of wire you would recommend.

I have also just noticed that while a print job is running, the z motor is "clicking". If you put your finger against it you can feel it pulsing about once every .2 second. The prints are still coming out perfect when they work though. I'm not sure if the x and y axis are doing the same as they are always moving so you wouldn't notice. I'm wondering if this is what is causing the extra interference. It seems to be causing the z motor to get quite warm to the touch where I would expect that one to stay quite cool since it doesn't move very often. It's like there is power going of he motor all of the time.

I saw in this thread somewhere about acceleration and I noticed that with repetier the acceleration was much quicker than the stock firmware. I have changed this from 1000 down to 900 at the moment. Are their any other settings in the eeprom that could be changed?

Apart from the above issues, my prints are now coming out perfectly. It is so close to being exactly how i want it. It's just that I can't trust it with long prints at the moment as it just wastes hours and loads of plastic when the x axis jumps half way though a 20 hr print Sad
Reply
#87
I have just had a closer look at the clicking, and the Z axis is actually "hunting". I have recorded it so people can see here https://www.youtube.com/watch?v=mFhtQFuO3LE. If you look at the white spec at the bottom of the silicone you can see it slowly moving backwards and forwards. It is not causing any noticeable problem with the prints but it surely should not be doing this? Could this be the cause of the issues that people are having with the 1.0A?

Can anyone else with a 1.0a check and see if their z axis is moving like this one? If I put my fingers on the axis while it is printing, you can feel it pulsing and can just about feel the rotation too.

Anyone got any clue as to what could be causing this? It's surely got to be something firmware related?
Reply
#88
I have just watched my video back and the z motor is turning with the X motor??? If you listen to the noise, you can here when the x axis changes direction and the z motor follows it!
Reply
#89
You most likely have auto bed leveling enabled. If so, it's normal. Personally, i tried it, but i feel manual bed level is more consistent and reliable. It's been literally months since i adjusted my bed, and i print daily.

Kieth
Reply
#90
Ah, that would tie in with why it is changing direction then Smile.

I did do the auto calibration to get everything leveled out. I didn't realise it then did things to try and keep it level during the print.

Thanks, Matt.
Reply
#91
Have disable auto leveling in the eeprom and now everything is normal Smile. I much prefer to adjust the bed myself!

So is there any other settings that people have played around with to get their printers running smoothly. I need to tweak my z height for the first layer a bit, but everything else is running nicely.

What have other people done with acceleration and jerk values? Left standard or changed them?

Thanks, Matt.
Reply
#92
Hello, I figured out what the problem was for me. one of the cables on my stepper motors wasn't getting full contact with the motor, so after checking all the cables I did the same print and it worked without shifting layers. the question I have is where I can get the cables for stepper motors, just incase I have to replace them or I just want to redo them completely. Thanks.
Reply
#93
I've replaced the harness to my x stepper motor, the connections on the ends of the wires are JST 2.0 I've had the best luck crimping them onto wires with the universal micro crimper part number PA-09, can be found on amazon.
Reply
#94
so I'm having the layer drift issue as well but I have a 1.0 with stock .G firmware. I don't think its the x axis wire harness issue you guys have discribed because it drifts in random directions on both the x and y axis (see picture below to see it drift diagonally)

any thoughts?[Image: IMG_5053.jpg]
Reply
#95
also, I've printed the demo star vase twice between failed prints. The demos come out without issue...
Reply
#96
the issue also can come from slicer due to non manifold object

the issue can be due to wire, so depending on position on bed, the shift may not happen
Reply
#97
Quote:so I'm having the layer drift issue as well but I have a 1.0 with stock .G firmware. I don't think its the x axis wire harness issue you guys have discribed because it drifts in random directions on both the x and y axis (see picture below to see it drift diagonally)

any thoughts?

That does not look like a stepper hardware error as it is unusual to get such a uniform shift in x AND y yet the print is otherwise correct ie fill is stable. That looks more like a slicing error or an endstops error that triggered a reset on two axes simultaneously. The latter can be can be eliminated if check endstops=0.

Unrelated to this issue, another possible cause of these widespread issues is the higher speeds and accels are taking their toll on the connectors to steppers which are coming loose. A bit of hot glue (high temp not low temp) may help to secure these connectors.
Reply
#98
I actually have 3 machines. Sending the exact same gcode to the other 2 machines works just fine so its not the slicer... and the fact that it prints demos from the SD card fine leads me to believe hardware is ok.... so the gcode is either getting jumbled on the way to the printer or the printer is reading it wrong... odd
Reply
#99
DOH! It was a simple but unexpected solution for me. After checking everything I could think of I was just staring at my machine in disgust when I noticed that my wifi router and a bunch of power cables were DIRECTLY under my machine on the desk. I moved my machine 2 feet to the other side of the desk and BOOM, perfect prints again. It's an RF issue. At least it was for me.

WAY TO SHIELD YOUR PRODUCT XYZ!
Reply
OK,

So this one has me a little stumped. I printed a tall owl on my printer, and it came out perfect. So then I tired the print that failed before, and it failed again. That part I can except.

Here is the weird bit. The first time I printed this model (T800 terminator skull on a stand), I printed scaled at 80%. The print failed at 30.5 mm high, the x axis shifted by 7mm. The rest of the print continued until I stopped it at a height of 75mm.

The second time I printed the model, I printed it at 100% scale. The print failed at 30.5mm high, the x axis shifted by 7mm. I then stopped the print shortly after.

So does anyone have an idea what could cause this print to fail at exactly the same height, by shifting exactly the same amount? I used Slic3r on Repetier host.

I have printed this model before using my reprap and using Slic3r and it printed perfectly fine. There are no errors on the model as I ran it through netfab first and fixed the problems it had.

Answers on a postcard Smile

Thanks, Matt.
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)