Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.0A and Repetier Host .92 Layer Shifting Support Group
#61
@Svekke use repetier and edit EEPROM you will see the accelleration for printing and travel for X Y and Z
default values are :
/** \brief X, Y, Z max acceleration in mm/s^2 for printing moves or retracts. Make sure your printer can go that high!
Overridden if EEPROM activated.
*/
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000
#define MAX_ACCELERATION_UNITS_PER_SQ_SECOND_Z 100

/** \brief X, Y, Z max acceleration in mm/s^2 for travel moves. Overridden if EEPROM activated.*/
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_X 1000
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Y 1000
#define MAX_TRAVEL_ACCELERATION_UNITS_PER_SQ_SECOND_Z 150

you can decrease to 900 to test for X Y
Reply
#62
Sensor issue is common reading at all thread forum, here another one : https://forum.voltivo.com/showthread.php?tid=8286
switching the endstops using the top door as spare seems solving issues - Davinci is a cost down product so some component will have failures for sure.
Reply
#63
Guess finding new end stops are in my future...thank you luc for all your help...I'm now printing again...I'm 3 hour into a 12 hour print...fingers crossed!!!
Reply
#64
Well can also be the signal wire too close to stepper wires, because wire is not protected from noise, it can generate false signal also.- it just happened to me on another printer - I even cannot homed, when it was working before, I had to armored sensor wires to recover, I guess it is EMI perturbation but I am not electronic guy, so ....
Reply
#65
Indeed,

Endstop issues like this are almost always noise issues rather than a failing in the endstop device. Replacing the endstop itself will do nothing. Shielding/grounding and other methods (pull down resistors etc) to reduce interference can help but sometimes the board design means you are limited and just need route to avoid all the noise.

Obviously they have changed something/s in the new design which increases the noise and they don't poll the endstops during printing with their own firmware. At least I hope this is true and we have a solution.

Now if only someone can work out how to reflash the firmware back to OEM for the sake of warranty returns etc.
Reply
#66
Well, the wires connecting to the x stepper suck. It looks like they broke internally. I cut them and replaced with thicker wire and no more lost x steps! It was getting really bad for a while.
Reply
#67
I have the 1.0A without anything marked J37 - no pins and no pads. I'm still on the stock firmware it shipped with; I believe it was 1.0.1. Of the three things I've tried to print in the last four months, two of them have had this layer shift problem. I was using Slic3r rather than the XYZ slicer, but everything else was stock. So the root cause is not related to the Repetier firmware. I should probably update to the latest XYZ firmware and see if it helps...
Reply
#68
Do I have layer shifting of is this something else... I sliced with S3D... I don't know what I'm doing wrong... this isn't the first time this has happened to me
[video]https://www.youtube.com/watch?v=xlw5ZB9KasE[/video]
Reply
#69
I'm having the problem below, is this same issue?

I'm having problems with my DaVinic printer not moving correctly on the x axis. I have one of two things happen to me:

When I try to move the print head (repetier or from the printer) on the x axis it will move it will move correctly is the positive direction, but just make noise (like it's stuck) in the negative direction while changing the coordinates (repetier and on the LCD). This is the majority of the time

The other option is that printer will start printing and when it needs to return on the x axis it will not do it fully and ends up printing everything left. This occurred during the 18th hour of a 20 hour print and is when my problems started.

Some other strange things, it will return "home" correctly when I first turn on it, but will not if I move it using either the printer controls or repetier it rams into the back of the printer.

Your help is greatly appreciated.
Reply
#70
So, can anyone vouch for what seems to be the best solution to try first?

Edit: All new wires for the entire X axis, swapped endstop, and a fan blowing directly on the board near the stepper drivers seems to have fixed it. It wasn't fun, but it prints good now.

Update 2: Still no missing steps, even with several consecutive 3 hour prints with no power cycles!
Reply
#71
Check the X axis home position sensor harness at the point of the zip tie. I had two of the three red wires broken.Repaired and working great.
Reply
#72
FYI : I have set
#define ALWAYS_CHECK_ENDSTOPS 0 by default in FW master branch, I think it is not big deal to apply for everyone and it will help people who do not check this thread
Reply
#73
And what are the consequences of this change for the rest of us with fully working endstops? Should we care to set it back to 1 before updating? I'm not really sure what this define does exactly...
Reply
#74
no consequence - actually I do not see the goal of checking in permanence outside of homing function if endstop position is reached or not, because negative position are allowed - so won't change anything
Reply
#75
I've also had lots of layer shifting in the X-axis and my printer is a 1.0A with stock firmware (actually version 1.0.5 right now). It has been slowly getting worse and was definitely worse when printing parts that extend to the front half of the bed (closer to the door). I was expecting that the issue was with the wire harness to the X-axis stepper motor, partially based on trouble and trouble shooting I had previously completed on the Extruder Stepper motor (issue there was a broken wire in that wire harness).

Finally got the parts and had the time to make a new wire harness with better quality and slightly thicker gauge wire for the X-axis motor and so far the problem is solved. A part that covers an area of the bed of about 6 inches by 2.5 inches and had failed with shifted layer the previous 3 attempt to print had now been printed 3 times with no issues.

If you are having layer shifting this could possibly be the issue. When I first had this problem it was intermittent, so a change else ware on your printer (firmware settings or other) or in how you do the print may appear to fix the problem simply because the failure doesn't happen consistently. Also, it will get worse over time, so it starting to happen after flashing firmware might just be because you've used the printer enough for the failure to start occurring and not because of the firmware change.

During my trouble shooting of the X-axis stepper motor wire harness I had completely removed the harness to checking conductivity of the wires while applying stress to them but did not find a break or open in any of them. But the conditions of an ohm test do not represent the amperage load that the wire needs to deliver to the motor for it to work correctly. A good conductivity test on a wire doesn't mean it is a good wire. Once this failure starts to happen it will continue to get worse because of the heat generated at the bad spot in the wire (high resistance point) and arcing that is likely happening between broken ends of wire strands resulting in more damage in that area.
Reply
#76
I agree with you it is not an issue related to firmware as also mentioned by David before but wire/sensor.

But cannot change the title and anyway the software is always the usual suspect :pinch:
Reply
#77
So you're telling me that the wire harness went bad after I flashed Rep .92 and then fixed itself after I went back to stock firmware? I haven't had one single misstep after 100+ hours of prints now on the stock firmware.

I'm not saying that the wire harness isn't the issue. It obviously has been for some, but I don't think that is in any way related to what we're experiencing here.
Reply
#78
As I mentioned, the failure is intermittent. I had several failed layer shift prints a couple of weeks after getting my printer back in mid January. I suspected a bad plug connection or wire back then, unplugged the connection on each and wiggled wires around, and then the problem was gone.

A couple of weeks ago (after about 300 more hours of print time since previous fail) it was back, and getting worse to the point that almost every print failed, included all 3 of the last tries on the part mentioned in my previous post. Also as mentioned, I haven't flashed any other firmware on my printer, stock the entire time.

I hope your printer keeps working correctly. The point of me posting here is to make sure people are aware of a very likely cause of this problem. If you printer does start to have this issue again I hope the information I've provided here helps you get it back up and running again.
Reply
#79
how did you set the endstop option to 0. is this option in repetier host or ?
Reply
#80
Evan how did you flash back the 1.0A to stock FW ? - I think many people would be interested by the process, as several people said revert is not possible - so it would help a lot of people.
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)