Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier-Host firmware upgrade
#1
Attempting the Repetier-Host firmware upgrade, all appears to go correct, except when I look at 'System Version' on the printer it displays Da Vinci 1.0 3.15-03-02_0.1 Repetier 0.92Mod

i have the following setting in Ardunio - major version 3 and version build 0 (since i jumped JP1)

Should the display Da Vinci 2.0?
Did I miss a step?

thanks
Reply
#2
#define DAVINCI 1 // "1" For DAVINCI 1.0, "2" For DAVINCI 2.0 with 1 FAN, "3" For DAVINCI 2.0 with 2 FAN
#define MODEL 0//"0" for first generation (jumper JP1 to reset ) , "1" for new generation (jumper J37 to reset)
#define REPURPOSE_FAN_TO_COOL_EXTRUSIONS 0 //Setting this to 1 will repurpose the main Extruder cooling fan to be controlled VIA M106/M107
//Warning: for DaVinci 1.0 need to add a permanent fan with power supply to cool extruder
#define VERSION_MAJOR " 1"
#define VERSION_MINOR_YEAR "15"
#define VERSION_MINOR_MONTH "03"
#define VERSION_MINOR_DAY "02"
#define VERSION_BUILD "1"

//version
#define UI_VERSION_STRING_FULL VERSION_MAJOR "." VERSION_MINOR_YEAR "-" VERSION_MINOR_MONTH "-" VERSION_MINOR_DAY "_" VERSION_BUILD "." DAVINCI_TYPE MODEL_TYPE

seems version build is 0 should be 1 and you compiled for 1.0 not 2.0 old generation
Reply
#3
so my settings should be the following?

// ################## EDIT THESE SETTINGS MANUALLY ################

#define DAVINCI 1 // "1" For DAVINCI 1.0, "2" For DAVINCI 2.0 with 1 FAN, "3" For DAVINCI 2.0 with 2 FAN
#define MODEL 0//"0" for first generation (jumper JP1 to reset ) , "1" for new generation (jumper J37 to reset)
#define REPURPOSE_FAN_TO_COOL_EXTRUSIONS 0 //Setting this to 1 will repurpose the main Extruder cooling fan to be controlled VIA M106/M107
//Warning: for DaVinci 1.0 need to add a permanent fan with power supply to cool extruder
#define VERSION_MAJOR "2"
#define VERSION_MINOR_YEAR "15"
#define VERSION_MINOR_MONTH "03"
#define VERSION_MINOR_DAY "02"
#define VERSION_BUILD "1"

// ################ END MANUAL SETTINGS ##########################

>


I compiled the above and upload but still see 'Da Vinci 1.0 2.15-03_023.1.1 Repetier 0.92Mod' under settings->system version

Am I just looking in the wrong place?

thanks
Reply
#4
when you compile you need to change according your DaVinci :
#define DAVINCI 1 // "1" For DAVINCI 1.0, "2" For DAVINCI 2.0 with 1 FAN, "3" For DAVINCI 2.0 with 2 FAN
#define MODEL 0//"0" for first generation (jumper JP1 to reset ) , "1" for new generation (jumper J37 to reset)


So, if you have a 2.0 as you said you expected 2.0 in first post :
#define DAVINCI 3 // "1" For DAVINCI 1.0, "2" For DAVINCI 2.0 with 1 FAN, "3" For DAVINCI 2.0 with 2 FAN

so you will have 1.15-03-02_1.3 for the version number if you do not do any another changes
Version is the system version according to what have been compiled

What arduino version are you using ?
Reply
#5
ok, caught up with my own confusion....

I was changing VERSION_MAJOR and VERSION_BUILD, instead of changing the DAVINCI and MODEL line.

Will recompile, have a print going now...

thanks for all the help and sorry for the confusion....Smile
Reply
#6
Hmmm - Ok that is a good point, I will move version definition under
// ################ END MANUAL SETTINGS ##########################
to avoid future identical confusion
Reply
#7
thanks.....all is good now......now showing correctly Da Vinci 2.0 1.5-03-02_1.3 Repetier 0.92Mod


now off to discover proper settings and work out if the filament jams that I was getting when I went back to original XYZ firmware was bad XYZ firmware or bad extruders Smile

thanks again....
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)