Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier with B57560G104F and Bed Thermistor Troubles
#1
I just installed a hexagon hot end and it comes with a B57560G104F thermistor. I cannot get this thing to read the correct temperature for the B57560G104F thermistor or the bed (stock thermistor)! I'm out of ideas. Here is what I have tried for the extruder:

[ul]
[li]I tried creating a user table using the online thermistor calculator and multiplying the ADC number by 4 and the temperature by 8.[/li]
[li]I tried using a generic thermistor table and inputting the correct values such as R1, R2, beta, etc.[/li]
[li]I verified I am reading ~100 kOhms on the thermistor at the connector on the main board. I heated up the thermistor and saw the resistance drop as expected. The thermistor seems to be fine. I have even tried with another thermistor (I have a few spares).[/li]
[/ul]

I haven't tried to trouble shoot the bed yet but it worked before I flashed the latest Repetier from github using arduino 1.5.8. I have never had thermistor issues before, either the extruder or bed.

I have attached my configuration.h file. Please tell me there is something stupid somewhere I am missing because I'm out of ideas Confusedilly: https://forum.voltivo.com/images/Configuration.txt
Reply
#2
well you try to use
#define USE_GENERIC_THERMISTORTABLE_1
when bed is not generic table, so should bring some mess I guess

I suggest you to comment back
//#define USE_GENERIC_THERMISTORTABLE_1
as before and modify the extruder table manually if you can find good values
Reply
#3
I have tried with and without that #define and don't see any different results. I have also tried all the default types available and still don't have a temperature that makes sense. Any other ideas?
Reply
#4
I see several changes so I just guessed - is bed working when back to original Configuration.h ? if not it means there are other changes you did in another place
Reply
#5
I just tried the Configuration.h that is on github with no changes and the temps are still not correct. Also I should note that I erased my previous EEPROM file and restored fail-safe settings.
Reply
#6
did you try with a clean FW without any modification ?
Reply
#7
Yes, just tried again and still the same temperatures with an unmodified FW from the current master on github. If it means anything, the extruder thermistor is sitting out at ambient (~20C) and it reads 161C. The bed is reading 116C.
Reply
#8
so issue looks like hardware not FW - and if you said it was working before you apply the changes for the new thermistor - something may be damaged
Reply
#9
This sounds like when I shorted out my heated bed. Something on the control board was toasted (possibly a fuse resistor)... and the bed constantly read 130C and the extruder was stuck at 119C. New control board fixed the issue.
Reply
#10
Did you ever find what actually failed on the board? I'd prefer not to have to replace the whole board.
Reply
#11
Unfortunately no, I had to send in the damaged board to get a replacement under warranty. There are a few other threads on here about the fuse resistors, would be a good place to start checking.
Reply
#12
I have looked over the board and I dont see anything blown up. I'm getting normal voltage on the rails. What is curious is the voltage divider resistors both measure ~585 ohms but this is probably because it is in-circuit. I rung out the black wire on the connector (yellow is 0V) and it goes back to pin 91 on the micro. From pin 91 to 0V is also ~585 ohms so its definitely a red haring from measuring resistance in-circuit.

Any other ideas? I really don't want to buy a replacement mainboard or a smoothieboard right now Tongue
Reply
#13
Yellow is 0V? Yellow should be 12V, every yellow wire from the power supply should be 12V.

With my board, nothing looked obviously blown but I didn't get the chance to try and trace it out.
Reply
#14
I'm sorry, yellow on the "Fan" connector. It is the 0V lead for the thermistor.

And on second thought, I think the resistors are in fact blown or damaged. R1 is 10k and R2 is 4.7k but I'm measuring them both at 585 ohm. R1 and the thermistor are in parallel, so (585*100000)/(585+100000) = 581. Voltage divider between 585 and 581 ohms with a 3.3v source voltage is 1.64v which is exactly what I am measuring. Sigh...guess I need to order some tiny resistors or get some bodge wire to fit normal sized ones Smile

Edit: Correction, R1 is 10k, not 1k. That puts the measured voltage supposedly at .18v but I'm not getting that...
Reply
#15
OK, forget that. I took the resistors off and measured them and they are fine -- R1 is 10k and R2 is 4.7k. There is a short or partial short? to ground somewhere which is causing this 585 ohm nonsense...
Reply
#16
Keith is the expert to fix board you should contact him
Reply
#17
It's probably obvious, but don't forget to check all of your connections. If you fried one of those resistors, that means you likely have a short somewhere. Before you blow something else up, or another resistor... double check every connection and wire.
Reply
#18
if the voltage goes up and down woth temperature on the MCU input pin, but the reading of temperature never changes, then there is a very good chance the MCU has failed. You might be able to find someone to replace the main chip locally.

Alternatively I can change the mcu for $75.00 plus shipping assuming there are no other problems. If there is anything else wrong I will give you a quote before additional work is done.

Kieth
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)