Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to use Repetier untethered?
#1
Hi folks,

After finally getting fed up with the XYZ firmware, I decided today that I would go ahead and put repetier 0.92 on my DaVinci 1.0. So far I think I like it, once I managed to manually calibrate the bed. However, I did not realize that the printer has to be tethered to a laptop to keep the print going! I'm so used to XYZ where the file just kicks over to the printer and you can walk away with your laptop.

I have a couple of questions about how I can get better functionality out of this. For starters, my printer is in a university lab building and I run it using my laptop, so I need to be able to leave once the print has started. I don't think I can do a raspberry pi / octaprint setup since I can't control the routers and port forwarding on the university's network.
Sorry if the solution to my problem is already on the forum, but I looked around and couldn't figure it out. Can I load gcode directly onto the SD card somehow? I tried using repetier to put a file straight on the card, then used the printer to select that file, but the print aborted almost immediately. Is there a trick to this? Do I HAVE to use an SD extender and just manually put the SD card in my laptop to load files? Or can I upload the files to the SD card over USB?

Also, is there a different way I could use a raspberry pi to drive the printer? Can I put arduino software and repetier host on the rpi and just run straight off of that with a keyboard and mouse?

I always get great answers from you guys, thanks for being so helpful!
Reply
#2
normaly printing from SD it is working, I only use like this, but me I use wifi SD card as file transfert is faster
Reply
#3
So I've tried it a couple times now, and every time it stops the print while still on the first layer and says:
Extruder has not filament! Push Ok to go to change filament

It decides to give this message at a different point during the print each time. But when i do a print via usb as a job in repetier host, the whole file prints just fine
Reply
#4
ok this is different, do you use clear filament or dual extruder?
if use dual extruder and have issue it means you have some call to empty extruder in gcode that generate the message and go to pause
if use clear filament, sensor do not see it, you can override it by fesactivaye filament sensor in printer settings
Reply
#5
No, this is black filament in a DaVinci 1.0, only has a single extruder. Like I said, it works just fine with repetier host, it just fails if I try to run the gcode from the SD card. I'm guessing it is something in the header, but I have no idea what I'm supposed to do with that
Reply
#6
this strange, in all case disable filament sensor will make message and pause to disapear, the pause is not working if using usb connection as no command exists to ask host to pause from printer
you have 1.0 or 1.0A?
Reply
#7
Thanks for the idea, I will try this next time I am in the lab. This is a 1.0, not the newer 1.0A
Reply
#8
ok so I guess sensor wire has been broken
Reply
#9
Looks like you were right luc! I disabled the filament sensor and now it prints off of the SD card, quite interesting.

I have another question too. Is there a reason that the bed and extruder don't heat up simultaneously when I start a print? The bed heats up first, then once it's at temp, the extruder heats up. It only adds I guess another 70 seconds or so before the print starts, but it seems unnecessary to me.
Reply
#10
all commands are generated by your slicer, it is the one which says heat bed and wait then heat extruder and wait
but it is common behaviour, I guess it is to avoid to drain too much power at once but actually I do not know

you can edit your GCODE to move your heat extruder command close to heat bed but before wait for bed to be stabilized command
Reply
#11
I need some help disabling the filament sensor on the Da Vinchi 1.0a. Is there a way to do it?
Reply
#12
in settings - printer menu
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)