Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
1.0A – No power to extruder heater fix
#1
What happened:
Just as I was beginning a print, helf-way through the first layer, the extruder started to click from the filament not feeding anymore. A quck check at the temps showed the hot end had dropped to 130C. I canceled the print and reset thinking it was just a software hiccup.
Ran a head cleaning procedure, and the head would no longer heat up. Uh oh, time to start diagnosing the problem.

Diagnosing the issue:
First I checked for power. Restarted a head cleaning cycle. No power at the hot end, no power at the connector on the logic board.

I pulled the heater cartridge, and threw it on my multimeter. It was showing 1.3 ohms of resistance. It had gone way out of spec. For a 40 watt heater as marked, it should have been 3.6 ohms. I ordered a new heater cartridge and replaced the defective one. This fixed what caused the issue in the first place.

Now to track down and repair the damage on the logic board.

I checked the power from the PSU, everything was good there.
Next I started following the traces to the extruder heater connector, and found my suspect part, R271 (right above the heater connection, see attached picture) It was singed and I couldn’t make out the markings.

There was no continuity across R271. The top side (as seen in the picture) was connected directly to the 12VDC pin on the PSU, and the bottom side was connected directly to the heater connector.

It looks like XYZ used a resistor as a fuse on the 1.0A boards. Stupid! Let’s fix it!

I removed the surface mount fuse and jumped the connector with solder and bit of copper wire.

I still wanted a fuse, so I added an inline fuse holder on the heater supply cable (see the picture, make sure it’s on the hot 12VDC leg) with a 4 amp fast-blow fuse.

That fixed my problem, and I’m back up and printing! I hope this help you if you run into the issue as well. This only applies if you have the newer DaVinci with the 1.0A board.

(BTW, been lurking for a while, lots of great info here and thought I should contribute)[Image: R271.jpg][Image: fuse.jpg]
Reply
#2
Thanks Peter. I have the same problem in my 2 months old printer. Thanks to you post, I have now fixed the printer and up and running. Since it is a duo extruders printer, I think it is also necessary to bypass the 1/4W SMD resistor on the second extruder so that the 40W extruder can work properly without burning the inline 1/4W resistor.
Reply
#3
I can't thank you enough I purchased this printer brand new and after two trial prints the thing died. I searched and searched and couldn't find a resolution after contacting the supplier i was advised I had to deal with the manufacturers direct. So I get in touch with the manufacturers and get no support. Thanks again all fixed and successfully printing God Bless
Reply
#4
I have 2 DA VINCI... The newest is the 1.0A...

And I did make one print with success.... THEN next day I did have the 0011 ERROR on screen.

EXTRUDER OR BED CANNOT MAKE IT TO THE SETTING TEMP POINT...
I made a second and third try only to have the printer received the program and the EXTRUDER even had the 215C then came to the front...
THE LCD had the BUILDING>>> and the time run without the extruder to move...For some reason the EXTRUDER stays after to 138C~135C ..

I thought the problem was of the SLIC3ER ... Because I do not use the XYZ PRINTING suck slicer...

Anyway I did make a slice with XYZ printing... The machine started and make a roll of extruded filament around the nozzle tip...

CANCEL AND THEN ANOTHER TRY...

AGAIN WITH SLIC3R only to have the same clicking noise on the extruder and NO filament at all.

NOW I WILL CONTACT WITH THE SUPPLIER AND ASK WHAT?????

THOUGH THANKS FOR THE PRECIOUS INFO..

THANK YOU VERY MUCH MAN... KEEP THE GOOD WORK
Reply
#5
I had the same problem with R271 going bad. I have what I think is everything working correctly, the heater cartridge is at 3.8 ohms, but I have 12 volts on both pins to the heater when it is shut off, and nothing when the heater is turned on. Even when I have 12 volts, the printer is not heating. what should I have on the pins to have the heater heat? I have tried two different heater cartridges, and I got the same result on both. Any Suggestions?-
Reply
#6
Hi,
I think you shorted the two pins together. Only one pin connected to R271. Just clean out the R271 repair to make sure the two pins are NOT connected first and then jumper the R271 with a short wire.

Hope this helps.
Reply
#7
Ok, I put one pin on each side of the resistor, would you mind posting a picture of what you did with the wire, I just can't visualize I. Thanks for the help
Reply
#8
Now we know. Wrong way to do this

Imagine the resistor R271 is just a wire. It is NOW broken. You need to reconnect this wire.

Resistor R271 short the two points on the resistor with a piece of wire

Resistor contact X is connected with a piece of wire to contact Y


Peter has posted a nice pic of this before so please follow it.

Connector Pin A Top (12V) should be
Pin B botton (DONT touch)



There is NO need to wire connector Pin A to this resistor because the PCB should make this connection already.......


Also worth doing is to put an inline fuse on the 12V wire connecting to Pin A to the heater cartidge as a protection (4A fuse) will do as this gives a 4x12V =48W protection.
Reply
#9
I just couldn't make out what I was supposed to be seeing in Peters picture.

So basically I need to put the top of the resistor on the board, and attach a wire to the bottom of the resistor going to the bottom of the two pins?
Reply
#10
Last attempt.

All you need to do is to solder a wire across the resistor R271. This will get you the 12V to the Extruder. No need to solder wire from CONNECTOR. After this test you have 12V on the connector (pin on the left next to the 12V label)

See the attached diagram. The wire is in BLUE.

BTW you may have caused damaged to the board with wrong wiring already......

Good luck.
Reply
#11
ok I did this, I have power to the left pin and nothing to the right pin, I assume that that the left pin is ground. Any idea why this thing is not heating? I had previously replaced R271 so their was already 12v to the left pin.
Reply
#12
Good to hear that you have the 12V on the right pin.

The next step is to trace the 12V all the way to the heater.

1. Check it reaches the connector at the extruder
if it does
2. Check it reaches the other side of the connector

The connector is known to fail as well.

If the above is all tested ok and you have also replaced the heat cartidge. Worth to check continuity of you earth (the right pin).
Reply
#13
Well... This is embarrassing, it turns out the grounding screw fell out next to the heater, I am still trying to figure out how that happened, but once I out it in everything worked great.

The KS for all the help
Reply
#14
Thank you so much for this fix.

My fuse didn't look blown like yours but was causing problems. After soldering a wire to bypass it (Was a pain) , It's working again. Would have never figured this one out with your help.

If I don't put an inline fuse, what could go wrong?

Also, someone else mentioned this may occur while cleaning your hot end with a wirebrush when then hot end is heating. If the wirebrush touches the heaters bare wire, it can short it?
Reply
#15
If you don't add an in-line fuse, there is no protection if your heater fails or you have a cabling problem that results in a short. The fuse is there to protect the motherboard from this sort of problem. If you have a dead-short or a heater than suddenly starts drawing too much power, instead of blowing a fuse, you will blow out a much harder (or even impossible) to replace part(s) on the motherboard.

Get a fuse holder, get a 4 amp fast-blow fuse and install it!
Reply
#16
Great. Mine was not obvious either. I can only tell using a meter to check continuity (again thanks to Peter's post).

Regarding the wire brush comment, I tends to agree with it. I recall just before the extruder heat problem, my Duo reboot for some reason when I was cleaning the extruder with the wire brush. Seems to the brush had shorted something and tripped the circuit to reboot (now we know it blow up my R271). Need to find out where the live part is and why it can be shorted by a wire brush.......
Reply
#17
I tried to search for the fuse but could only find a 5 amp fuse and mentioned no fast blow out.

Do you have a link of where you got yours?
Reply
#18
I have the same problem except mine is an older board I think. It is F1.0 MB R4 2013/10/30
I don't have the same layout.
Again I have 12v led lit and 12v rail is fine.
It has from gnd pin 12v on both the hot end pins so I guess it is ground switched for the hot end heat control.
Does anyone have any pointers for this board?

This happened when I was trying to sort out the hotend and unplugged it then plugged it back in whilst the machine was powered on. I have tested the hotness with a 12v supply and it works fine.

[Image: IMG_0478.jpg]
Reply
#19
What grounding screw are you talking about? I may have the same problem.
Reply
#20
It is the six large screws that hold the board in place, if they are not put in the holes, then the printer will not work
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)