Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Duo / Repetier firmware - Automatic heat timeout?
#1
Background:
I started a long job overnight. It was still running when I left for work this morning so I let it go. When I arrived at work I remoted in to my home PC to check status via Octoprint. I could see on the webcam that the print head was still moving a few cm above the piece, but not extruding. I'm guessing I ran out of filament (burning through my supply of XYZ stock, so I couldn't visually see how much I had left.)

Seeing that my print had failed, I hit 'cancel' in Octoprint and watched the carriage home and the bed travel down a bit -- but the extruder and bed temps stayed at print temp. I attempted to set the extruder and bed to 'off' and the interface became unresponsive. I SSHd into my Beaglebone and restarted OctoPrint, and then the Beaglebone dropped off the network & so far hasn't come back... Ugh.

My questions:
[ul]
[li]Does Repetier firmware have a failsafe idle timeout for the heaters, whereby it will shut off heat if no commands are received within a specific period of time?[/li]
[li]Is Repetier firmware supposed to recognize when the filament sensor enters an 'out of filament' state? If so, what actions does it take at that point?[/li]
[/ul]

Configuration: Da Vinci 2.0 Duo; BeagleBone Black; Repetier firmware 0.92-Master (last updated 2/17); OctoPrint (last updated 2/17).
Reply
#2
Quote: [li]Does Repetier firmware have a failsafe idle timeout for the heaters, whereby it will shut off heat if no commands are received within a specific period of time?[/li]
No, there is no time out - if heat is on it stay on
Quote: [li]Is Repetier firmware supposed to recognize when the filament sensor enters an 'out of filament' state? If so, what actions does it take at that point?[/li]
yes you need to set filament sensor to On, currently when no filament detected, it go in Pause
Reply
#3
Thank you Luc.

When I got home the bed and extruder were off. It had in fact run out of filament. The filament sensor is enabled & the printer was displaying 'out of filament' message on the panel however it had continued to dutifully follow the instructions Octoprint was sending it until I had cancelled it via OctoPrint. It seems that Octoprint was unaware of the filament state. This leaves me wondering if Repetier server has a tighter integration with the firmware and would provide more control & status notification.

In any case I picked up a z-wave plug in module so that I can kill/reboot the entire system remotely just for peace of mind.
Reply
#4
yes you are correct there is no message to ask the host to stop sending command, that is a pain point...
the pause when out of filament, is today efficient only when printing from sd card
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)