Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Z-Axis only moves down. Possibly inverted.
#1
I just installed repeater and managed to get jogging working over serial. The problem I have now, other than having no idea how to use Repetier, is that the Z-Axis only moves down. When I home the Z axis it will only go down and will make horrible noises if I home it while the bed is all the way down. It will also only move down when I try to jog the Z-Axis I can confirm that the printer is getting the command as it will say that the Z-Axis is now less than it was before I jogged it.

Any help would be greatly appreciated because for the moment at least I have a brick that I can't print with.

EDIT: I am an idiot and I am lucky I didn't brick my printer. So anyone who has the same problem and finds this knows what my problem was it's super simple. I didn't save the updated config file when I was supposed to so the firmware complied for the JP1 board type. I'm assuming that this meant that it had the wrong pins assigned for shit and thus didn't work correctly. This also explains why it only went down. I hope no one ever needs this information but at least if they do it is now out there.
Reply
#2
what printer do you have ? what fw do you use ?
Reply
#3
Thank you for the amazingly fast response. I have the Da Vinci 3D JP37. I think I have it sorted now. I didn't save the edited config file with the bit set for the JP37 model.
I'm running a small test print now. We'll see how it goes.
Reply
#4
Yes this the behaviour using 0.92 with MODEL 0 (old generation) on new printer generation
No worry you cannot brick your printer flashing wrong repetier FW - just rebuild using correct configuration, reflash and it is Ok
Reply
#5
Thanks. That's good to know. While you are here I have to ask, is it possible (and if so how) or worth it to adjust the Z axis offset in firmware? The nozzle is pressing into the plate and I would rather not adjust the screws to fix a software problem.
Thanks again for the fast response.
Reply
#6
you can ajust using repetier and editing Zmin in EEPROM but this is dangerous, if you do any Z Homing with your nozzle in middle of the bed it will press it as homing is handled by sensor not by software, Zmin is only used when printing

Using XYZ you do not have the possibility to Jog under Zmin and do Zhoming, but in repetier it happen, sorry the best is to redo bed leveling using screws
Reply
#7
I actually just fixed it. I changed
#define Z_MIN_POS 0
to
#define Z_MIN_POS -2.52
First I measured 2.52 as the distance that it was pressed into the build palate. So this is just correcting it. I'm running a print now to see how it goes.
EDIT: Worked flawlessly. I literally just added $1000-2000 in value to my printer. This is amazing. Huge thanks to all of those who made this possible.
Reply
#8
This is wrong. Anytime you home Z with the extruder in the bed you'll still hit the nozzle badly. Do what luc said to fix the "problem" (not really a problem, just incorrect leveling).
Reply
#9
I don't understand what you mean. When it homes it's using the optical sensor. It never touches the bed. I've printed several times now and it's working flawlessly. When exactly would it hit the bed?
Reply
#10
The nozzle would hit the bed if you ever home the bed while the extruder is anywhere over the printing area. While it may not be so common, it's better to avoid the risk of it happening and potentially cracking the bed. At any rate the bed should be leveled such as at Z = 0 the nozzle is just shy of touching the bed. That's the way it was designed to be. If you wanna do it wrong then it's up to you.
Reply
#11
You are mistaken on two fronts.
First, the axies home in the order X Y Z that means that the cart would be in its home position before the bed moved at all.
Second, the Z axis is homed with the optical sensor meaning that the distance is consistent regardless. When you start a print the bed drops into the home location 0,0,0. This effectively leaves the bed 2.52mm lower than normal.

This is the same technique that is used by the X and Y axis that allows you to actually print on the build plate. Otherwise the printer would have the home, 0,0,0, over the drip bucket. The drip bucket is considered a negative location.
Reply
#12
I think I may be having the same trouble as you Hunter. I zero the bed using the home all function in the printers menu, then proceed to level my bed, getting the tip of the extruder approx 0.2mm off the bed evenly across the bed. When I start a print in repetier I noticed the bed drops a little and the nozzle is sitting too high off the bed, resulting in a very average start to the build.
Reply
#13
No, I am not. You can always jog each of the axes individually, as well as home them individually, either via custom gcode or using the RH buttons or the printer menu. That's when you are more likely to run into such issue. But hey, if you like it that way, be me guest. I'm not going to put a gun to your head so that you fix your printer Smile
Reply
#14
If you tried to home just the Z axis it would smash the build plate into the nozzle regardless of the setting I fixed. If you home the Z axis you are required to have the print head out of the way or you will smash it. All I did was fix the offset.
Reply
#15
About how far would you say it is off the build plate when it goes to print?

You are supposed to use a sheet of paper and adjust it until you can feel the nozzle tugging on the paper when you pull on it. If you are leaving a 0.2mm gap it will probably give you a layer height of 0.3-0.4mm because paper is only about 0.05-0.1mm thick.
Reply
#16
You won't smash anything if your bed is properly leveled. Have you noticed those 3 screws underneath it? What do you think those are for...?
Reply
#17
Those are for leveling the bed. Not changing the height. There is no reason to screw up the leveling that it already has to fix a problem that isn't there if you don't home things wrong. Thank you for the help though.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)