Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Extruder and bed turn off in the middle of a print
#1
I have had the same problem for the last 4 prints. in the middle of a print my extruder and bed turn off but the print continues to air print like its going to finish the print. on the screen i get a error "def" where it would normally show the real time temperature. does anyone know how to fix this? or troubleshot. Originally i thought it was the plug that connects the heating cartridge together. So i clipped the plug off and soldered the wires together. that didn't work so thought i would reach out to the community for help.
[Image: image11.jpg]
Reply
#2
Are you running a recent version of Repetier 0.92? I had a similar issue that was fixed a while back in the firmware which would cause exactly this issue when running an additional extrusion cooling fan powered by the stock fan connector.
Reply
#3
Yes,I am running the current version and I do not have any additional fans or accessories installed on my machine. I've been running the firmware for a little over a month. And the problem only started a couple days ago. It's a little frustrating.
[Image: image.jpg]
Reply
#4
Then it's probably safe to say that you have a broken wire somewhere.
Reply
#5
I'll bust out the voltmeter and start testing connections. If anyone else has experienced this problem please feel free to share your experience. I've had nothing but bad luck with this machine. First 2 broken bearing mounts, then filament Cartridge not registering on the da Vinci software, my glass bed is not perfecly flat, and I still can't get perfect circle prints. This is just the icing on the cake.
Reply
#6
As a side note, I tightened up my belts a bit with these tension springs and it went a long way towards perfect circles. They are still off a tad in one spot but much much better than before.

http://openbuildspartstore.com/timing-be...on-spring/
Reply
#7
that's a really good idea. thanks for sharing that tip. uninformatively my glass bed broke today when i was pre heating it for a print for further testing of my original problem. So it looks like my machine is going to be out of commission again for a couple of weeks. luckily Ive documented every print, and every problem Ive had with the printer good and bad. so today seems like a good day to turn all off my video footage into a review of this unit.
[Image: image12.jpg]
Reply
#8
I upgraded to .92 last week. When printing off of the sd card I kept getting the same problem. Small prints would be ok, but longer prints the heaters would shut off. The last few prints I printed from pc. Then the heaters stayed on. I had .91 installed for a month with no problems and made no recent hardware changes.
Reply
#9
I was also printing off the sd card. And my print was large in comparison to everything else I've printed. That could have been my problem. Once I get my machine back up and running I'll see if that works. Thanks for sharing Chris
Reply
#10
I have made several more prints and still get the def error. I've made several 4 to 6 hour prints that worked. A print can fail and I retry with success.

When a print fails I usually usually power cycle the machine in less than a minute. I only touch the power and the display shows the correct temperatures. I checked the connections and they are all tight. Possibly a short, but everything still work a minute later?

A month ago I had the connector for the extruder heater fail. As a temporary fix I used wago quick connects and wrapped with tape. I double checked and they were still secure. When it failed there was no error, just temperature didn't change.

Looking at the machine the connector for the temperature sensor looks cheaper. Has anyone had a problem with it failing?

Trying to figure out if this is a hardware or firmware problem. It first happened after my upgrade from .91 to .92. I like the menu layout of .92 so prefer not to downgrade.
Reply
#11
0.91 based does not have decoupled feature that is why never happen before.
any way last week I imported in 0.92 several changes for decoupled feature and temperature reading, and a compilation define has been created to enable/disable decoupled feature
it may help
Reply
#12
I had 3 def errors today. The first 2 were between 1 to 2 hours before error.

Trying to narrow down the problem I decided to start with the bed heater. I started the print then disabled the bed heater. I had a def error halfway through the first layer. Restarted and now over an hour without error.

I have been running at 270c but some times turn it down to 260 and still get the error. Would the temp of the extruder cause problems with the temp sensor?

The disable decouple feature seems like it would bypass the error. Would it override a safety? Earlier when unplugging the machine from repeater host I caught it not stopping at temperature and climbing. If there is a real problem with communication in the machine I would rather it stop a print before destroy the machine.

So far with some upgrades it turning into a good machine. Several corners were cut to make it an affordable starter machine. There have been several failures of the extruder heater coupler. Are there any other parts of the wiring harness that are weak links?
Reply
#13
the few times I got decoupled errors was when my connector was loose or fan was not working properly.
yes disabling feature bring less safety but put same level as 0.91.
additionnaly 0.92 has watchdog so if printer is unresponsive it will reset which is better than 0.91 for safety.
also if you add the usb patch, this will avoid to lock printer if usb connection is lost, so temperature should be always under control.

That said 270 is pretty for davinci from temperature and power supply point of view which could affect the temperature stability and generate defect sensor issue.
Reply
#14
I've upgraded to using octopi for printing. There is watchdog does that work with .92 firmware? If that means safe I'll upgrade and disable. Just don't want to override the machine saying there is a problem if it really is.

A few times I did get a jam I unplugged the main extruder harness and pulled out the extruder. Recently I noticed def error. Before I could unplug, fix error, plug back in, then print.

I've been using "premium filament" from ebay that split and tore apart at 240. I read for that kind of filament 270 and up worked better. Recent prints have no splits. Not ruling my error out but so far hotter is better. Also Covered top opening handle with some clean socks to stop heat loss. The sides of the printer seem warmer. Maybe combination helped make prints work.
Reply
#15
I've the same problem ("DEF" on LCD screen and loss of heaters) with .92 on a 1.0 fairly early in long SD card prints with PLA twice recently. I'm using an extra fax blowing at the nozzle with all doors open, and with the extruder set at 220, the measured temp was varying between 211 and 217. I've been playing with the extruder temp settings, and did not have this problem with severe successful but relatively small PLA prints. Am I getting the error because the measured temp drops too low? I've never had the error with long ABS prints and the extra fan off.
Reply
#16
I too am getting the "def" error on .91, but I have recently switched to an E3D V6. Did I possibly wire something up wrong or break something? I can see temps in Repetier host, but the Extruder temp is saying -20 ambient. (Haven't changed the Thermistor Tables)
Reply
#17
Yes bad air flow control can generate the error - especially if your extra fan is blowing on nozzle/extruder instead of filament/ extruder/model
Reply
#18
yes if your thermistor detect -20 it generate sensor error as under -10 it is considered a problem at ambient temperature - you have a connection issue or you changed the thermistor by a one which need a new table
Reply
#19
How do I change the thermistor table, as I can't find it in repetier host. Or is the option somewhere else?
Reply
#20
In FW - several threads talk about this
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)