Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Davinci firmware 1.2.4 downgrade
#1
hello to all,
i'm a new user and i bought a used Davinci 1.0
unfortunately it was an early version (the one with motor drivers on socket) but without jumpers soldered
most unfortunately it was with firmware 1.2.4.
since i didn't found anything here on voltivo regartding that firmware version (neither on web) i supposed it was similar to firmware 1.2.3 (maybe with best cartridge checks algorithm) i was wrong.
i followed the instruction on downgrading to 1.1.J using bossac.exe
after the reset procedure (J1 short) the printer completely disappeared from windows! no unknown hardware found, nor bossac serial, absolutely nothing... i think printer is dead, print bed and nozzle heat up, but nothing... can't put any firmware on it, tried with xyzware but it's like no printer is connected to the computer
so BEWARE OF PRINTERS WITH 1.2.4 BECAUSE THEY CAN'T BE DOWNGRADED!!!! you will make junks of your printer if you try... Sad Sad Sad Sad Sad Sad Sad :'(

Juri
Reply
#2
Hi Juri
I have the same mainboard as you. You may be having the same problem that I had when trying to get back to 1.1.J firmware.
It could be that you have another driver or program that is interfering with the bossac driver. Try using msconfig to boot your PC with only the windows services and no startup programs (you can change it back later). Make sure you use a good quality 1.8m USB cable. Your PC should then be able to see the printer on one of the COM ports.

Have a look at Another bricked da Vinci 1.0 ?
I used the instructions in New firmware 1.2.3 , though you won't be able to do step 3 as the DAV commands are implemented in the firmware and your printer has none at the moment.

BTW It's probably fortunate that you have the old mainboard as you can swap between firmware versions and repetier. The new mainboards can't go back to the XYZ firmware once you reset.

Tony
Reply
#3
hello tony,
i didn't know exactly what happened but firmware 1.2.4 is still in my printer
i followed that procedure first time too
[strike]but shortening JP1 do not reset the printer firmware... i tried and tried so many times.... i think firmware 1.2.4 will disable firmware erasing!
[/strike]
i fixed the issue of "printer disappeared from windows" by replacing usb cable,

[strike]i soldered a small wire at JP1 and powered up printer.. it power up normally, i can navigate menu freely with that jumper shortened!
[/strike]
do not know to do now... Sad

UPDATE: STUPID STUPID STUPID!!! i'm an IDIOT MAN!!!!! i was jumpering JP2 what a stupid man i am!

now i resetted and DOWNGRADED to 1.1.J

one strange thing remain: the usb cable is no more useable!!! i do not know why... but no problem, i replaced with a new one Big Grin

thanks again!!!
Juri
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)