Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to flash repetier to your Da Vinci printer video tut
Did you remember to Load failsafe to store the firmware on the EEPROM after you had uploaded the repetier firmware?
thanks for the reply.

After firmware upload (IMO) the CPU should have reset itself, and the printer re-start with the new firmware (with out having to cycle the power).
That does not happen in my case.

Even though I get (in Arduino):
Verify Successful
Set boot flash true
CPU reset

The CPU does not restart:
a) The Bossa programming COM port is still showing
b) I have two black bars on the printer display.
c) the internal light is OFF
d) I do not see any LED on the PCB to flicker to indicate any kind of reset.

I do not have a way to save the firmware on the EEPROM.
I think I have to have the display working to save the FW on the EEPROM.

Am I missing a step in my process?

Somehow it sounds like the correct files were not copied over to the Arduino directory.

I will delete (and un-install) all the download files on my computer.
I will re-download
Arduino 1.5.8 - ( )
and repetier files - ( )

and try again...

I will document all the steps.

I am assuming:
a) the SD card does not have to be removed for any of the steps - correct?
b) the CPU should reset after the firmware upload, and printer should run without cycling the power (I know that I have to save to EEPROM before power cycle). I will have to reconnect to a different COM port (BOSSA port will not be showing)...

Attached is a PDF with detailed step-by-step I am using.

The problem is highlighted in yellow (in the PDF) , here is the summary of the problem:
[li] On the end of the upload, the computer does make a sound, similar to USB being connected.
[li] I watched the Device manager to refresh itself after the sound, but BOSSA programming port is (still) showing in the Device manager.
[li] If I pull and plug back the USB cable (with out turning off the power to the printer) the Bossa programing port is in Device manager.
Nothing else happen...
The board (IMHO) should reset and boot-up, and it does not.
There are still two black stripes in the printer display, Bossa programming port is (still) showing in the Device manager.

any suggestions?

Looks similar to problems I had and the only way I managed to flash was to use a binary upload.

If you run the arduino IDE with preference set to verbose it will show you the binary file created by compiling the sketch in the comments at the bottom which you can copy and rename to location of your choice in a command prompt window. It disappears when you close the arduino window.

Once you have the binary file secured follow the instructions on this video to upload using Bossac

Easiest way to upload I had problems under XP Vista and 10 with drivers this was straight forward and as you already have correct driver should be easy.
Louis thank you.

As I was getting ready to flash the firmware using the route you described, I power-on the printer, and the printer did start with the firmware I installed the night before. It was not configured correctly, as I was messing around with different options in the Configuration.h tab, but it did boot-up, for the first time, with the repetirer firmware.
I reset the processor and load the firmware a few more times. No problem. I can do it at will now.
I the last upload, I made sure that I configured the repetier firmware correctly for my printer, and flashed as I did many times before. And it works.
I did save the EEPROM using the printer display.

The only thing is, that the printer does not re-start when the upload is finished. It just sit there. I have to power down - and power up the printer to switch from the BOSSA COM port to DUE port. Just pulling the USB does not do it. The printer has to be turned off.

I have no idea why I had problems the days before. I did not change anything (software, firmware, process)... I noticed in earlier comments, that somebody had similar experience.

So to anybody that is also trying and it is having issues - keep at it, it is not easy to brick the processor, in the end it (most likely) will work..

thanks all for your help.
The next step is setup and first print.
After shorting the eprom chip I am unable to connect to the printer as a USB com port. Therefore I am unable to use Arduino to flash it.

I'm using Windows 10. I've tried installing the Arduino drivers to no avail. I have tried rebooting in troubleshooting mode. Sadly the Arduino drivers still wouldn't install.

I got the USB port to work for momentarily by reinstalling the USB root hub drivers. Sadly, the Arduino software continued to refuse to update the printer.

Does anyone have any ideas? Thanks in advance for your help.

[Image: DavinciMess.PNG]
Has anybody flashed repetier on J37 board 1.0A with 2.0.1 firmware?
hi guys , I have bricked my Da Vinci 1.0A that I have own for almost 2 years now ,i have flashed it since the beginning i own it with repetier and had to do it a few time for different reasons ,anyways i have not tried it with Win 10 yet , this is what I use on my PC since it was released without any problems with my Da Vinci and so I am trying to flash Luc repetier 0.92 Version , all is going good until I try  compile on Arduino 1.5.8 and get an error message ....


USBCore.cpp:18:20: fatal error: USBAPI.h: No such file or directory

 #include "USBAPI.h"


So with that I can't upload to my Da Vinci
Can anyone help me with this issue, thank you!
(02-01-2015, 09:41 PM)dopesoner930 Wrote: Hello all,

After flashing mine and a buddies 1.0/1.0a I decided to make a video tutorial for those that want a visual. I know there are others out there but I wanted to create one that was extremely quick as in do this do this do this done.

So here is is for those who want to take a look! Hope it is helps!

Hi there, great instruction. Only wish i had read a bit further and not flashed my 1.1 Plus. Really hoping that there is a way to recover it. If someone can give me some ideas i would be extremely gratefull.

If I have the solution,I will tell you immediately!
Recommend a site about Neverwinter Xbox AD

US:+001(209)753-4925  CN:+0086-0551 63858894
Edit: I solved the issue... See my next post in this thread

After running Repetier on my DaVinci 2.0 for the last year, I decided to reflash the printer so I could nuke all of the tinkering I've done...  Only the process is a tad different (Luc's code use to call for Arduino 1.5.8 and now is different) from my last round and I may be missing something.

The entire flashing process works (no errors) but after uploading the firmware to the printer, whether I restart the printer or not, I get black bars on the screen which means the firmware is not working as expected.

I followed the as far as I can tell:
  • Use a jumper on the J37 pins to clear the chip of code
  • Connect the USB to my PC
  • Confirm that the printer was showing up as a com port (COM 3)
  • Download and installed Arduino 1.8.0
  • Download the Repetier firmware from Luc's Repo.
  • COPY the hardware folder from the AdditionalArduinoFiles/Arduino - 1.8.0 -Due 1.6.8 and pasted it in to the Arduino directory in my program files
  • Opened the Repetier.ino Arduino file which opened up Arduino 1.8.0
  • Edited the configuration file for my printer (3 for DaVindo 2.0 Duo w/ two fans...  Two individual fans on the extruders & model 1 because I have the J37 jumper)
  • Set the Tools > Board & Port to the correct settings (Arduino Dual Native USB and Port 3)
  • Compiled the code in Arduino, no errors
  • Upload to the printer (no errors, console logs bellow)
  • Check printer LCD screen (still bars)
  • Restart the printer
  • Check printer LCD screen (still bars)
Notably, when I restart the printer, something must have uploaded because it cycles 'USB device not recognized' error messages in windows.  So SOMETHIng is going on with the printer but who knows.

I've cycled this a few times and can not figure out why the firmware is not taking.  

Any ideas?

Sketch uses 207460 bytes (39%) of program storage space. Maximum is 524288 bytes.
Atmel SMART device 0x285e0a60 found
Erase flash
done in 0.013 seconds

Write 210436 bytes to flash (823 pages)

[                              ] 0% (0/823 pages)
[==                            ] 9% (82/823 pages)
[=====                         ] 19% (164/823 pages)
[========                      ] 29% (246/823 pages)
[===========                   ] 39% (328/823 pages)
[==============                ] 49% (410/823 pages)
[=================             ] 59% (492/823 pages)
[====================          ] 69% (574/823 pages)
[=======================       ] 79% (656/823 pages)
[==========================    ] 89% (738/823 pages)
[============================= ] 99% (820/823 pages)
[==============================] 100% (823/823 pages)
done in 8.425 seconds

Verify 210436 bytes of flash

[                              ] 0% (0/823 pages)
[==                            ] 9% (82/823 pages)
[=====                         ] 19% (164/823 pages)
[========                      ] 29% (246/823 pages)
[===========                   ] 39% (328/823 pages)
[==============                ] 49% (410/823 pages)
[=================             ] 59% (492/823 pages)
[====================          ] 69% (574/823 pages)
[=======================       ] 79% (656/823 pages)
[==========================    ] 89% (738/823 pages)
[============================= ] 99% (820/823 pages)
[==============================] 100% (823/823 pages)
Verify successful
done in 5.736 seconds
Set boot flash true
CPU reset.

Issue solved...  I followed Luc's instructions from this issue in his repo:

I manually downloaded the 1.6.8 drivers and manually moved the new files into my appdata/local folders (not the system folders) and everything worked perfectly!
I have a Da vinci 1.0A with a da vinci 1.0 replacement board, pulled from a working unit and I am using an E3DV6 hotend mod. After successfully installing repetier firmware version 0.92, I get the message "heater decoupled" but the heater wires are soldered, and seeing as they are not polar, as long as the wires contact it doesn't matter which pin goes with which wire. Additionally, the heater cartridge heats, but the thermistor does not register the heating?

Forum Jump:

Users browsing this thread: 2 Guest(s)