Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
How to flash repetier to your Da Vinci printer video tut
#1
Hello all,

After flashing mine and a buddies 1.0/1.0a I decided to make a video tutorial for those that want a visual. I know there are others out there but I wanted to create one that was extremely quick as in do this do this do this done.

So here is is for those who want to take a look! Hope it is helps!
https://www.youtube.com/watch?v=rjuCvlnpB7M
Reply
#2
Nice work
Reply
#3
Very nice video, you make it easy enough I just may go for it.

Can I still use Simplify3D with repetier or do you recommend another software.

Also is 0.92 the latest for my 1.0A printer, I thought I saw in another post there was a 0.92A.
Reply
#4
I think it is the same, they may be wanted to say a 0.92 Alpha as it is still in alpha, I did not turn yet to beta - I will do soon I think.

Personnaly I use Simplify, compared to repetier host/Cura it is better, more setting and the support management is perfect!
but usb communication is better with repetier host, or using SD Card - no progress on printer with simplify - only on computer
but using wifi SDCard and Simplify is excellent per my experience
Reply
#5
Quote:I think it is the same, they may be wanted to say a 0.92 Alpha as it is still in alpha, I did not turn yet to beta - I will do soon I think.

Personnaly I use Simplify, compared to repetier host/Cura it is better, more setting and the support management is perfect!
but usb communication is better with repetier host, or using SD Card - no progress on printer with simplify - only on computer
but using wifi SDCard and Simplify is excellent per my experience

I think I will take the plunge and put repetier on my printer tomorrow.
I have been kind of hesitant because there is no going back to stock the way I understand it.

So your saying S3D will not connect to the printer after repetier is installed?

What wifi card are you using?

thanks
Reply
#6
Simplify can connect but do strange pause when printing then resume, I did a tracker here https://github.com/luc-github/Repetier-F.../issues/38
Looks like there is USB connection issue - I did not tried yet with blinded USB cable and ferrit - I have switched to Wifi SDCard like for my others printers as they are in another room - it is more convenient for me

I use Toshiba flashair and I have rewriten the file manager to erase the files and have information about SD Card : https://forum.voltivo.com/showthread.php?tid=7947
Reply
#7
Well I did it! Installed repetier on my 1.0A.

Everything went very smooth, took a little time recalibrating the bed and making
some start and ending code for Simplify3D.

Printed out a couple of models.

It sure is nice having full machine control in S3D.

I printed one by USB, another by uploading through the USB to the micro sd card, both ways worked great.

Was notified that S3D just came out with a new version today while I was messing around with it.
Reply
#8
seems they improve USB communication in 2.2.2: http://www.simplify3d.com/software/changelog/
- Improved USB communication reliability during processor intensive tasks
Reply
#9
When printing from the SD card and you pause the print it goes to the right front.

This makes very hard to swap the filament color.

Is there an way to change this?

Thanks
Reply
#10
use the position menu to move the head in place you want (move X back)
Reply
#11
Quote:use the position menu to move the head in place you want (move X back)

The pause feature always leaves the model offset whether I use the position menu or not.

And the head moves so fast it sounds like its hitting or might damage something.

I think I will refrain from using pause till it gets fixed.

Has anybody else had this problem on the 1.0A?
Reply
#12
the offset is in which direction ? X? Y ?
PS: if you have issue it is better to raise here : https://github.com/luc-github/Repetier-F....92/issues, or open a new thread instead of using this one
Reply
#13
Quote:the offset is in which direction ? X? Y ?
PS: if you have issue it is better to raise here : https://github.com/luc-github/Repetier-F....92/issues, or open a new thread instead of using this one

Y axis is shifted about 1mm.

Sorry I'm still learning, I'll go to the github
Reply
#14
Quote:Well I did it! Installed repetier on my 1.0A.

Everything went very smooth, took a little time recalibrating the bed and making
some start and ending code for Simplify3D.

Printed out a couple of models.

It sure is nice having full machine control in S3D.

I printed one by USB, another by uploading through the USB to the micro sd card, both ways worked great.

Was notified that S3D just came out with a new version today while I was messing around with it.

Hi,
I wish I had a story as good as yours. Since I installed repetier, the printer takes random pauses for 2 to 5 seconds and ruins my print with empty sections. I use Simplify3D too. Does anyone have a fix for that issue ? I searched the net for hours and found no fix. There is talk about usb cable interference or power cable interference but it is too hazardeous imo. Doing tests is painful as the issue is random and may occur at the end of a 1+ hour print. I suspected the power supply to fail with too high temps but it is not the issue.
Thanks for any input.
Regards
Reply
#15
I can't speak to S3D as I have opted for cura/octoprint but I did notice a 2-5 second pause every once in a while when I was using repetier host. It came down to the cache (should be 202) not being set correctly in the printer settings. The computer would send more commands than the printer could store and it would start skipping commands. I also removed the usb cable from a power usb hub and plugged directly into the computer and it seemed to go away. I haven't noticed any issues after switching to octoprint on the raspberry pi but it may be because the cable isn't stretched around several other high powered electronics like it was when coming from my computer.
Reply
#16
Thanks Brent.
Did you changed something in the firmware related to the cache ?
I am plugged directly into the usb port of my PC. No hub.
maybe I should try to slice using S3D and communicate using Cura.
Regards
Reply
#17
Luc,,, after flashing the printer with repetier, as shown in the video, what else has to be done, either firmware/software modifications in order to start printing successfully? I've read that the are eeprom changes, heater temp table changes/recalibrating, and specific file revisions (whithin repetier host) and of course recalibrating the bed in the Z direction. I want to start off using repetier host, and then maybe switch to S3D.

These questions are my only concerns for not re-flashing my printer at this time. I want to totally understand what I'm getting into before I jump in, as I know this can be very frustrating.
Reply
#18
I am still having issues with communicating to the printer, either in RH or S3D. The printer just doesn't communicate back it seems.

What GCode start and end changes were made above to get prints to work?

BTW, I used the video above to Flash.

It is so frustrating to have the firmware on the printer fine, but can't print???????????
Reply
#19
Although USB printing worked ok for me and I did see the pause a few times it did not affect the model I was printing.

The way to go in my opinion is to add the sd card reader.
In my case for the 1.0a a micro sd to standard sd card reader from Amazon, (see picture).

This scenario seems to work the best and be the most stable.



I use S3D and a good start and end code inserted in S3D is a must or the printer starts printing even before the bed and extruder are heated.
If anyone wants my start or end code let me know.[Image: P2120004.jpg]
Reply
#20
Need start code please.

I am going to try and add in the Octiprint solution also to see if that works.

I just worry since I can't even get Repetier host to work right.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)