Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Emulating original begin and end behavior
#1
Just started with Repetier on my DaVinci 1.0, and so far I'm liking it a lot. I've done a couple of prints that already look much better than what I was getting on the original software.

How do I go about making the print process begin and end like original xyzware? By that I mean, at the start of the print, "wiping" the extruder before printing, and at the end of the print, wiping and stowing the print head and lowering the print bed. Currently, the printer just moves the extruder to the side when the print is done, and leaves the bed wherever it was when the print stopped.

Thanks!
Reply
#2
you need to customize the start code and end code of your slicer
for the clean nozzle there is already a command you can add M100
for the others behaviour you wish - you just have to add the GCODE you want as mentionned (move down, park, play sound etc...)
Reply
#3
Thanks Luc! I'll find a guide on gcode and start learning!
Reply
#4
I took a start script someone else had posted, and modified it for what I wanted it to do. The intention was to run the M100 cleaning process after the extruder was hot, and right before it started the print. Instead, it heats up, extrudes some filament in the drip box, and goes straight to printing - usually dragging some of the extruded filament behind it. Could someone take a look at my codes and let me know what I'm doing wrong?

M140 S[first_layer_bed_temperature] ; Bed (no wait)
M104 S[first_layer_temperature] ; Extruder (no wait)
M106 S255 ; Start fan
M117 Start
G90; set absolute coordinates
G28 X0 Y0;home all axis
;G1 Y100 X50 Z20 Pull over
M109 S[first_layer_temperature] ; Extruder (wait)
G92 E0; reset extrusion distance
G1 E6 F100 ; Prime Extrude at anchor point
M100; This should clean the extruder
G92 E0; reset extrusion distance
G1 X36 Y30 F1000
G1 X36 Y130 E14.5 F1000
G92 E0; reset extrusion distance
M117 Print

Thanks!
Reply
#5
I see no homing for Z, and not waiting bed temperature reached

I suggest you to use repetier manual tab and you send manually, each command, one by one, and see what is happening in printer and what the log says - it will help you to see which part is wrong
Reply
#6
Hi Luc - I had removed the Z axis homing because I didn't want the bed to go up just yet. Now that I know it does more than just move the bed, I've put it back in.

I looked for a code to wait for bed temperature, but didn't see one (or didn't recognize it). What is the code for that?

I will try the commands manually as you suggest. Thanks!
Reply
#7
I figured out why my settings weren't working. I had saved them under a different name than My Settings, but did not realize that I needed to select those settings on the slicer tab before slicing. Dumb mistake, but that's how we learn, right?

Once I have run a test print with the new settings, I'll post if I have any other questions.

Thanks for your time!
Reply
#8
Here are my custom g-code commands for the Da Vinci 1.0, For those that may happen by this thread these are found in Repetier Host under Slic3r>Configuration>Printer Settings>Custom G-Code.

Start G-Code
Code:
M140 S[first_layer_bed_temperature] ; Bed (no wait)
M104 S[first_layer_temperature] ; Extruder (no wait)
M106 S255 ; Start fan
G90 ; set absolute coordinates
M109 S[first_layer_temperature] ; Extruder (wait)
M190 S[first_layer_bed_temperature] ; Bed (wait)
M117 Start
M300 s1000 p400 ; Beep
M300 s1500 p400
M300 s2000 p400
M300 s2500 p400
M117 Cleaning
M100 ; Cleaning
G1 Z5 F1500
G1 X0 Y15 F1000
G1 X32 Y30 F1000
G92 E0 ; reset extrusion distance
G1 Z[first_layer_height] F4800.000
G1 X32 Y170 E14 F1000
G1 X32 Y185 F1000
M117 Printing

End G-Code
Code:
M104 S0 ; turn off extruder
M140 S0 ; turn off Bed
G90 ; Absolute
G28 X0 Y0 ; home
M117 Down Bed
G1 Z200 ; Lower bed
M117 Cleaning
M100 ;Cleaning
M84 ; Disable motors
M117 Cooling
M190 S50 ; Bed (cooling)
M116 ; Wait for all temperatures
M140 S0 ; turn off Bed
M117 Pickup piece
M300 s2500 p400 ; Beep
M300 s2000 p400
M300 s1500 p400
M300 s1000 p400
M84 ; Disable motors
M117 Printer Ready

What is posted above is tried and working, however I am about to add an auto bed level check to the start code. Adding the following should do the trick but at this point it is untested by me.
Code:
g28 ; home all axis
g1 z10 ; lower bed by 10 mm
g32 s1 ; check bed level, do not save results

[Edit] I have to say I like your "Prime Extrude at anchor point." I may have to add that as well...
Reply
#9
James, I really like your start and end sequences - I may give those a try myself.

The prime extrude at anchor point command came from the start codes I copied from another thread, but after a few prints today, I think I'm going to get rid of it. It resulted in extruded filament getting stuck to the head and not cleaned off well by the cleaning swipes. Instead, it would get dragged to the print bed, and I would end up having to pause and clean it manually before continuing. I've been printing with a skirt - I think that will be sufficient to prime the extruder. YMMV.
Reply
#10
Yep, a skirt or a brim is a better option to prime the extruder.
Reply
#11
The bulk of my gcode came from this thread by Edouard.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)