Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Flashed Da Vinci freezes print exactly 2 hour 30 minutes...?
#1
I reflashed my Da Vinci 1.0 with some old firmware I found from youtube videos floating around. I think it is the duet rep rap firmware I'm not really sure how to even find how what I have on it.. but I use Repetier Host and it connects and controls it very nice. I have about 300 hours of printing time on the printer and I regularly used to do 8+ hour prints over night with no problems at all but recently the printer has been stopping mid print.

Seems like it simply stops communicating with the computer. Sometimes the printer itself will freeze and the temps go wild, or it will simply lose connection but the computer does not play the "usb un-plugged" sound, the printer itself will stop sending "ok" messages. I'm very inexperienced with firmwares and have no idea how to debug or fix this. Right now the printer will freeze almost exactly 2 hours 30 minutes into any print very consistantly. Very frustrating to print any large objects right now. It has printed approximately 275 hours without any issues what so ever but slowly started freezing and stopping over the past 2 weeks.

I'm thinking of ordering a new board like Rambo or something but it prints so perfectly for those 2.5 hours it works... it is a very strange issue. Any ideas at all for anything I could try to fix this? I checked voltages off the PSU and everything is good, I tore the whole machine apart and unplugged anything not needed like the LCD panel and lights etc. and it will still freeze. I wanted to buy a 2nd printer because I love this one so much but I cannot if I will need to replace the main controller board like this... Any help anyone?
Reply
#2
So you don't even know what firmware you flashed and your first thought is of switching to a different board? LOL Smile How about you begin by flashing something that is known to work well, such as https://github.com/luc-github/Repetier-F...g/v1.0-RC1
Reply
#3
I just don't know the name of it, but I installed this firmware from here
youtube vid: https://www.youtube.com/watch?v=Ya0SPLHGKs8
firmware: https://github.com/bgm370/Repetier-Firmw...ee/davinci

It seemed fine because it has worked perfectly for over 270 hours so its such a strange issue. Currently I can't get more then 2 hours 30 min into any print. 6 prints in a row now it stopped at around that.

That firmware you linked is that the most current and newest one around?
Reply
#4
I just installed that firmware and I'm getting "SD EEPROM write error" it is unable to even store EEPROM settings and restarts the printer when I attempt to save anything from the printers panel itself, or through repetier.... Any ideas? I tried 3 different SD card's can't get any of them to work. They were working on the last firmware so idk whats up with this... really frustrating.
Reply
#5
What you installed is a very old and alpha-status version. Use luc's 0.91 or 0.92 version instead.
Reply
#6
I may have shorted out the SD card reader somehow... because now when I go back to the old firmware I was using it will not even boot up, like it failed to save EEPROM to SD card. Is it possible to simply solder on a new SD card slot, or is it something more complex then that...?
Reply
#7
I didnt read the full post, so sorry if this has already been said. Repetier host is different than stock software. I believe the stock software wrote the slice as a temp file on the SD card, so if the computer died the print would continue. Repetier host is constantly feeding data to the printer, and needs to maintain connection. I ran into the same thing until I noticed it directly correlated to my computer going to sleep. I typically use octoprint now, but if I need to use repetier host for a long print Ill pull up a video in VLC and pause it. This typically keeps the PC from sleeping/hibernating.

I suggest you follow this guide for firmware flashing: https://forum.voltivo.com/showthread.php?tid=8333

Information is so scattered on this site, I cant even find details I know Ive read here before. Its like following the white rabbit for a newb to gather the complete steps. The OP of the thread above does a great job at consolidating.
Reply
#8
Sorry I meant I went back to the "old" firmware I was using, not the stock. I had about 270 hours on this beta firmware then it started to stop mid-print so I flashed to the newer 0.91 luc firmware and now the SD card reader is not writing EEPROM settings, even if I go back to the old beta firmware I was using it will not work at all now. I may has shorted something out with the SD card or something? I have tried everything to get this to work now but it is not... It will connect to Repetier host in the luc 0.91 firmware and any settings I try to adjust in the firmware, or sending that M502 command the log shows "SD EEPROM write error" and the entire printer restarts. It created the eeprom file on the SD card though it just refuses to write any further data to the card without restarting the printer, at a complete loss here. The machine works I ran a simple 5 min test print through Repetier and it got through it right when it finished it tried to save the filament print time to the EEPROM on the SD and the printer restarted. no clue
Reply
#9
Hmmm, thats crappy. Youve confirmed you can write to the SD via other means, like on the PC? Sounds like either a failsafe is kicking in and rebooting the machine, or theres somehow a short in the card reader, or both. Ive only extended the SD card slot by plugging a premade reader on a ribbon into the existing slot so I cant speak to the complexity of this one. Do you get the same printer behavior if you power the thing on without a card at all?
Reply
#10
Yeah I have tried 3 SD cards all writable from the PC, the little "lock" switch is in the right spot. I tried looking at the card slot and it looks normal I cant really see any shorting going on idk... If I power the printer on without the SD card it just goes to a blank screen and nothing boots up at all. It did create the eeprom file on the card though, like if I format the SD card, and turn the printer on with it, it will create a blank eeprom file with the default values. I wonder if something in the firmware is messed up with the SD card code or something?
Reply
#11
Ryan, so if the printer does act differently without a card, its at least being read so thats good and probably indicates there isnt something wrong with the reader. I dont know where you are at in the process currently, but Id definitely suggest attempting a reflash with Luc's latest .92, before trying to do anything on the hardware layer. Maybe hit the jumper, and reflash with a freshly formatted SD? Please read the .92 instructions for loading default values and saving to eeprom, I inadvertently skipped that step at first and had all kinds of problems, one of them being repetier host not writing the full gcode to SD reliably. Please let us know how it turns out, Im hoping you got it sorted and are now happily printing.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)