Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Da Vinci Setup Guide: From Installation to Wireless Printing
#41
hey luc, I did everything over again, started from scratch, and the same thing happened, the software is on the printer but the LCD is staying two black bars. Other than the screen the printer is working, I can connect and control with my laptop. Any suggestions on what to do now?
Reply
#42
It works on Duo old Generation - On Duo new generation 2.0A I think some pin should be missing based on change we did on 1.0A
Check your board to see what generation you have
Reply
#43
can you some do restart or emergency stop to see if screen is back ? we changed the initialization process recently and was ok on all tested platforms but may be still need some tuning
Reply
#44
once I clicked emergency stop the screen started functioning. Is their any permanent fix, or do I have to do that everytime. It isn't a big deal though.
Thank you so much!
Reply
#45
after restarting printer do you still have issue ?
Reply
#46
yes but the emergency stop seems to work every time.

Thanks for all of your help
Reply
#47
MOD: Deleted, completely off topic. Please start a new thread if you wish to ask questions unrelated to the original post. Thanks.
Reply
#48
I got the Octoprint server up and running without much trouble, but I am having difficulty getting the webcam piece running as a service.

I am able to run /home/octo/webcam.sh manually but as soon as I close my SSH the camera session ends.
[email protected]:/home/octo# sh /home/octo/webcam.sh
MJPG Streamer Version: svn rev: 3:172
i: Using V4L2 device.: /dev/video0
i: Desired Resolution: 320 x 240
i: Frames Per Second.: 15
i: Format............: YUV
i: JPEG Quality......: 80
/o: www-folder-path...: /home/octo/mjpg-streamer-code/mjpg-streamer/www
o: HTTP TCP port.....: 8080
o: username:password.: disabled
o: commands..........: enabled

When I try to run it via the service it fails as follows:

[email protected]:/home/octo# systemctl start webcam.service
[email protected]:/home/octo# systemctl status webcam.service
webcam.service - Run WebCam
Loaded: loaded (/etc/systemd/system/webcam.service; enabled)
Active: failed (Result: exit-code)since Thu 2015-01-29 15:26:32 EST; 7s ago
Process: 731 ExecStart=/home/octo/webcam.sh (code=exited, status=203/EXEC)
CGroup: name=systemd:/system/webcam.service

Jan 29 15:26:32 beaglebone systemd[1]: Started Run WebCam.
Jan 29 15:26:32 beaglebone systemd[1]: webcam.service: main process exited, code=exited, status=203/EXEC
Jan 29 15:26:32 beaglebone systemd[1]: Unit webcam.service entered failed state


Any suggestions?
Reply
#49
I'm having a really difficult time getting this to work. I followed the instructions to the T three times. Twice on my desktop and once on my laptop and I get the same compiling error message. I can't figure out where it's going wrong. Everything seems to be working up til I try to upload the ino file onto my printer. I've attached the error message I get when this happens in hopes that will give more insight into my issue.

Both computers are running Win 7 x64. I tried installing on an external drive on my desktop and running the software off that and it didn't work, so I tried on the C: drive on my laptop and ran into the same problem. My printer has no firmware on it so I can't use it until it's fixed and I can't seem to get anything to work right.

Another thing, the printer shows up as Bossa program port on both my laptop and desktop. I first installed the arduino software on my laptop then plugged in my printer. It initially said it was an arduino device (didn't get this on my desktop) but once the drivers finished installing it displayed as Bossa program port.
Any help is greatly appreciated! I really want to get my printer working again. https://forum.voltivo.com/images/errornote.txt
Reply
#50
you are using 1.6.0 not 1.5.8 of arduino as mentioned in Guide -I know 1.6.0 has been released but I did not worked yet on porting for it

download the 1.5.8 from here : http://arduino.cc/en/Main/OldSoftwareReleases - this will solve the compilation issues
Reply
#51
Ah, of course it was because I had the wrong version! :S I didn't think a newer version wouldn't work. Thanks for the help. Hopefully this will fix the issues.

Edit: Successfully verified! Changing from 1.6 to 1.5.8 fixed all the problems. Thanks again for the help!
Reply
#52
Ok - FYI arduino 1.6.0 is now supported, new variant.cpp is available in sources, I did not put usbcore.cpp as 0.92 has watchdog support
Compilation/flash is really faster on my PC with 1.6.0
Reply
#53
Seems like you have an exit call in your script. Be sure that the webcam.sh does not say exit at the end. When creating a new shell script from linux, this is placed in automatically. Be sure the only code in it is what I posted in the guide.
Reply
#54
Thanks Jake. I did verify that the code in my webcam.sh is exactly as you posted. In any case, I've spent some time learning Angstrom/Linux and have had success running the script with the "&" symbol so that it the process is detached from the SSH window.
Code:
sh /home/octo/webcam.sh &
This is an acceptable workaround for now.

Thanks again for taking the time to write up the guide, and to Luc for tirelessly maintaining the Repetier firmware.
Regards,
David
Reply
#55
Are the files in the same github? and the process is still the same if you use 1.6.0?
Reply
#56
1.6.0 compilation worked but result was weird due to pre processor command messing up with #define ( and FW has a lot #define....) and bring several issues during print, so I removed files,
After I added the files for 1.6.1 when they released, has no time to test, but seems same , 1.6.2 recently released seems broken and not backward compatible
Arduino is working on fix, but last night fix seems not compiling sketches per feedback.

so to sum up:

Stay on arduino 1.5.8 as nothing else stable is out right now
https://github.com/luc-github/Repetier-F.../issues/51
Reply
#57
I cant get my printer to print anything. I can control the printer in Repetier Host and even test the heating bed/extruder. But every time I try to print something Repetier Host says the Print Job Finish right after I click print but the printer doesn't do anything.

I am running:
Repetier Host V1.5.1
Arduino 1.5.8
Repetier-Firmware-0.92
Windows 8.1 Pro
Da Vinci 1.0A
Reply
#58
Hello all
I have a Da vinci Duo with 2 extruders and the board shown on the picture

I have followed all the steps and after flashing with arduino IDE i get an OK message from arduino IDE but black bars on the LCD

I tried on windows and Mac and still get black bars on the LCD

I modified configuration.H to type DAVINCI 3 Model 0
My arduino IDE is 1.6.4

And before flashing I sleect Arduino Due Native as the board

One thing I noticed is that after copying the variants.cpp and the USBcore files I had to install the board on the bpard manager.

I dont knw what else to do

PLEASE HELP

Thank you
Best regards

Rod Magnus
I have tried many times


[Image: IMG_7945.JPG]
Reply
#59
When was the last time that the firmware has been updated on the github? I updated sometime in may and was wondering if i should update it again?
Reply
#60
Is there a way to set repetiar host software to connect to the printer through octoprint?
Reply


Forum Jump:


Users browsing this thread: 3 Guest(s)