Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to setup Toshiba FlashAir SD card
#1
So hear's a puzzle. I bought a 8gb class 6 Toshiba Flashair SD card so I could upload gcode files to the sd card as I'am using Repeter firmware and this way my computer does not have to stay connected to the printer. I modified the config file by adding UPLOAD=1 and with some files (like pdf, jpg) it now works, but whenever I try to upload a gcode file I get "NG" and it does not upload. I have tried to rename the file, use a different gcode file - nothing works. Maybe there is a mistake in my config file? If someone has had similar issues ....any help would go a long way, because I simply do not know what else to try.

My config file looks like this:

[Vendor]
UPLOAD=1
CIPATH=/DCIM/100__TSB/FA000001.JPG
APPMODE=4
APPNETWORKKEY=********
VERSION=F24A6W3AW1.00.04
CID=02544d535730384707500258cf00cb01
PRODUCT=FlashAir
VENDOR=TOSHIBA
APPSSID=flashair
LOCK=1
APPAUTOTIME=0
NOISE_CANCLE=2
Reply
#2
i use this setup my self one thing i found is that i need to be close to the printer when i send the file or i get this error. try moving closer .

[Vendor] CIPATH=/DCIM/100__TSB/FA000001.JPG
VERSION=F24A6W3AW1.00.03
CID=02544d53573038470750031e0c00cc01
PRODUCT=FlashAir
VENDOR=TOSHIBA
UPLOAD=1
APPMODE=5
APPAUTOTIME=3600000
APPNAME=Makerbot
APPSSID=Basement A
PPNETWORKKEY=************
LOCK=1
COMMAND=wlan 11n 0
Reply
#3
No, its not that. When I started the setup I installed the sd card to the printer but because I got frustrated I'am now testing using my camera. I'am very close to it and connection is just fine. Anyway, the issue seems to be the 8.3 DOS filenames - when I rename my test.gcode to test.gco it uploads. I don't know however, if da vinci would be able to use this file with improper extension? But there has to be a workaround to that?

UPDATE: Ok, repeater host reads a .g file as gcode so I can just use that.
Reply
#4
The version 2 card, according to other reports, does not have the 8.3 filename limitation. ( That was one of the reasons i stopped modifying the factory firmware. )

Kieth
Reply
#5
Yes, I recently bought the 2nd generation card (W-02) and it doesn't have the 8.3 restriction. I'm able to transfer files with long names, no problem.
Reply
#6
Hi,
Thanks for the info, apparently my Toshiba Flashair is the old version (that was all I could find cheaply from a local store). Fortunately, because I'am running Repetere firmware, if I upload filename.g file, it works as well as if it were filename.gcode so everything is working now. Just started a test print and no problems.

Merry Christmas to everyone Smile
Reply
#7
did you tried to update the FW of the SD Card ? they already provided several updates
not sure if it is still helpful now, but long time ago I did this: https://forum.voltivo.com/showthread.php?tid=7947 becauseI was not happy with their UI :pinch:
Reply
#8
I did a writeup of using a flashair with a flashforge creator, but it should be mostly the same.

http://microfabricator.com/blogs/view/id...3d-printer
Reply
#9
I am really glad I came across this topic :woohoo:. I have a DaVinci 1.0 and am running Repetier 0.92 firmware. I have recently been trying to upload my .gcode files to the SD card using Repetier Host so that I can print without having to leave my computer on. I was starting to get frustrated because I would position my objects, slice (which took quite a while for this particular print), and then upload to the SD card (also quite slow). Everything would seem to be OK, but when I would go to print the file from the printer menu the file would not be there :ohmy: ! I had previously uploaded and printed a much smaller (file size) print I titled Clips.gcode, so I thought maybe the file size may have been the issue. I tried several different .gcode files and nothing was working. I could not figure out why the Clips.gcode file would work and the others would not. The file names of the ones that were not working had several more characters. It seems from the posts above that the length of the file name may be my problem. I would have never thought that would be a problem. I can't wait to get home and test this theory Wink .

*UPDATE* So I tried using a short file name ( 5 characters) uploaded and still not showing up on printer menu. I tried a second time and it seems that I was omitting the file extension (.gcode). The key is to be smarter than the machine, which apparently I am not :S.
Reply
#10
The file extension needs to be .g (at least with older FlashAir cards). Ether change it manually before uploading or specify .g file extension already while saving the file. Also, file name should be no longer than 8 characters I think.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)