Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
I think I've bricked my printer: "Verify failed"
#1
Mod: please refrain from colorful metaphors.



.. I was playing with the 3 wires that power the LEDs panel, since I've tapped that to use it as power source for my extruder fan... not sure what happened exactly, but I might have connected 2 ends of the wrong cable together. Anyway, the printer was working, I turned it off to do some work, then turned it on again... only 2 black bars. So I did the JP1 erase, but nothing. I can see the Bossa Program Port COM8 in Windows, but both Arduino IDE and bossac.exe give me the same error after uploading any firmware:

D:\Dev\arduino-1.5.8\hardware\tools>bossac.exe -p COM8 -U true -i -e -w -b d:\Downloads\DaVinci-1.02014-12-12-1.1.bin -R -v
Erase flash
Write 145368 bytes to flash
[==============================] 100% (568/568 pages)
Verify 145368 bytes of flash
[==============================] 100% (568/568 pages)
Verify failed
Page errors: 568
Byte errors: 142707

Sounds pretty bad. Any ideas? Please, help!
Reply
#2
I googled it and several people said it is bootloader damaged - may be try to reburn it , I saw this in menu of arduino in tools / Burn Bootloader - not sure it can make it worse :dry:
Reply
#3
Tried that, it just throws an exception:

Error while burning bootloader.
processing.app.debug.RunnerException: Please select a programmer from Tools->Programmer menu

There are several items to choose from in the Tools->Programmer menu, I'm not sure which one to pick. EDIT: tried them all, same error Sad

I think that my best bet at this moment is to try and get the mainboard replaced under warranty... will there be any trace of the Repetier Firmware?
Reply
#4
if they can fix bootloader they will access to FW, better is to flash the stock fw even verify failed, so no more repetier for sure
Reply
#5
I'm not sure if anything valid is in the flash memory anymore. I've run bossac.exe -e to manually erase it, then bossac.exe -w to write the stock firmware (without verification), and finally -r to read the entire content of the flash back into a file, and the result is that all the bytes are 0xFF, so apparently nothing is really being written?
Reply
#6
seems - at least if they check they should have same results than you
Reply
#7
I wonder if they'll let me ship the board only, rather than the whole printer, otherwise there will be some physicals signs of modifications that they could perhaps use to void the warranty. Does anyone know of XYZ ever doing that (allowing to send them just the board)? I suppose it won't be hard to take apart.
Reply
#8
Update: I ended up sending just the toast board to tech support (in Germany) and just today got a new board back! I'll be installing it tonight and hopefully I'll be back to printing soon!! Smile

The new board is (as expected) the 1.0 model, with the JP1 jumper, but unlike the version I had before, the jumper has no pins, just two holes. I've seen pics of other people's boards with one of the holes 'filled up', but not this one. Anyway, no big deal. Plus now there is this trick to wipe the flash by switching the printer on while some buttons in the front panel are pressed, right? So the jumper is not really needed anymore...
Reply
#9
Yayyyyy printer is back up and running! (Repetier Wink )
Reply
#10
Welcome back :cheer:
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)