Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Da Vinci Aio 1.0 cartridge hack/reset?
#1
I just bough an davinci aio.

It comes with 1.1.1 firmware, xyzsoftware says 1.1.1 (1B1).

Im interested on using the wctek cartridge hack to keep the warranty and go with the standard soft for now while I learn more about custom firmwares and stuff.

Does anyone knows if the cartridge reset works on this Aio's 1.1.1 firmware?

Thanks!
Reply
#2
I do not know if it will work or not. To be honest, I would be very cautious of it at this point. I doubt your firmware is the same as the DV 1.0 / 2.0 units. We have reports that XYZ is engaging in the illegal practice of disabling printers which have been reset, requiring a change in firmware to resolve. At this point, Im not sure any other firmware is compatible with your machine, hence my cautions against doing anything at this point.

Maybe you could post some pictures of the PCB in the machine to give us a better idea of what they are doing?

Kieth
Reply
#3
Board photos of my aio. Seems the microsd it's glued...[Image: image.jpg][Image: image_2014-12-03.jpg]
Reply
#4
I've just received my AIO tonight, and have downloaded the contents of the 4GB micro SD card and have begun to analyze the data.

In looking at the filament cartridges (I ordered replacement black and white carts) it appears they are compatible with both the scanning and original DaVinci 1.0- so it would seem that the same reset should apply regardless of printer model. I plan to dump the EPROMs later this week to compare at byte level and will report back with in fob& pix.

In the meantime, if anyone else can test this out, let's work together to bring the KB for the AIO 1.0 up to the level of the ancestor unit here on Voltivo-

Cheers-

Jeff
Reply
#5
Wouldn't we assume the printers work the same and use the same commands with xyzware? cartridges can be reset on the 1.0 latest firmware. The trick is changing the serial number and keeping the filament default values at 240m. The printer keeps track of previous serial numbers somewhere. Usually reflashing the firmware gets rid of previous cartridges used. See if you can figureout the DAVEEW command that can write to eeprom as it is connected to the printer.
Reply
#6
Has anyone successfully been able to get the SAMPLE rename trick to work? I recently got the 1.0 with the AiO board. I used Slic3r, both independently and through Repetier, added the appropriate header and renamed the gcode to SAMPLE01. The issue was, when it started the bed raised, it heated up, and the extruder moved to the front right side of the bed. Then it just stayed there for about 10 minutes and then went back to home. I tried with multiple versions of the header, different configs for slicer, but had no success. As a gcode newbie, I'm not sure what to look for to make this work. Also, I tried a microSD to SDHC extender and kept getting the 0040 error, until I plugged the microSD straight into the board. I tested the extender and it works fine, I tried with a flashair and the microSD in an adapter and had the same issue. Any help would be appreciated.
Reply
#7
Can you provide us the files on the AIO sd card? Not sure how the header is on the AIO but on the 1.0 its

; filename = composition.3w
; machine = daVinciF10 ### change this to the AIO machine name
; material = abs
; layer_height = 0.2
; total_layers = 1
; total_filament = 1
; extruder = 1

Make sure that is at the top of your gcode file.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)