Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Having issues getting davinci 1.0 to run with repetier
#1
Hello gentlemen,

I have received my printer yesterday. It's my first 3d printer, but I'm not new to things that move. After getting the mechanical parts to work (my printer arrived with loose belts and unplugged Z motor) and successfully printing the star vase sample I thought all is cake now. I installed XYZware, it has updated and immediately it told me that the cartridge the printer came with cannot be identified and therefore I should buy a new cartridge... if before I was ready to buy filament from them, now I was rather miffed and I've decided I want nothing to do with them, especially after finding that their support is closed on weekends. I was able to roll back from 1.2.3, however even than XYZware complained about the cartridge, which worked fine when printing from SD. So... now I have flashed Luc's firmware. That was easy, thanks a lot Luc!

In repetier host (I installed 0.95F since in the newest version the option for reprap duet is no longer there it seems and I'm not sure if that's relevant in the new one) the settings I have are as follows:

Connector: Serial
Baud: 38400
Transfer Protocol: Audtodetect
Reset on Connect: RepRapPro Duet Firmware
Reset on Emergency: Send emergency command and reconnect
Receive Cache Size: 127

Now here's the issue I'm having:
I am trying to issue an M105 in manual G-code tab and on the bottom I can see "Echo M105, Error writing to file, Echo M105"

It does not seem like I am actually connected to the printer. Pronterface gives me same error. Help would be highly appreciated.
Reply
#2
and magically it just started working, even with newest version, but now my extruder ran into the bed side. My Z is definitely not where it should be.
Reply
#3
you can update to repetier 1.06, it works very well - I use it -( Reset on Connect: Due Native USB Port) once fw is flashed you must send M502/M500 command from repetier or go to setting on printer and load Fail-safe and save to printer

For the bed there is an helper for the leveling in Maintenance menu : Manual Leveling this will help you to find good position
are you using source or beta 1 binary ? (sources are up to date but not binary, I will release beta 2 binary monday)
Reply
#4
im trying to find a step guide into using repetier with the Da Vinci....... no luck so far
Reply
#5
I'm using source. Just got back from the evening pub trip, so manual calibration is what I'm doing. Another issue that I noticed is that it did not wait for extruder to heat up, just the bed before proceeding with a print. I know at this point it's settings, just the learning curve to this is pretty steep... M502 is reset defaults and M500 is write to memory?

Also, my z probe keeps hitting the tin clean plate. Any easy way to not have that happen?
Reply
#6
There might be one when I'm done with this if time permits. Overall the process of reflashing the printer is very easy. Which *magic* got it to work eventually is not yet clear to me, but I'll find out.
Reply
#7
Not sure about the question - Z-probe need to hit metal plate to do contact and know when reach the bed then do calculation of z-probing
Reply
#8
Not that metal contact. The little metal flap on the "garbage bin". When homing it goes straight over that and it's pretty annoying.
Reply
#9
Strange, homing start by X homIng so nozzle should be far on right of this cleaner, do you have picture of your nozzle in homing position ?
Reply
#10
Here you can even see the probe caught on the plate.
[Image: IMG_20141130_152232627.jpg]
Reply
#11
so it hit after doing X homing, when doing Y homing ?
Reply
#12
Yep, sound about right. Does it every time it homes. Also when it does the cleaning G-code it's doing it in the wrong place. Between the bed and the cleaning strip.
Reply
#13
what fw do you use ? (binary ?, sources ?, version ?)
it may be caused by
#define ENDSTOP_X_BACK_ON_HOME 0
#define ENDSTOP_Y_BACK_ON_HOME 0

Which are not set to 0 actually
Reply
#14
0.91.7 from source from your github.

Where are these definitions found?
Reply
#15
in Configuration.h
Reply
#16
Thanks, I will play a little with this as soon as my print finishes. Got myself a nice 3 hour print going.
Reply
#17
Ok, machine sat for a day and now my bed and extruder are not heating. It had finished a large print from SD card, after which it was cooled down and powered off. I had nothing to do for it yesterday and today I just powered it on and nothing heats. Also, in Repetier extruder temperture shows about right (25*C), but bed shows 10, which can't be right, it's 25 in the room. I have not touched the printer at all between the last successful print and right now.

Edit: Just tried to tell it to print from SD card... both heaters started working.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)