Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
FW for 1.0 2.0SF and 2.0 : binary and sources
#1
Hi - I think is time for a release and more feedback so here the rc version (still have room for improvement) for repetier fw (0.91 based) for DaVinci 1.0, 2.0SF and 2.0
It does not support latest boards generation! Check you board first! for New boards check 0.92 based FW
RC1 is now out, target is final for end of December :
https://github.com/luc-github/Repetier-Firmware/wiki
https://github.com/luc-github/Repetier-F...g/v1.0-RC1


Thanks everyone for your feedbacks and support

Thanks Aaryn,Drbogger, Edouard, Oscahie, Nepenthy, David Bender, Gary Rantz, Matthew Sanders and axs-gentoo for their participation, thanks of course bgm for initial version, and all forum guys for their help.
It is my first time playing with repetier FW and I had good fun and learned a lot coding and about 3D printing - hope this will give better user experience than stock FW to you guys who want to try this fw.

Features
*Standard GCODE commands
*Single/Dual extruders support (DaVinci 1.0/2.0)
*Single Fan / Dual fans support according printer configuration
*Repurpose of second fan usage to be controlled by M106/M107 commands on Da Vinci 2.0
*Sound and Light management, including powersaving function (light can be managed remotely by GCODE)
*Cleaning Nozzle(s) by menu and by GCODE for 1.0 and 2.0
*Load / Unload filament by menu
*Filament Sensor support for 1.0 and 2.0 (auto loading / alert if no filament when printing)
*Top Cover Sensor to alert if open when heating
*Auto Z-probe for 1.0 and 2.0
*Manual Leveling for 1.0 and 2.0
*Dripbox cleaning
*Advanced/Easy menu (switch in "Settings/Mode" or using Up key/Right key/ Ok key in same time)
*Loading Fail-Safe settings
*Emergency stop (Left key/Down key/Ok key in same time)
*Increase extruder temperature range to 270C and bed to 130C
*Add temperature control on extruder to avoid movement if too cold
*Add fast switch (1/10/100mm) for manual position/extrusion
*Several fixes from original FW

Please be noted:
*Watchdog is not implemented
*Binaries have timeout for disconnected usb to avoid hang up
*Binaries do not have preheat bed to workaround thermistor table lack of accuracy, need to activate in sources
*After flashing, do not forget to do a M502/M500 commands or go to settings/Load fail-Safe and accept to update EEPROM


This is a RC version,

For the ones who want to try more :https://github.com/luc-github/Repetier-Firmware-0.92
in beta stage but with :
- Watchdog Support
- 1.0A/2.0A support (thanks ogremustcrush, David , additionally need to define MODEL to 1) and AiO without scanner (thanks kryts and zeus10)
Feel free to test and feedback https://github.com/luc-github/Repetier-F....92/issues

Edit : I do not support 0.91 anymore - I only support 0.92.3 one to follow repetier updates and support all models
Reply
#2
Thanks Luc! So far so good! Ive only tested a reprint from older firmware, and from that limited view all is well. Test was through repetier host, will test some more tonight via octoprint, just in case communications improved at all.
Reply
#3
for usb hang only binary has fix because fix is not in FW sources but arduino sources
Reply
#4
Luc, If I just uploaded the adruino sketch, then I didnt get a usb hang fix? Would that correct Repetier disconnects? Octoprint is cool and all, but its buggy for me and with the way it can render the printer unresponsive it makes me nervous about burning the thing down. Is there a downside to flashing the binary versus uploading the sketch?

I like the way the menu is laid out now, btw. Clean nozzle command could use a home all first, for the brainless who chose that option while the carriage was pulled towards the front of the printer.
Reply
#5
Fix only in binaries as it is part of Arduino sources but you can add it check this https://forum.voltivo.com/showthread.php?tid=8138

About USB disconnection I never experienced one so I suggest to check your USB connectors if have some contact issue
About binary vs sources no downside only better as more fixes, it is downside only if you want to modify specific settings that is not in eeprom file - but there are few

About home actually it is done only if not homing yet, can you explain more the issue ?
Thanks Smile
Edit:To solve your USB connection issues did you tried WiFi SD Card ? it is good solution for transfert
Reply
#6
Luc,

For clean nozzle mishap I had manually pulled the carriage forward to clear some filament that was stuck to the extruder. With the carriage manually pulled forward I chose clean nozzle from the menu thinking it would go home and run through the routine. It instead tried to move forward followed by the dreaded gear clicking as the carriage was already at the the furthest Y point of travel.

My repetier "USB disconnect" issue was from me using Virtual Here on a raspberry Pi to share the device over the network. It would work fine for short runs but longer prints would stop for no apparent reason and a repetier disconnect and reconnect would restablish the connection fine. Sharing like this worked fine for stock firmware and Open XYX mod. However, not having to dork with the cartridge reset was worth the loss of that functionality so Im not going to worry about it.
Reply
#7
Ok - good catch - I created issue : https://github.com/luc-github/Repetier-F.../issues/67
Edit: Fixed in sources 2014-11-12 thanks
Reply
#8
I have been using this printer with the stock firmware for about 6 months. This was my first 3d printer and as my skills grew I started noticing all of the deficiencies in the Stock XYZ setup. I was on the track to buy a new printer, when I found this site. I now have my Da Vinci up and running on the new Firmware and Host and it is AMAZING!! I can not even imagine going back....

Thank you for all of your hard work! My Da Vinci now puts out parts with much higher quality and I now have complete control!!!!!

THANK YOU!!!

I wish I could give back in some way.
Reply
#9
I think I found an issue. When I attempt to Load / Unload Filament the LCD switches to a screen that says Heating 29 / 0 and the extruder never heats up. Right now I am stuck and can't print - is there a way to manually perform this?

Thank You
Reply
#10
I got the filament issue resolved by doing it manually in the RH control panel.

Thanks again
Reply
#11
It is because no heating temperature - I think you did not do a M502/M500 after flash neither load fail-safe settings in menu
some others function should not work because eeprom does not have the information - do a M502/M500 or load fail safe and accept to save to eeprom
Reply
#12
I think you are correct. I will give that a try! Thank You!! The firmware is AWESOME. These are the BEST prints I have ever gotten - This is like getting a whole NEW printer!!!! THANK YOU!!!!!
Reply
#13
Because have several boards now, please feel free to feedback which printer and which board you use : 1.0, 2.0SF,2.0DF, 1.0 ready for AIO
FYI: AiO is not supported by this Firmware - I do not have one so I cannot check/work on new features of AiO
Reply
#14
Hello i just got my 1.0 and installed this firmware i was able to print fine at first but after my printer was turned off over night it would on longer heat the extruder or the print bed on the LCD it would say DEF/ 225 or what ever number i was trying to heat too if i go back to stock and heat every thing back up i can re-flash and use the Repetier firmware. Is their a setting i can change to force the extruder to heat back up. I have loaded the fail safe eeprom but it does not help.

PS
The firmware is great thank you for your hard work
Reply
#15
looks like https://forum.voltivo.com/showthread.php?tid=8177

you can try to heat bed manualy a little with an hair dryer to confirm
Reply
#16
yep that works heat the bed a little with the hair dryer and restart and it works. I'm new so i don't know much about how to edit the firmware how would i go about changing the MIN_DEFECT_TEMPERATURE and making a new .bin file to go on my printer
Reply
#17
no if you do this your printer cannot detect issue and if have one you wil damage your printer

solution is here:
https://forum.voltivo.com/showthread.php?tid=8177

as now several people have issue (at least 2 but I suspect more now), I wil add some modification in fw based on previous patch but with more check and send you one version later for testing Ok ?
Reply
#18
cool thanks
Reply
#19
Hi please try this one
It checks if temperature of bed is ok or not when starting - if not it will try during 10 second maximum to warm bed until 40 Degres, you will hear a beeb sequence and a status saying preheat on LCD.
When done, success or failure it will put temperature of bed back to 0, if still issue it will show temp error as before.
This happen only once when starting printer you can follow temperature rising on LCD
I tested on my side but I do not have issue so I simulate it - only you can confirm it is Ok - I put 10 second as max if it is ok earlier it will stop before

Let me know

https://forum.voltivo.com/images/Davinci...st.bin.zip
Reply
#20
just tried it still not working i don't think it trying to heat i don't here the fan kick on i now get a falsh of -20 when i fist start then it says def/def
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)