Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Error 0030 Things to check?
#1
I have a 0030 Error. Prior to getting the error I was getting prints that were not round, layers shifted, and after a bit the nozzle would just move over like it was lost.
Any ideas of things to check?
I checked the wires going to the X axis motor and optical sensor, as well as the wires on the mainboard. Still no luck.
Running stock firmware 1.1J
Reply
#2
I think When I got an 0030 error, I just rebooted the machine. Something about the home sensor not reading properly. Reboot fixed it. But I'm assuming you've tried that.
Reply
#3
yea, many times
Reply
#4
Error 0030 stands for: X axis motor failed result moving failed or X axis home sensor failed results home detect failed.

cheers
Reply
#5
Cracked Bearing holder or belt miss aliment might cause it too. When I just got my printer without fixing the cracked bearing holder ( didn't know at that time) . I use tape to extend the trigger pin so it can do homing before motor hit the wall.
Reply
#6
Bearing holders aren't cracked, and if I pull the sled all the way forward the belts aren't miss aligned.
I also swapped sensors and still the issue remains.
Reply
#7
noticed that every time at boot up the X axis shifts to the left.... almost like it thinks the sensor is closed. Even though I swapped sensors, might be a wire.
Reply
#8
Turns out I have a bad wire to the stepper motor (blue one) and a bad wire to the sensor. Tested each wire with a meter. Ran jumpers to bypass them and 0030 solved. Now I am getting a 0014... so I put the original heater cartridge back in and that went away.
Now I am having a problem with the filament feeding. The stepper motor just goes back and forth. Upgraded the firmware to see if that had anything to do with it.. nope.
Guess I will check the wires for that now. I'm getting to know this thing really well now.. lol

I have had an open ticket with XYZ. They want me to send the machine to CA for repair. I am like... really for a wire. So far no luck trying to get a new harness from them.
Reply
#9
Just keeps getting better. Looks like 2 motor drivers went south. Figuring I had nothing to lose I tried some I had. They are smaller, but soldered jumpers and gave it a shot. They work.
All Axis working, heaters heating, filament feeding........ just calibrating now[Image: IMG_62951.jpg]
Reply
#10
Success

All is working. Now to put it all back together.
Reply
#11
Wes,
Same problem here. Which two Steppers went bad? I have spares of the smaller ones. How did you attach them?
Reply
#12
I checked all wires to the X and Y motors. They Ohm'd just fine. I swapped the Driver boards around to see if another mother would experience an issue (and thus indicate the board as an issue) but despite switching boards around, the problem remained in the Error 30 and then when I got that cleared by restarting, the X carriage would exceed the print base and basically "print" off the bed.
HELP!
Reply
#13
Sorry, I don't get on here much. Check the wires going to the limit switch. I had one that failed as well. The X axis are red wires. All the wires on the top right side that move seem to be issues (at least in mine)
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)