Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
New repetier install - no filament extrusion during print
#1
I've just successfully installed repetier firmware on my Duo 2.0 & host software on my Windows 8.1 machine.
So far everything seems to work well, save for the printing itself.
Extruder #1 does not extrude filament during the print. It seems like the feeder stepper does not move during the print.
However, using the manual tab i was able to easily bring the extruders to temp (220C) and extrude from both. So there is no jam, and evidently the communication is there to the extruders.

Anyone have an idea? I'd sure love to print something today.

One more question regarding levelling. I think I'd rather manually level, and not use the auto level functions. I will use a paper or feeler gauge to determine correct distance from the bed once the Z axis is in the proper height.
My question is how to ensure the Z axis is at the printing height? I'd rather not start a print and turn off the printer to do this as some have suggested.

Thanks in advance
Reply
#2
check in your GCODE if extruder is selected that is common issue I saw - need to add more starting code according what you want to print - slicer are not always good and "forget" to select the good one but just take the "default selected" extruder


What FW do you use ?
Reply
#3
Repetier 0.91 firmware.
Repetier Host 1.0.6

If that's the case, would the 2nd extruder extrude filament when the 1st is printing?
I'll check the gcode and hope I can see something there.

I did try to print with both extruders btw, and behaved the same (no plastic).
Reply
#4
ok sorry from which repository come from your FW ?

Yes check your GCODE as if work manualy, same command are send, so be sure T0 is used for extruder 1, and T1 for extruder 2,
depending of which fw you use 1 is left , 2 is right, or they can be upside down 2 is left , 1 is right
Reply
#5
I believe I downloaded this one (BGM 370) : https://github.com/bgm370/Repetier-Firmw...E/Repetier
Is there a more favourable branch?

I looked into the slic3r gcode, and compared it with a gcode dual-colour sample from the xyz sdcard. The xyz version showed 'T0' and 'T1' indicating when it switches extruders I presume.
I could not find any 'T?' parameters in my slic3r generated code. I'd be guessing that may be (one of) the problem(s). Do I need to manually put this into each slice? Seems odd since I have both extruders configured in repetier & slicer.

I am inclined to try again with the addition of this command, I am however hesitant since the extuders mash themselves into the bed. I need to properly level the bed.
Can anyone answer me how to have thez axis move to the position they will start the print at? some g code? or on the printer itself?

thanks!
Reply
#6
I believe I downloaded this one (BGM 370) Are you sure ? this one support only Davinci 1.0 and 1 extruder
You have a 2.0 right ?
Reply
#7
Nope, I was wrong. I am using the best one, found here:
github.com/luc-github/Repetier-Firmware/tree/davinci
Reply
#8
So I confirm both extruders work, the left one is E1 and the right one is E2 -
FYI latest version of my FW has helper function for manual leveling which drive you with instructions

About GCODE cura has some macros to help to select correct extruder in custom start code, but still need to modify - for slicer I think need to do the initial selection by yourself or it just take the default one. these are some I modified for cura to give you idea - I do not use Slic3r, so cannot help
; Default start code
T0
G28 ; Home extruder
G1 Z15 F{Z_TRAVEL_SPEED}
M107 ; Turn off fan
G90 ; Absolute positioning
M82 ; Extruder in absolute mode
{IF_BED}M190 S{BED}
; Activate all used extruder
{IF_EXT0}M104 T0 S{TEMP0}
{IF_EXT1}M104 T1 S{TEMP1}
{IF_EXT2}M104 T2 S{TEMP2}
G92 E0 ; Reset extruder position
; Wait for all used extruders to reach temperature
{IF_EXT0}M109 T0 S{TEMP0}
{IF_EXT1}M109 T1 S{TEMP1}
{IF_EXT2}M109 T2 S{TEMP1}
M100
{IF_EXT1}T1
{IF_EXT0}T0


; Default end code
M107 ; Turn off fan
; Disable all extruder
G91 ; Relative positioning
{IF_EXT0}T0
{IF_EXT0}G1 E-1 ; Reduce filament pressure
M104 T0 S0
{IF_EXT1}T1
{IF_EXT1}G1 E-1 ; Reduce filament pressure
M104 T1 S0
{IF_EXT2}T2
{IF_EXT2}G1 E-1 ; Reduce filament pressure
M104 T2 S0
Reply
#9
Ok, Cura engine it is for me then.
I'll try manual levelling tomorrow, then print with my Cura-sliced gcode.

Wish me luck!
LUC, many thanks for your (expeditious) help.
Reply
#10
I don't see any menus for manual levelling. I see an option for AUTO, but pressing the button does nothing when selecting this.
Unless you added manual leveling in the past few days, I'm at a loss to find it anywhere on the LCD menu.
Can you please point me in the correct direction?
Reply
#11
I have added bed leveling on 10/30, about autoleveling please check https://github.com/luc-github/Repetier-F...stallation
your eeproom is not up to date with positions for leveling they are for sure at 0.0 so won't move

additionally manual bed leveling on advanced mode not on easy mode
Reply
#12
I'm really having a hard time with this.
I see my version was older than Oct 30, so I updated it. I made the mistake of forgetting to change the 'DAVINCI' setting to '3'. The manual leveling was available, and did allow me to choose it.
However, after recompiling with the proper settings, again the auto,manual modes do not allow to be selected. I also noticed the extuders cant be heated using the manual mode within Repetier, whereas yesterday they worked fine. X,Y and Z are controllable however.

I'm not sure what you mean by :"your eeproom is not up to date with positions for leveling they are for sure at 0.0 so won't move"
I've attached my EEPROM file if you havent yet lost patience with me :-(
Reply
#13
did you do what is written :
Once flash is done do not forget to use M502 then M500 from repetier or got select printer menu "Settings/Load Fail-Safe" and accept to save in eeprom to have correct eeprom settings.
Reply
#14
yes, i did both multiple times. doesnt seem the eeprom settings change from how i set them.
Reply
#15
well it load settings from FW itself so settings change for correct ones
what is your eeprom file ? you did not put in previous message
Reply
#16
hopefully it work this time.


https://forum.voltivo.com/images/DirksEEPROM.zip
Reply
#17
you need to zip it if not nothing is accepted on this forum
Reply
#18
its attached to the above msg. seems it worked this time.
Reply
#19
I have checked your export it is fine - I have applied also on my printer it launch the process for auto level : ask for clean nozzle then heat extruder/bed then when hot move to positions, etc...
Reply
#20
even on manual leveling selection nothing move ?
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)