Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Another bricked da Vinci 1.0 ?
#1
This morning I accidently (stupidly) upgraded the firmware on my da Vinci to 1.2.3 .
Tonight I decided that I would go back to version 1.1.J .
I followed the procedure that fr333n3rgy provided in the New firmware 1.2.3 thread.
It was all going well but once I did the short the jumper bit, I lost all communication with the printer. Before that it was on COM13 but now it just shows up as Unknown Device in Device Manager. It also has the 2 black bars on the LCD. (BTW is this normal? What's normally on the LCD after an erase?) My desktop is running Win 7. I've tried to load some bossa drivers but I'm not sure if they installed properly. I'm still waiting for an email from Amtel for a link to Studio 6.

I also tried an old XP laptop and when I plugged in the printer it wanted to download a driver. I let it search and eventually it found a bossa driver and the port opened up as COM3. So I transferred the bossac.exe and .bin file to the laptop and tried the command and it returned "No device found on COM3". The bossa port had disappeared and Device Manager showed Unknown Device. Again nothing I tried could bring it back.

I've had this printer for 3 days and it came with J version firmware. Could XYZ have changed something so the jumper would brick the printer?

Any suggestions would be appreciated.
Reply
#2
2 black bars on the LCD are normal after erasing as no more fw on arduino board
for the unknown driver, install arduino ide https://forum.voltivo.com/showthread.php?tid=8156 it will install the due drivers and allow you to flash properly
Once flash back to stock fw you may need to reinstall XYZ software or pickup drivers in xyz directory if you have usb unknown device again
Reply
#3
Thanks luc,
I had installed arduino ide 1.5.8 on the desktop when I started this procedure (I already had an older arduino ide installed). I didn't have the latest ide on the laptop, so as you suggested, I have installed the latest ide and got the same result, Unknown Device and no com port showing.
I had a thought it might be a cable problem as I am running a 5m usb cable to the printer. I put the laptop on the printer and used the 1.8m cable that came with the da Vinci. Now the laptop recognises the printer on COM3 as a Bossa Serial Port. But the bossac program still gives the "No device found on COM3" message. I finally got a download link from Amtel and loaded SAM-BA to see if the SAM-BA drivers might help, they didn't.

So note - cable length makes a difference.

I am now downloading Amtel Studio 6 , another link from Amtel arrived. I'll try it later as it is very late.

I'm open to any other suggestions, thanks.
Reply
#4
Update -
Loaded the Amtel Studio 6, rebooted the laptop, still no progress.
Sees printer as Bossa port on COM3, but bossac says there is no device on COM3.
Reply
#5
is arduino IDE seeing the com3 ?
Reply
#6
The arduino ide displays a lot of COM ports. If I select COM3 and try to use terminal monitor I get a whole bunch of errors. Basically it's saying it can't find COM3. I've attached the error log. Same thing happens if I select Programming Port instead Native USB Port.
Windows (XP) sees the printer as COM3 but nothing else can see/use it. https://forum.voltivo.com/images/error.txt
Reply
#7
it find the com 3 but cannot open it , so it may be busy - check if another application is using like repetier - if you cannot find just restart you computer - it seems the port is busy in some way
Reply
#8
Fixed it.
Thanks luc.
I had done several reboots already. So I tried doing a boot without any extra services or startup programs using msconfig.
I tried the arduino ide->tools->serial monitor and there were no errors.
I ran bossac with the command " bossac -p COM3 -i " and the processor information came up.
Then tried the firmware upload, all good.
I now have a working da Vinci with J firmware.

Many thanks to luc, it really helps when you can get suggestions and help from someone. It also allows you think things out.
Reply
#9
Update - retried with the 5m usb cable, laptop would not even detect the printer. Then tried another 2m cable, the printer was detected but it took 3 tries to upload the firmware. Low quality cable, electrically noisy environment or both ? Funny thing is that I've not had any problems in using the printer with the 5m cable, maybe more error tolerant USB driver? I won't try it with the desktop and the 5m cable Smile
Reply
#10
it may be related to cable connector that have not good contact or computer connector
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)