Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Heatbed sensor requires multiple restarts to be detected.
#1
First off I want to thank everyone that has worked on repetier firmware for the Davinci. I would have been bored with this thing within weeks if I didnt have these different areas to tweak. The tweaking is turning into frustration now, as I keep having problems with Repetier detecting my heatbed sensor on my Davinci 1.0. If I raise the temp from the printer menu, it heats up and displays temp correctly. Through repetier though, the heatbed doesnt show up when I connect, and then goes into Dry Run mode when I try to print. Without changing anything at the printer, I can just power cycle the thing multiple times until Repetier sees it correctly. I got tired of messing with it last night and uploaded the firmware here: https://github.com/Doudou14/Repetier-Fir...E/Repetier. I litterally got the best PLA print Ive ever seen from this thing directly afterwards. Come home from work today excited to really give this thing a run with a more complicated file and BAM...: temp sensor defect, printer set into dry run mode until restart. I power cycled the printer multiple times to no avail. Reset and reflashed firmware again and it started working again on the first attempt.

Im admittedly new to all this and not the sharpest tool in the shed either...but I would think if this is common it would be all over these forums. Using Edouard's consolidated firmware instructions and picking the Repetier Davinci board from Audruino 1.5.8, i got the below error and changed the board type to Audruino Due (Native USB) and flashed.

:\Program Files (x86)\Arduino\hardware\arduino\sam\libraries\SPI\SPI.cpp: In member function 'void SPIClass::usingInterrupt(uint8_t)':
C:\Program Files (x86)\Arduino\hardware\arduino\sam\libraries\SPI\SPI.cpp:81:25: error: 'NUM_DIGITAL_PINS' was not declared in this scope
if (interruptNumber > NUM_DIGITAL_PINS) {
^
Error compiling.
I thought picking this board was for the watchdog function only but I could be mistaken.....Although I havent seen this error when flashing anything else, could this mean I have something wrong with my environment that keeps every firmware I load to generate a temp sensor defect? Any help is greatly appreciated.
Reply
#2
Hi

I think there must have not good contact with your temperature probe the bed
Checks the small black connector near the bed

Instead, use this firmware has more features and less bugs: https://github.com/luc-github/Repetier-Firmware
Reply
#3
Edouard, I took your advice and reset and uploaded Lucs firmware. As soon as I flashed I fired up a test print and was again very pleased with the results. Disconnected from repetier, turned off the printer and went to work. Came home from work, fired everything up and @#$!^ no heatbed again. Powercycled around 20 times until it showed up. Is it possible Im not doing something to clear out old settings or not saving new settings? Im using the jumper in the back to reset, power off, power on, fire up adruino and upload. Seems all is fine just fine until I turn it off for several hours. I have noticed that when I dump firmware from repetier, it has some of my custom settings for positions still saved, even though I can see the settings are not set to that in the adruino project. Am I missing a step? Bed issue doesnt appear to be hardware as I can reflash firmware and its back until Ive powered off for awhile. Any ideas?
Reply
#4
Do you do a M502 then M500 after flashing new fw ? It set eeprom with correct setting for the new fw
Reply
#5
Luc, well that certainly changed things for the better! Thats doing a configuration reset and a write? So that Im not a complete nuisance while Im getting up to speed, where can I learn this stuff? I thought I had read every post on this forum multiple times, and dont recall ever seeing the reference to do this.
Reply
#6
well it depend what parameters your configuration.h has when you flash a new FW
all settings are stored in eeprom and when printer is starting it load setting based on their position in memory, so just imagine what it can be load if eeprom data do not match what printer is expecting - in same spirit eeprom configuration can change from FW to FW including new version, so it is always safe to do a M502 to load default data for this fw then use a M500 to save these fresh settings to eeprom and you are sure your eeprom is clean
Only after you can do mofication using repetier or printer.
I have in my todo list to add this function in printer menu because it is source of lot of issues
Another way is to flash changing #define EEPROM_MODE 1
https://github.com/repetier/Repetier-Fir...leshooting

Not everything is on this forum about repetier FW as a lot is also on repetier documentation it self- if you want to know check also their wiki and documentation it is what I do.
Also be noted that seetings are stored in a virtual eeprom which is actually a binary file on SD Card - I hope it clarify your comprehension
Reply
#7
Luc, I really appreciate all the work that's gone into this and you taking the time to explain things to me. Now I understand why I was getting such strange behavior and why my settings and slic3r gcode weren't matching up with other users posts. I had been trying different firmwares without resetting the configuration. After a reset everything works as I expected and I'm not having to do fuzzy math to get things to print correctly. I'll read up on repetier documention before I dive any deeper. Thank you!
Reply
#8
You are welcome - we all learn from each othersSmile
Enjoy your 3D printing
Reply
#9
17:37:47.324 : heated bed: temp sensor defect
17:37:47.330 : ErrorTonguerinter set into dry run mode until restart!
Back again today, if the printer is powered off for any period of time this shows up no matter what I do. Think Im done with this thing.
Reply
#10
you mean just switch off printer after a reflash (+ M502/M500) and you have this issue or do you need to print ?
Reply
#11
I can flash, then issue M502/M500, and everything is fine until I turn the printer off for several hours, then i get heatbed sensor errors. I can then power cycle the thing multiple times and it will eventually register correctly. It seems to me that the thermosister needs to detect temp before it will be recognized. Today I tested this theory, when I got the sensor error I unscrewed the theromosister and screwed it back in, power cycled the printer, the display shows "def" for the heatbed temp where the extruder shows an actual temp ( iknow this means it will fail when repetier connects). I removed the thermosister again, this time rubbing it in between my fingers to generate a little heat, power cycled and this time heatbed temp displayed 22 degrees and repetier shows I have a heatbed when I connect. At least I know a workaround now, still doesnt make any sense to me.
Reply
#12
yes I do not see the relationship with fresh flash and the bed temperature detection...

When it fail you still can connect repetier and check what temperature is detected in status bar - it will not display error but the temperature
usualy if sensor is unplug temperature is -20, it could be interresting to see waht is the value
if warm the sensor is a work arround I guess sensor has some issue to give a good response time when cold
may I suggest 2 tests :
1 - to turn on printer and even error is present wait 5 to 10 min printer on, do not power off or restart, then restart to see if it is working
2 - another way to warm the sensor is to use hair dryer on bed, this is to be sure it is temperature warming that is the workaround and not an false contact or another kind of weird problem

Please let us know
Reply
#13
Ok, this has nothing to do with custom firmware from what I can tell, and Im not willing to go back to stock to test the theory. If a mod could move this post to user to user support, Im fine with that.

Printed non stop all weekend, just left the printer on but did power cycle it several times with no issues. Turned it off last night, turned it on this morning and.... heatbed: temp sensor defect. The printer display also showed "def" as the bed temp when I turned it on. Repetier displays 21.3 C/Off when I connect. Disconnected repetier and waited 15 mins. Same error but after a printer power cycle, it now shows 20c for the heatbed temp on the display. Repetier still displays 21.3/Off when I connect, but works fine when I send a print and then starts displaying bed temps. Not too sure what all of this means, but Im at least happy I just have to exercise a little patience versus removing and heating up the bed thermosister every morning.
Reply
#14
May I suggest to change
#define MIN_DEFECT_TEMPERATURE -10
to #define MIN_DEFECT_TEMPERATURE -100

in your configuration.h, your printer won't go to dry run if there is an issue and you can see directly on printer how long it take to get correct temperature on sensor

be careful as then no more control if something happen because sensor is not checked
Reply
#15
Luc, Again I really appreciate your feedback through this, Im learning a ton. Im a little apprehensive about changing that value in firmware, basically disabling the check....unless the check doesnt offer any real value or protection, then I wouldnt have any issue changing it. Here is something you may find interesting. Today when I got home I immediately turned the printer on and "def" showed for the heatbed temp where the extruder showed 21. I could not perform any heat operations, warming the bed, unloading/loading filament...etc. This is without repetier connected. I then took a small butane torch and hit the spot of the bed where the thermosister is, for a split second where it felt slightly warm to the touch. Turned the printer off and immediately back on, heatbed temp now registered! Still I dont know what this means exactly but I now also have an impatient solution as well!
Reply
#16
when temperature detector is found (cf temp
Reply
#17
Luc, since you are interested, Ill change to MIN_DEFECT_TEMPERATURE -100 tonight and report back in the morning. Im a little nervous that Im going to screw something up and have to start all over again, since its a minor miracle Ive been able to get this far with my total lack of experience with 3d printers. You have been helping me a great deal, so I will do what I can to bring closure to this issue.
Reply
#18
it won't damage your printer if you do not try to heat when sensor is defectiv
just change it for test purpose as you mention, then rollback to previous setting when you want to use printer for printing
also as they are same fw - no need to M502/M500 to save your time

Because you also mentioned just reflash FW is also solving the problem I guess the "warm up" time is less than a flashing fw time - and I am wondering if this delay is really due defective sensor or another component like capacitor if stock fw is ok.
Reply
#19
Luc, here are the results of this mornings test with MIN_DEFECT_TEMPERATURE -100. This is without repetier connected.
- Power On -20
- 1.5 mins -17
- 2.5 mins -15
- 3.5 mins, pretty sure I heard stepper deactivate
- 5 mins -12
- 7 mins -9
- 10.5 mins -7
- 12.5 mins -4
- 14 mins -1
- 16 mins alternating between -1/+1
- 17.5 mins +1
Reply
#20
wow sensor is very slow to warm up - I guess it is definitly not normal behaviour
I think stock Fw should raise error because even after 17.5min temperature is not correct
I am not an hardware guy but I suspect soon or later the sensor will be dead

I suggest you to put back the MIN_DEFECT_TEMPERATURE -10 for safety and do a manual bed warming as you do
Doing a work around in FW : like when power up, heat bed 10s just to warm bed sensor a little, then switch off heating bed, then launch sensor checking could be a solution but not sure it will always work
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)