Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XYZWare Open Mod
I'm another "new to 3d printing, want to start hacking" member. I have read through the entire post and gotten the open mod installed and have gotten files to slice. I have edited my en.XML file to use the provided definitions, but I'm not sure that it has taken. I still get L_Slicing_EXT type text in all of my readouts, which I could live with if I could just PRINT.

Unfortunately I also have the "program stalls after attempting to print", and eventually times out with the following problem signature.

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: xyz.exe
Problem Signature 02: 1.1.29.43
Problem Signature 03: 54822138
Problem Signature 04: mscorlib
Problem Signature 05: 4.0.30319.18444
Problem Signature 06: 52717edc
Problem Signature 07: 348
Problem Signature 08: d
Problem Signature 09: System.ArgumentNullException
OS Version: 6.1.7601.2.1.0.768.3
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Any help that could be provided would be greatly appreciated. I have a roll of NinjaFlex that is just dying to get into my DaVinci.
Reply
Hi,
I think my problem might be that I fid not repkace the en.xml file. How can I get a copy of the actual en.sml file without having to cut n past from the post?

Thanks,

John
Reply
Hi,
; just to say I am having the same problem en.sml file crashes every time.

Quote:I get an error reading en.xml file every time i open xyz open mod. Also cant get to print am i missing somthing it slices good and manual controlls work good but you hit print then it slices and never sends file to printer.
Reply
Dual XYZ Da Vinic 2.0 printer says it has "System Version 2.0J"
Firmware should be the latest for the Dual XYZ
Conputer is a DELL 64 bit
OS is Win 7

The XYZ Mod (2nd version) prints fine except the scale is off and only uses one print head

Please let me know if thereis any new updates.
Also where is the program for "Reset Cartridge"
Reply
Hi , it is my modified version base on official 1.1.30.9 , but this not too many features
only direct read gcode file and support Dual XYZ Da Vinic 2.0 printer
you can try it (put on the XYZware directory and execute XYZPlus.exe)

https://drive.google.com/file/d/0B-957gU...sp=sharing
Reply
Mostly, the problem will happen with the nonsupporting version of the machine also. We can't exactly figure out the problem where it will be happening.





Fuji Xerox printer servicing
Reply
Quote:H guys! I have a da vinci 1.0 AiO with stock firmware 1.1.1 and i can't get any connection between XYZWareOpenMod and the printer. Tried bot XYZOpenMod v1 and v2 (replacing the exe of XYZware-1.1.29.4) but still nothing. Can somebody help me? Thank you

Hello all! Yet another new member, also quite new to the 3D printing, but as I see, you guys have done tremendous work with rendering the XYZ software usable (instead of idiot-oriented spyware) and you have my sincerest regards!

Down to my issue unfortunately, I've gone and bought the 1.0 AiO Da Vinci and I just can't get the openXYZ to send the gcode to the printer - I gat the same error as did the 2.0 owners with the first program release - printer mismatch...

Everything else works great, slic3r imports, shows and renders great (at least visually) and all looks perfect if I could just send the commands to the printer at the end...

Since the AiO is essentially a 1.0 with a scanner, I was really hoping there shouldn't be any issues printing, but it seems I was wrong...
My sincerest request to the dev team, could you please review what could be the mismatch between 1.0 and the 1.0AiO, so I can finally put my otherwise great printer to producing usable prints, rather than odd-shaped filing tools... Smile

I kindly thank you in advance!
Reply
Is there going to be a MAC version for XYZWare version 1.1.29.4?
Reply
First off, this program is great. I can't even express how much I enjoy using different slicers instead of stock XYZware, prints come out so much better and I can print faster. It's just amazing.

But has anybody tried using Craftware with Open Mod? I can use Cura and the built in Slic3r just fine but when I import a Craftware gcode it always sends the object the back right corner (nearest to the extruder's home). I have set the bed size to 200x200 in Craftware and set the origin to the center but I still can't get it to work properly.
Reply
Did anyone grab a copy of the source code when it was posted? The link is now dead so if someone could repost it somewhere that would be greatly appreciated.
Reply
Here you go!
https://drive.google.com/file/d/0BxseCjt...sp=sharing
Reply
Thanks but I meant the source code he wrote before it was compiled. I know its a long shot...
Reply
Hello everyone, I am new to 3d printing my self.
I have the open mod working with the 1.29 xyz open mod with slic3r set up and importing gcode.
The problem I am having is when I try to print it says "Printer Mismatch please check printer settings."

I have gone over it may times now with no luck

Thanks for your time!
Reply
Hi Guys this is my first attempt at hacking the xyz software, i get the program up and running i have slicer working it generates the g-code i can see it in the g-code box but when i go to print it comes up with the same as Johnny garder get's printer mismatch when i go into printers it dosen't show da vinci printer it shows Cartesian printer, rock stock cicular print area, CNC router but no da vinci is it supposed to show da vinci, also in the slic3r section it is all set to simple mode and i can't change it to anything else such as abs etc. look like a great program and my thanks to 34 for taking the time to do it now if i could just get it to work.
I just noticed in the firmware setting's box it only has repetier/teacup/makerware(makerbot)mach3/linx cnc/no etrusion and nothing about da vinci.


Many thanks for any and all help
Reply
Ok so i pulled in some help and what we came up with is the openmod will not work on the newer machines with
serial # starting with 3f10A there is some kind of hand shake going on with the print file which i can't see if someone had access to a usb analizer this would make it possible to see what the file needs to send to the printer before it will accept the file.
So anyone trying to run the openmod software having the same problems i had this is your answer for now anyway.
Reply
Hi All

I have resisted the urge to flash a new firmware on my Da Vinci 1.0 for fear of bricking it. So I tried XYZware open mod and may have effectively done this anyway.

I was printing in the usual way using software 1.3X (cant quite remember but was a lower number than the latest software on XYZ's website) and firmware 1.2.3. I installed xyzware open mod and everything seemed to work I could slice and my settings in Slic3r were mirrored in xyzware open mod. That is to say if i changed my settings in Slic3r they would show up in the xyzware open mod. According to this thread this was a sign that it was installed properly. However it would not print and the manual controls would not work. It would slice but nothing would be sent to the printer. I have attempted all fixes in this thread I run the program as administrator, manually connected in xyz open mod, blocked xyzware using windows firewall, checked my serial number, installed the version 1.29 of the software as suggested etc etc. XYZware open mod would indicate for example that if i pushed a button it was heating the extruder but ultimately it was not. Having scoured the internet nothing would seem to work. I see others are experiencing similar problems. The printer itself was also showing as a device in control panel.

I had understood the XYZware open mod to be software so if it did not work out then i could reinstall stock software and print as I always have. This was opposed to firmware where it has to be flashed and thought was the riskier option. As it didn't work i uninstalled open mod deleted any remnants in my C: drive of XYZware and reinstalled the latest version of the software from XYZ's website including new drivers. The software again seems to slice using XYZ's default slicer but nothing happens with the physical printing. In windows device manager there are three references to the Da Vinci one ports, one printing queues and the other printer itself. They are all showing as working properly but in the notes at the bottom of the box there are weird comments using the words "null". There are other numbers which are non-nonsensical to me. I will perhaps upload screenshots later. However I am starting to wonder if XYZ has detected i have tried to use alternative software and has stopped my printer from working. Perhaps the firewall wasn't effective or perhaps i am just paranoid.

Any help in either getting XYZware open mod to work or back to stock and printing would be appreciated. I presume flashing a new firmware would fix this and would appreciate comments if it actually would. This would probably be my last resort. I do not feel comfortable jumping the pins at this stage. Any help is appreciated.
Reply
if i read your post correctly you did not flash the firmware as at this time if you have a 3f 10A machine it won't work, what i did was to rename everything so i could just go back and forth as i tried diferent thing's but to no avail. as this point what i would recommend would be to go into device manager and delete the da vinci printers you see there remove them also uninstall all the software shut the computer down not a restart wait for a few minutes and then restart the computer before you do anything check and make sure everything is gone or uninstalled again this is based on the fact you did not flash the FW, if you do find anything repeat what i stated above if you didn't find anything then just do a complete install of the xyz software and it should come back to life. good luck
Reply
Thanks heaps that was helpful. Got stock XYZware to work.. Deleting the driver store may have helped but not entirely sure ( http://www.thingiverse.com/groups/da-vinci/topic:1865 ).

Still want to get open mod going if I can. Everything seems to work but no physical movement in the printer Sad. It says all the right things but still no movement.
Reply
Faddyano
Great you at least got the printer going again, well i have made post and tried everything i can find to make open mod work so far no joy let me know if you find something.
Reply
Hello w34,

I am a fan of the modifications that you have made to the XYZware software to make it more usable. However when i tried to download the 1.02 Version of software the link that was posted is now dead.

Would it be possible to get a link to that software as it may solve some of the issues i am having right now?

Thank you in advance.
Reply


Forum Jump:


Users browsing this thread: 4 Guest(s)