Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XYZWare Open Mod
Has anyone figured out the format of the DAVEEW commad to edit the catridge's eeprom without an external tool? XYZware doesn't seem to use the command so there isn't a format go off of. Anyway ill get back to figuring it out. Then we can add the feature to xyz open mod. Used a jtag in swd mode to read the micro's ram as data serial info gets sent and received. Stopped because I need to solder the connector, as I am holding pins to the unpopulated jtag connector. Any other suggestions?
Reply
XYZMod1.1 attempt
.stl file selected (that works fine in normal XYZ software)
produces error and won't print
What can I do?

Once again where the files are located on my system can't be used by MOD?



Huh[Image: Stl_error.jpg]
Reply
I've got a hopefully dumb question. I can import a .stl, slice with slicer, the Gcode gets imported, then what? I hit the 'print' that the stock XYZ software uses & XYZ open mod crashes. (windows reports that it stopped working). my screen looks as above. the .stl & the gcode change the model view as the gcode adds support. so I know that is working. Just how do you actually print? Do I have a bug or am I just not seeing how to use the printer?

I've tried both J & E firmware
fresh install of 1.1.29.4 - test print on J firmware wasn't good quality & the slicer made crappy tool paths. lots of travelling back & forth across the model, so I went back to E, didn't re-test.
copied xyz.exe into folder
changed en.xml
set up slicer settings - not sure how good the settings are, but tried to copy them from what I've seen here.
Reply
Sorry if this is already posted somewhere.
Once i press print the XYZ Open Mod crashes resulting in not being able to send prints at all to the Da vinci.

Am i doing something wrong?
The mod works great untill i actually want to print something.

I'm using 1.1J and 1.1.29 with open mod.
I hope there is a easy fix available?
Reply
I am having a few problems. I am running 1.1.J and with open mod 1.0.1, Cant print a thing without it crashing. Hit print and it crashes. With 1.0 I can print anything as long its not 30MB's or more worth of gcode. I have tried different slicers, longer items with simpler forms like a large cube that sends tot he printer fine but if the gcode is 30MB's or more then the mod just crashes. I have tried cura, simplify3d and slic3r all with the same problem.

Edit, I ended up trying an i7 laptop rather than an i3 NUC and the power difference managed to get the object sent to the printer but as previously states, the new version does not work.
Reply
I just can't get this mod to print. I load it up, it slices great but it never sends anything to the printer. It also crashes any time I try to load a gcode or 3w file thats bigger than a small simple object. I'm running 1.1 J firmware and the latest Open Mod, but no luck in getting it to the printer. I did try doing an export from open mod to gcode, then base64 encoded reloaded stock XYZWare and loaded it into there. From there I was able to send it to the printer, but all the printer did was move the bed up, and center the nozzle then just sat there. Any help?
Reply
Thank you W34 for this great rebuild. Do you have any updates regarding the added support of the Duo system? Let us know if there is anything we can do to help! It would be great to have the source more available if you can manage.

Many Thanks and keep up the great work.
Reply
I have been watching this thread to see if anyone answers the posts about software crashing when trying to print. Then I see someone post how well it works. I am having the crash problem as well has anyone found a fix? Lately I've just fixed the GCode and made a 3W file then loaded back in with stock XYXWare and I'm able to print. Not ideal. I'd rather just open with XYZWare Open Mod and print from there.

Anyone? Multiple people have posted what is happening above.
Reply
I will take a look at the bugs.

Also source for Open Mod is now available to download at [url=https://filetea.me/t1spR8lJvYXQUa8xNT3H7F4aA[/url]. Due to my time others will probably have more time to fix bugs and add new features than myself. Enjoy!
Reply
I while ago I started running the program (First version) in XP compatibility mode and crashing has almost stopped. I haven't tried with the new version but in theory if it helped with one version, it might help with the newer version.
Reply
I get an error reading en.xml file every time i open xyz open mod. Also cant get to print am i missing somthing it slices good and manual controlls work good but you hit print then it slices and never sends file to printer.
Reply
this is the error i get when trying to print and xyz crashes.
Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: xyz.exe
Problem Signature 02: 1.1.29.43
Problem Signature 03: 54822138
Problem Signature 04: mscorlib
Problem Signature 05: 4.0.30319.18444
Problem Signature 06: 52717edc
Problem Signature 07: ea1
Problem Signature 08: 5a
Problem Signature 09: System.FormatException
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=1...cid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
Reply
stuart i could use some help with this i have skype
Reply
I'm having the same problem with it crashing when hitting the print button. I'm happy to try any troubleshooting steps.
Reply
:ohmy:

So I was printing just fine until today. I actually printed a file perfectly then went to print the second one and got the crash. I have done everything from reinstalling xyzware and replacing all the code and .exe file. My firmware has not changed and I disconnect my laptop before I print every time.
Reply
Just tried to use Version v1.01. It worked great until I tried to print. Hit the print button in the XYZware window as on the v1.0 and then it crashes. I tried a few times and the result was the same. I then remembered I hadn't updated the firewall (deny network access) for the new xyz.exe, did that, still crashes.

Went back to v1.0 and printing works.

Another small bug that I have found with both versions. If I manually connect to the printer, when I run the external slicer I get slic3r popping up with the defaults changed to my Open Mod settings but no object loaded. I can then add the stl into slic3r "again" and carry on, but I lose the object in the xyzware window. The gcode and the tool path are loaded and displayed. This will happen even if I disconnect from the printer before slicing.
If I don't connect to the printer then the slicing happens in the command line and I never see the slic3r window.
Restarting Open Mod fixes the problem, so long as I don't connect to the printer. I can live with the bugs as Open Mod makes the da Vinci so much more versatile.

Kudos to w34 on the work he's done with Open Mod. It works brilliantly and gives me so many more options than the plain XYZware, even using the XYZ slicer. Especially since I can view and edit the g-code (mainly play with temperatures) and look at each layer. I'm just getting slic3r going and should be producing better prints. Thanks w34.
Reply
where can I get v1.0?
Reply
I too would like to know where I can get my hands on version 1.

Got this all set up today and it's working great until I print. Just got my 3d printer last week and looking forward to using the benefits of this software!

If the developer is still sniffing around this thread, well done sir...well done!!!
Reply
I tried version 1, which works fine for me printing wise.

Someone else had a link in the thread. Re-posting for those that can't find it:
[url=http://www.mediafire.com/download/6l19csmc378bift/xyzwareopenmodv1.rar[/url]
Reply
That got me going. Thanks Ben!
Reply


Forum Jump:


Users browsing this thread: 5 Guest(s)