Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
No movment on X,Y,or Z in RH
#1
I have put repetier firmware on my machine a few times going back and forth with the factory FW. Now when I upload the bin with either xyzware or by compiling with arduino I can't use the manual movements in repetier host. The home buttons work fine but not the increments Dpads. I can see the z axis change on the printers screen but with no movement. Not sure what I missed this time that was different from the rest. Thanks for your help.
Reply
#2
I'm assuming that I'm the first to have this issue?No ideas?
Reply
#3
I had the same exact issue. I had to revert back to the stock firmware
Reply
#4
I'm just gonna keep posting stuff to keep this going til someone answers. If we missed something obvious feel free to say whatever you want. I just want to get away from the factory crapware and preferably to my raspberry pi with octoprint.
Reply
#5
Still no possible answers on this?
Reply
#6
Please confirm, does the printer work with the oem firmware? If so, try erasing the chip with the buttons on the board before you upload repetier.

Keep us posted.

Kieth
Reply
#7
Thank you Keith for your time,
Yes it does work on the OEM firmware. I have tried to use the reset pins and then flash with the same bossac command that I used with the factory firmware, only using the repetier bin. Maybe I have some bad bin's, is there a sticky thread somewhere that always has an up to date firmware with the latest common tweaks? I found many links in a bunch of places on here and not sure which one is current.
Reply
#8
When this happened to me I fixed the problem by changing the Baudrate in the Printer settings connection menu. It should be set to 230400.
Reply
#9
My baudrate already set properly. I even compiled from source and still same issue. Swapping back to factory firmware restores normal operation. This is driving me crazy. I had it working good before on repetier so I know its possible but even using the same bin I end up with the same issue. At one point I did accidentally update to the latest factory firmware, is it possible that xyz broke the 3rd party firmware?
Reply
#10
it may be value in eeprom if same bin was working before
did you tried to launch an M502 command to load default eeprom values ?
Reply
#11
That seemed to have worked. Haven't tried to print anything but I can move the print head around again using the directional keys in repetier host so I believe everything is good. Thank you for the help.
Reply
#12
Good ,
do not forget do a M500 after doing the M502 to save back the values to eeprom, M502 just load in memory
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)