Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
RepetierHost/ Repetier on Da Vinci Printer Only Single Steps
#1
I have seen no one else mention this issue, so if I'm a dunderhead, feel free to tell me so-

I have been struggling for a month or more to read through all the forum information to get the printer jail broken and configured. Last night I finally was able to get the printer to step through a sliced print of a 0.5 inch on a side cube, but I had to press the manual command some thousands of times to see the printer single-step through the whole print. It made a descent print, so I'm getting close with the setup, I just need it to work autonomously.

RepetierHost can't normally read the temperatures off the bed or extruder for some reason, and I suspect this is why RepetierHost doesn't autonomously control the printer. There were a few times this past weekend where RepetierHost would indicate the print bed temperature and the extruder temperature, but that was only after sending MANY M109's and M190's.

I am trying to understand what parameters I have wrong and where they are that is preventing normal operation. I am using RepetierHost 1.01 on a Fedora20 Linux box, with the Repetier firmware 0.91 from BGM's site (with the pinout file suggested), and compiled with Arduino 1.5.7. I modified the X, Y, & Z offsets as recommended on this forum.

The print appears to be centered roughly around 100,100.

I am sure I have one or more configuration parameters a little out of whack. I could sure use some assistance pointing me in right direction. Please let me know what information you would like to know about my printer configuration, and I'll be happy to reply.

Best regards,
Shane
Reply
#2
Hi
I made a topic that gives you my setting, you can try to compare them with your settings Smile

https://forum.voltivo.com/showthread.php?tid=8068
Reply
#3
Edouard,

Thank you so much for your kind directions! I have entered them into my RepetierHost and Slic3r settings. One question: How to get the embedded portion of Slic3r to reference the configuration file I just saved? The configuration doesn't appear in the Slic3d file I am attempting to send to the printer.

Many thanks and best regards,
Shane
Reply
#4
You configure slic3r in Repetier Host?
Otherwise it's normal that it does not work
Reply
#5
SOLVED!!!

I am using Linux Fedora 20, and I have found the following set up works to get the Repetier-Host and Repetier Firmware on the DaVinci 1.0 working well together. Here is my printer communication configuration that is working for me:

PORT: /dev/serila/by-id/usb-Arduino LLC Aduino Due-if00
BAUD RATE: 230400
TRANSFER PROTOCOL: Repetier Protocol
RESET ON CONNECT: DTR toggle
RESET ON EMERGENCY: Send emergency command and reconnect
RECEIVE CACHE SIZE: 202
USE PING-PONG COMMUNICATION (SEND ONLY AFTER OK): CHECKED.

I hope this helps anyone else wishing to work with the DaVinci through Linux using Repetier-Host.

Thank you, Edouard, I appreceiate your guidance in getting my system up to speed!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)