Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Z Probing
#1
Ok so I just took the plunge and installed REP on my Davinci. Can someone walk me through on how to set up Z probing so I can get the auto bed leveling please? Im a complete newb so if you can make it as dumb as possible that would be great. lol

I copied all my settings from here : https://forum.voltivo.com/showthread.php?tid=8068

Thank you
Reply
#2
Auto leveling seems to work fine for me, although I've read here that some have problems or don't like it.
Here's the procedure I've been using:
First, send a G28 to home everything. Turn the printer off. Get a rough calibration by cranking the bed screws so that when you move the extruder manually over the bed, you can "just" slide a piece of paper under the nozzle at the 3 adjustment points. Move the nozzle off the bed. Now raise the bed about one turn or so on the screws. The main reason for this is because if you don't, the auto level calibration frequently fails because the probe may or may not touch the metal corners on the bed properly.
Because of the way the z probe works on this machine, a typical setting for "Z probe Height" is 0.000. You can fine-tune the first layer thickness by changing this value. Setting it to 0.1000 or more will make the first layer thicker.
Turn the printer back on and connect Rep Host.
Now, heat up the bed and extruder, and THEN clean the z probe with the wire brush. I've found that it won't really clean when it's cold, as it usually has a coating of plastic residue that doesn't want to come off. The probe and metal frame MUST be clean for this to work. You can tell if it's not clean by the way it behaves when it does the probe. It all must be hot for calibration, as the bed will usually bend a bit when it's hot.
Now, you can send an G28 command to home the extruder and bed. THEN lower the bed about 1 CM by the manual arrows so that the extruder doesn't crash into the bed (remember you cranked up the bed one turn a bit earlier). VERY IMPORTANT!
Issue the auto bed level command G32 S2. This will start the auto calibration.
If you look at the bed values during calibration, they are typically 9.28, 9.30, 9.18, etc. Somewhere in the 9 to 9.5 range is typical of my settings.
When the auto cal is completed, then the Z home position value in the EEPROM table is typically - 0.94 or something like that. At this point you should have a proper first layer height for the nozzle, and these settings have been saved.
If you like, you "could" turn auto-leveling off, if the 3 z calibration values are close to the same, but if they are, then the z axis won't have to move much in auto-level mode anyway.
Once this is done, you should not have to calibrate again for awhile, if the first layer of your prints is right. Probably should do it again after every few prints to account for wear and flexing of parts and such.
Good Luck!
Reply
#3
I have been able to follow along NP all the way to issuing the G32 S2. I can send G28 and I can position manually just fine. Seems like I'm talking to the printer fine. But the G32 S2 does nothing...... Any thoughts?
Reply
#4
HI,

i am also having issues with the Z-probing to.

Basically i do a G28 , lower the bed 10mm and run a G32 S2 , which will be executed so far (the probe hits all 3 contacts)
but i get a Z-Home Position of -0.189 , which will end up in a nozzle crash on the bed upon a printing job , manually adjusting
this value to -0.900 works , but i am just curois why doesn't it work after the auto adjustment ?
Reply
#5
That sounds about right for z-home. Your procedure is correct.
What's your z probe height value?
Reply
#6
Z-Probe height is 0.000 , just like you advised here https://forum.voltivo.com/showthread.php?tid=8070
Reply
#7
The only way I can see for the head to hit the bed is if the actual probe height is wrong. My ACTUAL z probe measures about 0.2 mm above the nozzle tip. I don't know if there is any adjustment left on the probe screw or not. You could always increase the z probe height setting in the EEPROM to compensate and it should work just as well. Also the bed and nozzle must be at operating temp when you do the calibration, as the table warps a bit with heat. I can't think of anything else it could be. Good luck.
Reply
#8
There must be something wrong with my settings Sad
Meanwhile i have to adjust the z-home value to around -3.100 in order to avoid an extruder-bed-crash
What are the right values in RH for this printer , can somebody please post a screenshot ?
Reply
#9
Hi
For my part, I preferred to settle my bed by hand:
- I rule in EEPROM z = 0 mm home
- I heat the bed
- I let him in the home position
- I will lower with the 3 adjustment screws to make it a little below the extruder
- Then in repetier I'm down with the arrow 0.2mm
- I take the extruder by hand (note the plate is hot!) And moves it to the 4 corners of the bed (Do not go to the metal bracket of the auto setting). Then I have to succeed in passing a piece of paper folded in half or a business card too thickens without moving the bed when I pass underneath.
- Check the setting several times
- End your bed normally is set and you should not posser problem.

Caution must really heat the pan as it deforms so much. Once the cold bed, the extruder passes on, she tapped ...
Reply
#10
Here are my current settings. I basically used Keith's eeprom settings from ages ago.




[Image: eeprom_a.png][Image: eeprom_b.png]
Reply
#11
Thanks Z-probing is flawlessly working now Smile
I don't really know , but i guess i had some silly gcode stuff in slic3r's start code.

this is the way it worked for me:

remove any start g-code from the slicer of your choice unless you really know what you are doing
set your Z-Axis steps per mm to 2560
set all z-probe positions according to pcb_man settings (see above)
turn off the printer and manually level it on all 4 sides
turn on the printer and heat up the bed & the extruder
clean your z-probe and the 3 contact edges
in repetier host home the extruder with G28
lower the bed by 10mm in RH
and run a G32 S2
Reply
#12
Awesome Erfin!
Strangely enough, I upgraded Repetier Host yesterday to whatever the newest version is. ( I think it got harder to navigate, but I'll get over it).
When I used Cura as a slicer, it was WAY faster, but the nozzle clearance on the first layer was WAY too high, and nothing would stick.
Have not found out "exactly" why yet, but I notice there's a G0 in the gcode, which the printer ignores. I need to compare gcode output and see what I can find.
I noticed a gob of start code in there by default, so out it goes.
Reply
#13
I'm still stuck guys and could really use an assist. I still can't get any response from G32 S2 so I'm just trying to get it all set manually. It does not seem that hard to do.

I issue the G28 and that works fine. I then turn the printer off and level under the three screws using a piece of paper as a feeler gauge. But when I print, the Z drops about 1.8 mm before the printing starts so it has no chance of sticking

. I have played with adjusting the "Z home pos" in the EEPROM between -1 (where it started), and -3 (i.e. minus another 2 to account for the drop), but it does not seem to matter. I get the same drop in Z regardless.

Couple of things.... My EEPROM screen looks different. E.g. I don't have "Z-probe X1" and several others..... Why would this be? I went through and made all settings I could match up the same as the screen shots from pcb_man.

I looked for "Keith's eeprom settings from ages ago" mentioned earlier in this post, but could not locate that file. Can someone point me to a good/working eeprom file to try?

Please type slow, and use small words! I'm at the ragged edge of my knowledge but feel like I'm SO CLOSE!

Can I offer a bounty for a solution here? Would a bottle of scotch do the trick? I'm not kidding! I have way too many hours trying to get this going and no printer while I do.

I really don't want to revert to XYZ, but that is my next step if I can't get some help and that would really bum me out!
Reply
#14
Ok, we're going to figger this out! If you're close enough, I can pick up the scotch. Wink

First, when you do a G32 S2 after the rough calibration, does the X-Y position seem to be ok as far as hitting the test points?
Second, you can tell by watching it whether it gets good contact or not. If it does, it will reverse direction immediately after a light touch and move on to the next test point. If it doesn't get good contact, and has to "mash" the probe into the metal frame before it triggers, there is a slight time lag and flexing of the platform. This is a problem, because it throws the calibration way off.
Those Z probe X-Y values are absolutely necessary, as they tell the firmware where to probe on the platform. Enter those just as they appear.
On my printer, home Z position displays as -1.30 or so on the LCD I think. I'll have to do some checking when I get home tonite.
I notice that I get good prints with slic3r, but if I use the new Cura slicer, it puts the nozzle too high and I get no adhesion and have to abort the print. It has to be a Gcode anomaly, because the firmware stores the z probe values, so cura is using a different default starting value somehow.
You might want to double check the physical z probe adjustment and make sure it's right, also. The problem I ran into is that if you use the paper adjustment method, you are safe as far as a head crash, because the hardware z stop will trigger before the head crashes into the glass, but you can't be assured that the z probe can make good contact with the metal frame by the time the z stop is triggered; especially after the table warps with heat. That is the main source of calibration problems. That z probe setup would probably have worked better if it was a microswitch or optical flag, but if it's cleaned properly it works, and you should not need to calibrate every time you print.
Check your z home position in the EEPROM data after you do a G32 and see if it's a reasonable value. -1 to -2 mm is typical
I think I measured the thickness of the frame at 0.6mm, so your z probe must be LESS than that away from the nozzle tip to get the proper clearance. I think mine measured about 0.3mm or so away from the nozzle tip. I read somewhere on this forum that one person had a loose z probe screw and it didn't work until he cranked it down. It's a VERY cheesy way to do z probing, as the physical probe adjustment doesn't have much wiggle room. And you can't have the probe height at zero either, because the probe will hit your print and ruin it. So, you need between about 0.2 and 0.4mm on the probe to work. Fortunately the z probe height setting will allow fine tuning after calibration.
I also found that cleaning the frame probe areas with a contact cleaner helps a bit, and also cleaning the probe tip WHILE IT'S HOT. Theres just no way to clean it thoroughly when it's cold.
I'll try and post my EEPROM dump for you.
Good luck!
Reply
#15
Hello,

As I have stated before, while the z probing does work, it really is best practice to just manually adjust the bed at 3 points, 2 points on the rear sides near the touch pads and one in the center front. Due to the cleaning and other issues addressed above this just seems to be the best practical way to go about it.
Reply
#16
Quote:Couple of things.... My EEPROM screen looks different. E.g. I don't have "Z-probe X1" and several others..... Why would this be? I went through and made all settings I could match up the same as the screen shots from pcb_man.

Are you sure those settings are not there ? Try to scroll down , otherwise your eeprom settings might be broken.
Reply
#17
If your eeprom is missing some settings you might have the wrong firmware version in there. Might be one of the first versions before z-probing was enabled and working. Worth getting the newest version in there just to make sure.
Reply
#18
So sending the G32 S2 seems to do absolutely nothing. But it seems to me that I need to resolve any possible eeprom/settings issues before I do anything else. Not sure why I seem to have a different looking eeprom table and some of the entries from the above screen shots don't even show up in mine. I'm going to track down a good eeprom configuration and load that before proceeding any further.

Thank you all! I really appreciate the help! I will keep you posted!
Reply
#19
If I recall the the repetier.bin file on github does not have probing enabled so there will be no options for it in the eeprom, or if you compiled it in arduino and did not enable it there they will not be in the eeprom.
Reply
#20
Ah, things are starting to perhaps starting to become a little clearer..... I did not know that there might be differences in eeprom settings depending on the firmware installed, but that makes sense.....

I loaded "repetier-0.91-alpha-davinci10.bin". Will that work OK?

Also, let me get back to basics and rephrase my fundamental problem as I fear I'm getting wrapped around the axle with multiple issues:
First, thought I would like to get Z Probe and auto leveling working eventually, manually leveling seems like it should not be that hard, and I'm fine doing that for now since I really need to get my printer back to a usable state.

I sent G28 (home which worked fine), turned off the printer, and leveled manually leveling using a piece of paper as a feeler gauge. When I attempt to print, Z drops about 2 mm before starting to print and plastic just spooges out of the nozzle.

I have played with adjusting the "Z home pos" in the EEPROM between -1 (where it started), and -3 (i.e. minus another 2 to account for the drop), but it does not seem to matter. I get the same drop in Z regardless.

After reading all this, I thought "Z home pos" was exactly were I needed to adjust to address this, but I seem to be misunderstanding or doing something else wrong.

How do I account for and remove the ~2 mm drop in Z that occurs when I start a print?

Thanks all!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)