Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
USB Issue
#1
I have been having an unusual USB issue with the Da Vinci 1.0. I have to press print a few times before the PC "finds" the USB connected printer. I thought is was a cable problem...it isn't. I thought it might be a printer chipset/firmware problem. I don't think it is because today while uploading a sketch to my arduino red board, the IDE said the COM port was not available. I couldn't get the serial monitor to open either. Like with printing if I keep trying eventually the IDE connects and uploads and same with serial monitor. It's as though something is holding up the USB port intermittently blocking it and then releasing it. The process seems to garble info on the serial monitor too...I tried uploading the sketch from another PC and it all worked fine. Once I connected that arduino back to the original PC, it worked for a little while and then the serial printout was garbled again.

Not sure if this is the right place to ask but does anyone have any idea what is going on? I wonder if the XYZ drivers have done something?
Reply
#2
What version of Windoz are you using?
Reply
#3
windows 8. not 8.1 yet
Reply
#4
That's interesting as I've had issues with Win8 on both me laptop and desktop. This has been with both the Arduino IDE and the Da Vinci. In the end I did a full repair of the installation (win8) in both cases and all problems are now solved. My guess is there is something more sensitive in win8 when it comes to USB interfaces.
Reply
#5
i'll give that a go. I was hoping to avoid a rebuild so a repair sounds like a nice middle ground.
Reply
#6
I didn't get around to doing a win8 refresh but yesterday I updated XYZware to the latest version when it suggested it. I noticed it reinstalled the driver. Problem has gone...so far so good Smile
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)