Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Octopi Da Vinci wireless enabled
#1
Just add an adapter to get 5V from Da Vinci's power supply. The cable is same as 4-Pin Motherboard Power Extension Cable. I just recycle the parts form my old power supply and make the cable. Tested with Da Vinci's on-board 5V to power up Pi connected and print though wireless router. On the Pi install OctoPi for viewing and control. Here is link to OctoPrint/OctoPi download
[Edit] On Da Vanci you need to have Repetier Firmware installed.
5V USB power plug for powering Pi ( power only )

Pi is powered

USB cable route to inside

OctoPi running
[Image: IMG_20140611_205100.jpg][Image: IMG_20140614_172022.jpg][Image: IMG_20140614_172238.jpg][Image: IMG_20140614_171959.jpg]
Reply
#2
Can you give me a little bit more of a schematic on this? I know how to do the Raspberry Pi and how to program the RPi for wireless as well, but how to you connect it to the printer?
1. Are you just connecting the RPi USB port to the USB port on the Printer? (I assume the top USB connector as the bottom one is a little better for a Wireless Adapter I am told).
2. Are you Ethernet-ing the RPi to the network or are you plugging in a wireless USB to to RPi?
3. I did not see a power plug on your pictures running to the RPi. Are you talking about hooking the power up to the RPi from the printer's internal 5v lead and if so which connector? I could use a little more direction.
Thanks.
Reply
#3
There are 3 cables connect to Pi
(1) micro USB cable for powering Pi through the 4pin-atx-USB-A adapter.
(2) Da Vinci's USB cable, route form the side to inside printer and connect to Pi's USB port.
(3) For Ethernet I just use Ethernet cable connect Pi to delicate wireless router for printing ( running DDWRT ). You can also use wireless USB adapter. Since I am going to add USB-webcam. I just keep it wired.

Here is the J1 connector I get 5V from.
[Image: DaVinciPower.jpg]
Reply
#4
did you have to do anything special to get the Da Vinci to work with Octoprint?

Da Vinci isn't listed as a supported printer on the octoprint web site and I'm wondering if there are any special configurations required to get it to work.

Thanks!
Ken
Reply
#5
Da Vinci need to use Repetiier firmware from https://github.com/bgm370/dav10
Reply
#6
Hello,

I am trying to get octoprint to work on my repetier flashed davinci. It just wont seem to connect. I can set the comm to auto and speed to auto but it still wont connect. Same if i try the manual port and comm speed settings cloning what i use in repetier.

Any suggestions?
Reply
#7
My Da Vinci use 250000 BPS in my repetier firmware but default speed (230400 BPS) should work too.
Your repetier should show two serial port you should select /dev/ttyACM0 for DaVinci.
If you are using octopi image make sure you finish the first booting setup ( expending SD card and some basic setting ). I did that via connect keyboard and monitor to pi and setup procedure is like regular pi. I remember if I didn't do the setup for the pi I have some error running octoprint stably.
Reply
#8
Thanks for the reply. I reformatted the sd card and did a fresh setup. I expanded the file system but did not see any other settings there that would (in my opinion) matter.

I still cannot get it to connect at either of those 2 baud rates or either comm port.

If it matters i do not have the raspi camera connected. But thats all I can think of.

EDIT:

Heres the terminal log for trying to connect

Changing monitoring state from 'Offline' to 'Opening serial port'
Connecting to: /dev/ttyACM0
Connected to: Serial(port='/dev/ttyACM0', baudrate=230400, bytesize=8, parity='N', stopbits=1, timeout=2.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from 'Opening serial port' to 'Connecting'
Recv: Wait
Recv: Wait
Recv: Wait
Recv: Wait
Recv: Wait
Recv: Wait
Changing monitoring state from 'Connecting' to 'Closed'
Connection closed, closing down monitor
Reply
#9
Quote:Changing monitoring state from 'Opening serial port' to 'Connecting'
Recv: Wait
Recv: Wait
Connection closed, closing down monitor

Once you have receive wait that means it is connected to right serial port.
Set it to /dev/ttyACM0, baudrate=230400. ( stick to this setting )
Select Save connection settings and Auto-connect on server start up ( stick to this setting )
And try to reboot your pi and printer, see if it remember the setting and connected. I know I have trouble saving the setting without proper set up the SD card.
I only have problem on first time set it up. But I don't know what I did exactly, I don't think I did anything special.
I always got it connected after power on the printer and pi.
Reply
#10
Please check your Configure.h,
Here is link to another post for this issue [url=https://forum.voltivo.com/showthread.php?tid=7975[/url]

Make sure the line 262 is using "wait" not "Wait" ....
correct one
#define WAITING_IDENTIFIER "wait"

Octoprint need to got wait to start ready and start print otherwise it will disconnect the port after 5 seconds , ( that's why you always see 5 x "Wait" in the terminal log).

This should fix it. Have fun
Reply
#11
Steve

I see that you are using octopi with the repetier flashed da vinci. Can you post the config for your slicer? I have been trying to get this to work with Cura.......It's not playing nice.

Thanks

Todd
Reply
#12
Todd,
I don't use CURA as slicer with Octopi.
I use Kisslicer 1.5 beta
Here is my Kisslicer setting if you want to try


Steven https://forum.voltivo.com/images/Kisslicer.zip
Reply
#13
I'm also running mine with repetier and octopi. It's awesome. Especially the web cam integration, and remote controls.
Reply
#14
Thank you all for the great help!

i have been lurking around the forums as it made my da vinci 3d printer very satisfying to use. As i want to literally 3d print all day,
i am trying to make it work with my rasberry pi.

The only variable that is different in this case is that i am using the new "LUC" firmware with all the great bells and whistles.

I tried making sure the "wait" command was not capitalzed, but i can't figure this out for the life of me.

Help appreciated. Let me know if i need to attach any particular logs
Reply
#15
in configuration.h
#define WAITING_IDENTIFIER "wait"

it should be correct

you also can see it in repetier host in serial terminal/log window went no command is send
Reply
#16
Thanks for the Reply! Just to update, lame me resolved it by making sure to:

-Connect using the /dev/ACMO Serial Port. ( not the other port!!)

It is advised that if you don't see this port, you might want to power down your printer, turn it back on and than restart Octoprint.

-In my case, i connected using the 230400 Baud Rate.

Now, as i was still getting the Recv: Wait Error, i simply disabled / Unchecked the Wait for Start command on connect and i was in business!

now...i need to get that pesky MJPG-stream feature working in addition to makeing a mount.

Thanks forum![Image: capture1.png][Image: capture2.png]
Reply
#17
I'm a couple days away from receiving my Davinci Duo (early Christmas present) and am very interested in switching out the standard control software for the Octopi setup described in this thread, especially after reading through the limitations and weaknesses of the standard software. My plan is to do get familiar with the hardware and then start moving to the open source tools and software.

Couple questions:
- does this work with the Duo or only with the 1.0?
- does switching to the Octoprint software mean giving up any functionality or does it just add capabilities?
- is there a specific firmware version needed or does this setup essentially replace the firmware?
- can 3rd-party filaments be used with this setup or are you guys only using the XYZ carts?

Thanks in advance
Reply
#18
montressor,

Since no one else seems to have responded yet, I will jump in and give you my $0.02 on your questions.

First, I have a Duo with dual fans and I'm running the latest version of firmware that Luc has been so kind to put together with the help of others. You can get it from this site:
https://github.com/luc-github/Repetier-Firmware-0.92

To your specific questions......
- It most definitely DOES work on the Duo.
- Giving up functionality is a personal choice question. I've been using Pronterface and Repetier when I am in my shop where my printers are located. I like the ability to make tests, set up macros, etc from Pronterface - and it is my favorite for this reason. Octoprint (or Octopi if you're using a Raspberry Pi) DO work just fine. I've not gotten into the scripting part of Octoprint, but it does have that ability AND the fact that I have a camera on my Pi "watching" what's going on is a real bonus. Of course, I can have the camera watching without Octoprint, so that's a toss-up.
- I think you should focus your Duo on the version of firmware I gave the link to above. It works GREAT with the Duo.
- I most definitely am using 3rd party filament now that I can. I have a batch of XYZ filament and it will still work just fine with the new firmware, but you will be able to use PLA, or whatever else you might want and not be locked into only the XYZ brand of ABS.

Gary
Reply
#19
Gary - thanks for your response. General consensus seems to confirm my initial thinking: OctoPi adds a lot to this printer and is the way to go. To get there, looks like I need to go through the Repeater Installation - that's my biggest hurdle right now. My board is an "older" one with the P1 reset jumpers, but the left through-hole is completely open so I have nothing to close the circuit with. I'm a little leery of soldering the board so I tried a couple workarounds - I'm on a Mac and have been digging through the XYZware software, calculating SHA256 checksums and editing plists to get the software to accept the Repeater bin file as a valid firmware file but no luck so far, always get the "invalid firmware" error.

At this point, I'm going to try and get a hold of an older version of XYZware for Mac - I read some folks say that may let me get around the invalid firmware issue. Otherwise, I'll pull the motherboard out and solder in some headers, hopefully without releasing any magic smoke.
Reply
#20
with these http://xyzware.linzh.tw/beta/fw/ (take any of these)
no need jumper to flash from stock - just replace FW with the one you want to use (https://forum.voltivo.com/showthread.php?tid=7966
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)