Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
XYZWare 1.1.29.4 modified to load g-code
#1
Please see the XYZware Open Mod. All features here have been included in my other mod.
[url=https://forum.voltivo.com/showthread.php?tid=8132[/url]

W34

[strike]I had some free time to make some changes to XYZWare 1.1.29.4 for Windows to make it easier loading various slicer g-codes. You WILL NOT need to add the XYZ Header information in this modification. You just straight out import your generated g-code from slic3r, kisslicer, simplify3d, or other.

What changes have been made
- Load g-code files (*.gcode)
- No need to do base64 conversion
- No need for XYZ headers when loading .gcode files
- Real-time import adjustments to Simplify3D gcode to run more smoothly on the DaVinci. (There are other optimizations I am making for Simplify3D g-code and if there is enough interest I may upload).
- This version is set as 1.1.29.41

Other than that there are no other changes where added/removed from the software.

Usage, rename the old xyz.exe and copy this file into the folder.

http://www.mediafire.com/download/u1iqq9...p1/XYZ.zip

Enjoy,
w34[/strike]
Reply
#2
Thanks for this great work.

added to XYZ software repository.

https://forum.voltivo.com/showthread.php?tid=7966
Reply
#3
Interesting, and awesome,

May I ask how and where you acquired the source to do this?

Kieth
Reply
#4
Used a decompiler on the xyz.exe file. Big Grin
Reply
#5
I tried that but it wouldn't recompile. Mind telling more?

Kieth
Reply
#6
Ah okay.

Here are the steps I did to get it to compile.
Copy all the dll's from the XYZ folder to the decompiled folder\xyz\bin
Reference these dll's, as the one's that are referenced in the solution will have a reference error.

Most the the highlighted errors can be resolved by right-clicking -> Resolve -> selecting the corresponding library.

All "Colors" definitions must be changed to "GLNK.OpenGL.Colors"

Remove all constructors from function/class definitions "*"

On color assignments remove the "*()" around them.

Those were the changes I made to get it to compile.

Edit: Kieth I can send you the link to what I have.
Reply
#7
The download link doesn't work. Any way to get an updated DL link?
Reply
#8
Uploaded again

http://www.mediafire.com/download/2wsec4...7z/XYZ.zip
Reply
#9
Any chance on some mac development?
Reply
#10
Just started my first print with the mod. I used Slic3r, then uploaded the g-code to XYZ. When I went to print, it does not show how much filament or a couple of other info thats usually there. Is this due to the mod, or the use of Slic3r?

Also, this does not negate the fact I still need the chip mod for the filament, correct?
Reply
#11
Not at the moment. When I get some time I will try running it through mono and see if it compiles. If it does I will post it up. Otherwise it may be some time, if at all, before a work on the Mac version. I will may upload the source once I finish up what I am doing with it so someone else can work on a mac port.
Reply
#12
It is due to slic3r. The current version I am working on will pull the total length from g-code to display how much filament will be used.

You are right, you still to reset your filament cartridge. The mod was intended to make it easier to import g-code from other slicing programs easier.
Reply
#13
If I'm not mistaken (I tried it yesterday) when you move the header lines into the correct order that XYZware expects them, all the information shows up, including estimated time and filament used. At least it worked for me.
Reply
#14
XYZWare 1.1.29.42
What's New
- Export to gcode
- Log view window

http://www.mediafire.com/download/rv680w.../XYZv2.zip
Reply
#15
v1.1.29.42 revision 2
- Replaces G0 with G1 for Cura gcode files.

http://www.mediafire.com/download/j8fz62....42.v2.rar
Reply
#16
Is that the only modification to this version? If we currently don't use CURA, is there any reason to switch?

I haven't sent a G0 command to the printer--does it take G0 commands? Additionally, since G0 commands to not specify a feedrate, does yours add a feedrate to the end, or simply leave it blank (which defaults to the last feed rate commanded since Feedrate is modal)?
Reply
#17
If you are not using cura or simplify3d, there is no need to upgrade to this version.

As for G0 commands, stock firmware will simply ignore it. Same with M101, M102, M103, M227,M228,M229 and some others.
Reply
#18
Let me know if you enjoy that. Wink

Kieth
Reply
#19
Nice! Will have to check that out when I have some free time. Big Grin It looks promising and will definitely help. Thanks again for your hard work.
Reply
#20
Hi, first of all THANKS for the great work. I do have a problem though. When i load slic3r G-code into the new XYZware the printer will begin the heating process and all that just fine. but as soon as it comes to printing it wil just stay in one place above the heating bed. Am i setting up Slic3r wrong? please help me out, Im all new to the 3d printing seen Smile.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)