Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier X/Y/Z Axis Stepping - calibration
#1
I have been looking over the Repetier firmware and see that z axis steps per mm is set to 2600. If this is using 16 micostepping shouldn't it be 2560 steps per mm?

200*16=3200
3200/1.25=2560

The threaded rod in my machine is M8 x 1.25. If the motors are 1.8' and are using 16 microstepping it would be 3200 steps per turn of the screw. 1.25mm per turn would give you 2560 steps per turn of the z screw.

If I am right this would mess up the layer height.
Reply
#2
Bret4 - I think you're right.
Extruder steps are also a bit off. I've been trying to calbrate some things, and for extrusion, I have to use a multiplier of 0.76. Now this gets me acceptable results, but ideally the steps should be dialled into the firmware.

Maybe a new thread should be started to get correct steps for all the motors in the printer?
Reply
#3
Have you reached a consensus with regard to the appropriate firmware values for the extruder?
Reply
#4
The extruder Calibration values will be different on each extruder. I have a Da Vinci 2.0 with two extruders and I needed to set one to 97.09 and the other to 99.0. Here are the calibration instructions I used.


#1 use a ruler to measure 15 cm from the top of the extruder tool head and use a marker to mark your filament. It doesn't matter if your ruler has a few millimeters of blank space before the actual measurement marks start.

#2 use Repetier host to extruder 100 mm of filament.

#3 Use your mark on the filament to measure the actual distance the filament moved. You want to measure the difference away from the 15 cm mark. So if your mark is at the 6 cm line then the filament moved 9 cm. 15-6=9.

#4 If your mark is exactly on the 5 cm line then you are done and correctly calibrated. If not go to step 5.

#5 In Repetier Host when your printer is connected. Click the Menu at the top Config > Firmware EEPROM Configuration. Look for Extr. 1 steps per mm. Or Extr. 2 step per mm if you are calibrating the second extruder on a Da Vinci 2.0.

#6 Do this math. (100 * [Your steps per mm value]) / [Distance the filament traveled in mm] = [you new steps per mm value]
For example 100 * 96 = 9600 9600 / 90 = 106.67 You would use 106.67 as your new value.

#7 Repeat Steps 1 - 6 until you move exactly 100 mm.
Reply
#5
Oh. I forgot to mention that you can calibrate the Z steps the same way. lower the bed until you can use a ruler to measure an exact 10 cm from the bottom of the printer to the top of the bed. Then tell the bed to raise up 10 cm.

z steps per mm is 2560 on my printer just like bret4 suggested.
Reply
#6
I am not at all knowledgeable in this area but I was just doing a search on this because I was curious as to why when I lower the bed using the manual control in Repetier Host the action makes a louder whining noise than if I lower the bed using either the on board control panel or if I just push the Z Home Button in the RH manual control tab. It is a distinctly different noise and sounds much rougher than the latter. Could this be do to the stepper config? I am at 2560 steps / mm for Z and have a DaVinci 1.0 with Luc's Repetier_0.92. My other thought of why this is happening is that the max feed is set to 5 mm/s while the homing is set to 4 mm/s. Or is this the case for everyone. Thank you for any info, hopefully I can catch someone because I understand this thread is a little old.
Reply
#7
No, that noise depends entirely on the speed at which the move is performed. You may configure it in Repetier in Settings -> Printer -> Z axis feed rate.
Reply
#8
yes put 150 for Z-Axis Feed Rate in Repetier Printer Settings/Printer Tab
Reply
#9
Quote:yes put 150 for Z-Axis Feed Rate in Repetier Printer Settings/Printer Tab

Thank you Luc, I appreciate it once again you have offered an answer to me and it really is appreciated. Im going to give this a shot right now.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)