Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Did I brick my printer?
#1
I did something dumb. I couldn't get the repetier firmware to load on my printer. I watched a video online where someone shorted the JP1 jumpers and turned the printer on. I did that thinking that was needed to clear the memory and now I can't upload the firmware to the printer. It reads it as a bossa on com port 11. Does anyone know easy step by step instructions on how to get it back up and running? I'm using windows 7.
Reply
#2
Well,

How were you trying to do the upload?

Were you trying to do it with arduino IDE, or with repetier firmware?

If you were using arduino IDE(only reason to jumper the pins) did you also copy and replace the variant.cpp as described here
https://github.com/bgm370/dav10

If you just want to upload the .BIN file with bossa then It is some dos based command line stuff. Moving the firmware and bossa executable to c:\ I used
bossac -p com19 -R -e -w -v -b 3DP01_20140310_FW_V1.1.G_RELEASE.bin

you will need to change the firmware name to the one you use and the com to the one it is showing.
Reply
#3
When I got my printer the other day I loaded the xyz software. It asked me to update my firmware to version J. So I did and it worked fine. Then I read that version seemed to be a better version so I used downloaded version G and uploaded that to my printer using the off line method.

After all thar I didn't care much for the xyz software so I tried to use the xyz software to change the firmware to repetier. It would not work no matter what I did. So that is when I turned off the printer and shorted the jumper and turned it back on. Now I took the jumper off and tried to upload the repetier firmware to the printer with arduino.

I understand enough about arduino to make some changes and flash printers but I do not know a lot about it. When you say to copy the variant are saying I need to put that in repetier? Then it should let it work?
Reply
#4
I just used the batch file method and got it back to version G. Now I want to try and get it on Repetier. At least it works now. Thanks for that. So I really want to get repetier so I can have some fun making changes. If I want to upload firmware what is the best way from where I am now? Should I use repetier and add the variant file to it? Do I have to short the pins when I do that to clear the memory?
Reply
#5
Just put variant into the repetier files and compiled it. It gives me a massage

HAL.h:228: error: 'TimeTick_Configure' was not declared in this scope
Reply
#6
variant.cpp - replaces hardware/arduino/sam/variants/arduino_due_x/variant.cpp, adds pins 100-126

That is a copy and paste from the github page. It goes into the audruino ide's folder and replaces the one found at the above described spot.

I would guess you also updated the xyzware software installed on the PC?

OK so as it sits, the 3 choices are to reflash with bossa as described earlier. Bossa is found in the arduino IDE folder somewhere, I don't recall where.
this is actually 2 of the choices cause you can reflash to stock firmware .BIN or to the alpha .bin on the github.

Or replace the variant.cpp in the arduino IDE as described above and on the github and compile the sketch and reflash.
Reply
#7
See my reply made before your other replies.

Easiest is to uninstall xyzware, install older version and upload the precompiled bin using xyzware firmware update.
Reply
#8
I got repetier up and running using the batch file the same way as loading the xyz G version firmware. Had to clear the memory again before it would take the firmware with the batch file. Just leveled the bed and I'm ready to try printing. Thanks so much for your help. Now I can use simplify3d to make my Gcode!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)