Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Repetier firmware and bed center
#1
So I've recompiled and reflashed with the following settings in my configuration.h file:

Code:
// ################# XYZ movements ###################

#define X_ENABLE_ON 0
#define Y_ENABLE_ON 0
#define Z_ENABLE_ON 0
#define DISABLE_X 0
#define DISABLE_Y 0
#define DISABLE_Z 0
#define DISABLE_E 0
#define INVERT_X_DIR 1
#define INVERT_Y_DIR 0
#define INVERT_Z_DIR 1
#define X_HOME_DIR -1
#define Y_HOME_DIR -1
#define Z_HOME_DIR -1
#define X_MAX_LENGTH 237
#define Y_MAX_LENGTH 217
#define Z_MAX_LENGTH 200
#define X_MIN_POS -29
#define Y_MIN_POS -15
#define Z_MIN_POS 0

However the printer still shows X and Y as 0 when the extruder is over the dump zone. I've even erased the firmware with the jumper before reflashing.

What am I missing?
Reply
#2
the eeprom config settings
Reply
#3
I have my EEPROM_MODE set to 2 so the eeprom.bin should be rewritten every time the printer is reflashed.
Reply
#4
did you verify this in the eeprom config menu after connection?
Reply
#5
No, I didn't. Interesting...Since it's a SoftEEPROM I could see a situation where it doesn't act exactly like EEPROM_MODE would normally, nor would a jumper erase affect it.

I'm out-and-about but I'll check it as soon as I get back.
Reply
#6
OK, that was the issue. I ran an M205 and the X, Y, and Z were still set at 0,0,0 in the SDEEPROM. I deleted eeprom.bin, recompiled and uploaded and now the values match those in my configuration.h.

Thanks Josh!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)