Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
X axis issue
I can't reproduce the problem because I'm printing right now... so I can't tell you specifically what commands or conditions cause the problems.

I've noticed three interesting anomalies so far:

1) The x-axis cannot move in the negative direction (toward home), but it can move in the positive direction (away from home).
2) The x-axis seems to "scale down" the commands. So if I say jog 10 mm, I can hear it step twice. If I say jog 100, I can hear a little stepping but it never actually moves. So maybe its's not stepping at all.... I don't know.
3) Combinations of (1) and (2)

Later I'll try to reproduce the problems so I can at least give you more details about what I'm doing to cause them.
So this problem has not gone away for me. Although it is intermittent, I finally realized that it was occurring during my prints, not just during manual control through Repetier. I've uploaded a video showing the problem. Any ideas? I'm hoping that this isn't a major hardware failure. The video shows a screen capture of me using repetier host, along with video of the printer response.
When the problem happens can you control X/Y both directions from the lcd/buttons? If not, its a firmware or hardware problem. If you can control it, then the problem is communication with the computer, maybe try a shorter USB, different version of rep host, etc.

A few other ideas:
Reload the stock firmware and see if you ever notice the problem.
Download the firmware again, recompile , and reinstall on the chance it somehow was a corrupt download.

If it happens with both firmwares then I lean towards it being a hardware issue.

*IF* its hardware it is most likely a problem in the stepper driver. Could be just a bad connection, poor solder, etc. It doesnt appear it would take much to swap the stepper driver from X to Y Y to X to see if the problem moves axis... Doing so would def narrow it to the stepper.

I saw in the video your X axis is -31... I think that is your printer Xmin value in Reptetier Host. Reepetier Host has software limits that will prevent you from moving .
I think some miss-stepping in your X ( or never do X home after the startup ) will cause it.
I'm thinking the x stepper is faulty

1) I reloaded the firmware, however the problem persisted suggesting it was not a bad compile.
2) I used the windows host, however the problem persisted.
3) I swapped the x and y A4988 carriers, however the problem persisted suggesting that it was not a result of the stepper controller malfunctioning.

**4) I swapped the power cables for the x and y steppers. Thus, the manual control for x actually moved the y stepper, and the manual control for y now moved the x stepper. The y stepper (operating off the original x circuit) functioned properly, but the x stepper (operating off of the original y circuit) showed the same problems, suggesting the problem is isolated to the x stepper. I have noticed that this usually only occurs after several minutes of use. I'm going to take off the stepper and check it out.
Anybody know a good replacement motor?

The tag on the motor lists the following:

NO. T13y29-01
Minebea Co., Ltd.
Made in Thailand

I'm measuring a total length (from end of shaft) of about 52 mm (about 16mm of shaft), and a width of about 42mm on each side.
I'm thinking something like these:

I don't know if I can get the pulley off my old motor though.
Quote:Anybody know a good replacement motor?

The tag on the motor lists the following:

NO. T13y29-01
Minebea Co., Ltd.
Made in Thailand

I'm measuring a total length (from end of shaft) of about 52 mm (about 16mm of shaft), and a width of about 42mm on each side.

Below is a link to the data sheet:
So I got a new stepper and timing pulley on the x-axis. It moves, but it appears that at the standard 80 steps/mm the x-axis is not moving the correct distances. The motor is 1.8 degrees per step and the pulley is an aluminum 20 tooth GT2. The x-axis belt is a 2mm wide 2mm pitch belt. Could it be an incompatibility with the stock drivers?
I also just noticed that the replacement motor is rated at 24V. Is that a problem?
Printing a test cube with the new stepper installed using 95 steps/mm. So far looks good. The new motor is much quieter than the old one
So after all this I finally see what's happening (thought maybe it's a new problem all together):

When I rapid the x-axis, the z-axis moves. Not ever time, just every once in a while.
I just discovered a similar problem with mine. There is something faulty with the wiring for the X axis. When the wiring is pulled tight because the tool head is near the front of the printer. Something happens with the wires and my x stepper does strange things. Sometimes it will change directions extremely fast. So a movement of 10 mm will not go any where. It will just vibrate back and forth. Sometimes it seems to just move in the wrong direction. Sometimes it will just do nothing. I have not seen it move the wrong axis though.
In my case I have just tried to move where the wires are located. Seems to have fixed the problem. We will see how it goes long term.

To avoid breaking the thread of the X axis, I designed this circuit:
This saves a lot of stress at the wire.
You must remove some of the printer. I advise you to print parts in good quality that they slide well
I'm having the same issue. Issue 0030 the motor will move left but not right. All the sensors can be triggered, and it will occasionally work 1/10 times. While I was on repetier I couldn't get the x-axis to move right. I swapped the controllers and still the same issue.

Will these work as replacements? The stepper seems to have the same dimensions and connector. I'm still under warranty as the printer is only 2 weeks old but I would like a backup in case xyzprinting customer service falls through.

Nema 17 1.8 Degree
20 Tooth GT2
Do you have an oscope or logic analyzer? I'd be willing to be that your x-axis limit switch has faulty wiring, or some other problem that is causing the controller to think the x-carriage has closed the limit switch. On my printer, I disabled the steppers and manually moved the print ahead through it's full range of motion by pushing it with my hand. At the same time, I had a probe hooked up to the signal pin for the x-axis limit siwtch. In certain positions I could see the signal flicker on/off even though the carriage was nowhere close to its end stop. I eventually traced it to a fatigued wire.
You're right. I swapped the x and y sensor wires and it moves to the right now. All the sensors were good, but no continuity on one of the x-axis wires... Thanks for the help! Lets see if I have any luck getting a stock replacement wire now from customer service :S

Forum Jump:

Users browsing this thread: 2 Guest(s)